Some tips on vf34 install and sti pinks
+ Reply to Thread
Results 1 to 7 of 7

This is a discussion on Some tips on vf34 install and sti pinks within the Engine Performance forums, part of the Tutorials & DIY category; well yesterday me and my buddy ryan put my vf34 turbo and pink injectors on. The turbo wasnt that bad ...

  1. #1
    Registered User flabele's Avatar
    Join Date
    Jun 2005
    Location
    New Jersey
    Posts
    815

    Some tips on vf34 install and sti pinks

    well yesterday me and my buddy ryan put my vf34 turbo and pink injectors on. The turbo wasnt that bad at all. just a little tricky lowering it down while making sure the hoses went in at the same time. the injectors were a pita. this one bolt on the passenger side green bracket took for ever. u cant get a wrench in there really. i actually put the wrench on the bolt and had to pry it up with a piece of wood on the block. keep at it and you will get it. the bracket on the other side didnt have that bolt so it was easier. once you get the brackets out the injectors are pretty easy to put in. Just watch you dont lose the little rubber washers that sit under them. one of mine rolled under the car.Once uget everything back together there is something very important u must do. my car almost overheated because of this. your gonna have to put almost a whole gallon of collant back in the little black resevoir. I bled the bubbles out by sqeezing on the radiator hose. squeeze then fill. over and over again untill the collant stops going down and the bubbles stop coming up. then when u take it out watch the temp. should be a little less then in the middle on your gauge. Dont forget to check ur oil too. When i changed my base map i was running rough. So i reset the ecu ( negative on the batterey ) And then i did the vishnu reset. And then vrooooooom!!!!! Nice and fast. If anybody needs any tips feel free to ask me. later...gotta go drive

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Needles's Avatar
    Join Date
    Nov 2002
    Location
    Long Island N.Y.
    Posts
    305
    I can't get the GBOD out.Got all the bolts out on bothj sides now I need to get them out.Any tips.

    Stg 2 06STI
    02/04 WRX MSPT Tuned - 18g(DEAD)

    "Never go in against a Sicilian when death is on the line!"-Vizzini

  4. #3
    Registered User flabele's Avatar
    Join Date
    Jun 2005
    Location
    New Jersey
    Posts
    815
    Quote Originally Posted by Needles
    I can't get the GBOD out.Got all the bolts out on bothj sides now I need to get them out.Any tips.
    Well I took the air filter out. The big box and tube part. ANd youll have to remove the little black collant resevoir too. On the driver side take the windshield wiper fluid container out. Its just a clip on the bottom and a hose. Easy to remove and helps alot.. Good luck man. If u run into any problems give a shout...ive heard of some people taking out the air condition hoses. I didnt want to mess with them. ( i was scared freon would come out haha ) well i didnt have to take them out anyways . I just wiggled it around till it came out. Oh i left the passenger side GBOD out. i dont think u ned it it. HOwever the one on the driver side u need for the hose. Cause the hose actually connects to a little metal tube on it. Although if u have something to cut the little metal tube off the bracket , that would prob work../.
    Let me know how it goes.

  5. #4
    Registered User Needles's Avatar
    Join Date
    Nov 2002
    Location
    Long Island N.Y.
    Posts
    305
    Got the injectors in. Not putting the GBOD back on. I just cut the metal pipe off so I can use it. The only trouble is getting the bottom coolant hose back on. I can't get my fingers down there to put it on. How do you do it?

    Stg 2 06STI
    02/04 WRX MSPT Tuned - 18g(DEAD)

    "Never go in against a Sicilian when death is on the line!"-Vizzini

  6. #5
    Registered User flabele's Avatar
    Join Date
    Jun 2005
    Location
    New Jersey
    Posts
    815
    Quote Originally Posted by Needles
    Got the injectors in. Not putting the GBOD back on. I just cut the metal pipe off so I can use it. The only trouble is getting the bottom coolant hose back on. I can't get my fingers down there to put it on. How do you do it?
    Yeah that was a pita. I had my buddy lower it down slow as i watched from under the car with a flashlight. ONce it lines up it should slide right in. Then u can check it from under the car to make sure. Try a little wd40 if u need to. good luck.

  7. #6
    Registered User flabele's Avatar
    Join Date
    Jun 2005
    Location
    New Jersey
    Posts
    815
    Quote Originally Posted by flabele
    Yeah that was a pita. I had my buddy lower it down slow as i watched from under the car with a flashlight. ONce it lines up it should slide right in. Then u can check it from under the car to make sure. Try a little wd40 if u need to. good luck.

    PS. are u gonna use the stock wastegate hoses with the restrictor pill. I was told to do this so i did. But im not hitting target boost yet. Although it is hot as **** out side. Let me know what u do.. I was wondering if this was my problem.

  8. #7
    Registered User Needles's Avatar
    Join Date
    Nov 2002
    Location
    Long Island N.Y.
    Posts
    305
    I'll try the WD-40 tomorrow.Right now I'm done for the day The whole install is a PITA TurboX's instructions sucks a$$ . Never again. If I upgrade again I'll get someone to do it.
    Quote Originally Posted by flabele
    PS. are u gonna use the stock wastegate hoses with the restrictor pill. I was told to do this so i did. But im not hitting target boost yet. Although it is hot as **** out side. Let me know what u do.. I was wondering if this was my problem.
    Yes I used all the hoses from the stock turbo.Cobb said to use them with the AP.
    Last edited by Needles; 06-28-2005 at 05:01 PM.

    Stg 2 06STI
    02/04 WRX MSPT Tuned - 18g(DEAD)

    "Never go in against a Sicilian when death is on the line!"-Vizzini

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •