My car sounds like a 78 toyota HELP
Results 1 to 4 of 4

This is a discussion on My car sounds like a 78 toyota HELP within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; hello people i installed a borla header and hks uppipe about 15000 miles ago and everything was fine. tonight im ...

  1. #1
    Registered User 20wrx02's Avatar
    Join Date
    Oct 2002
    Location
    South East Mass
    Posts
    667

    My car sounds like a 78 toyota HELP

    hello people i installed a borla header and hks uppipe about 15000 miles ago and everything was fine.

    tonight im driving home from work i take a sharp turn and poofff

    my car sounds like an old a$$ beater.. could the uppipe came loose -- i do smell stinky exhaust coming from there -- i checked underneth and all the bolts where still there --- i also used the thick gasket replacements. for the uppipe and header..

    what happened ? ?
    it sounds like a plastic bag over the exhaust.


    how did it come loose after that many miles if its the uppipe.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Shibby's Avatar
    Join Date
    Jan 2003
    Location
    Dayton, OH
    Posts
    1,333
    Engine doesn't sound right... Any ideas?

    same thing happened to zapix, as well as me.

    listen to the clip at the end of the thread.
    --Jason-- 2004 MT WRB WRX
    Cobb Stage 2 more goodies:
    STi SS | Blitz SUS | Samco IC Hoses | Perrin Rear Sway Bar and Endlinks | Eibach's | Steel Gray Rota Downshifts | Goodyear Eagle F1 GS-D3's | Blitz DTT-DC2 | Phatty-Ass System

    "This is my WRX. There are many others like it, but this one is mine. My WRX is my best friend. It is my life. I must master my WRX as I must master my life. Without me, my WRX is useless. Without my WRX, I am useless."

  4. #3
    Registered User 20wrx02's Avatar
    Join Date
    Oct 2002
    Location
    South East Mass
    Posts
    667
    Originally posted by Shibby
    Engine doesn't sound right... Any ideas?

    same thing happened to zapix, as well as me.

    listen to the clip at the end of the thread.

    *************************************************
    I listened to the clip and thats exactly what mine sounds like .. i just hope its not anything else though..

    so was it ur uppipe that was leaking also ? ?

  5. #4
    Registered User Shibby's Avatar
    Join Date
    Jan 2003
    Location
    Dayton, OH
    Posts
    1,333
    Originally posted by 20wrx02
    *************************************************
    I listened to the clip and thats exactly what mine sounds like .. i just hope its not anything else though..

    so was it ur uppipe that was leaking also ? ?
    i dont know yet, im fixing it this weekend

    what boggles my mind is, my car sounds exactly like that clip. except, i dont have an EGT sensor, mines bungless! I have a feeling it might be my 02 sensor on the passenger side manifold. i dont remember tightening it to tight.
    --Jason-- 2004 MT WRB WRX
    Cobb Stage 2 more goodies:
    STi SS | Blitz SUS | Samco IC Hoses | Perrin Rear Sway Bar and Endlinks | Eibach's | Steel Gray Rota Downshifts | Goodyear Eagle F1 GS-D3's | Blitz DTT-DC2 | Phatty-Ass System

    "This is my WRX. There are many others like it, but this one is mine. My WRX is my best friend. It is my life. I must master my WRX as I must master my life. Without me, my WRX is useless. Without my WRX, I am useless."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •