Cant Control boost with MBC!!
Page 1 of 2 12 LastLast
Results 1 to 15 of 16

This is a discussion on Cant Control boost with MBC!! within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; Well i am driving and my boost goes crazy...it spikes all the way to .15... omg..I pull over open the ...

  1. #1
    Registered User Jack's Avatar
    Join Date
    Mar 2003
    Location
    North New Jersey, School at Susquehanna University in Pennsylvania (Rt 287, Rt 78, Rt 22, Rt 80)
    Posts
    1,070

    Cant Control boost with MBC!!

    Well i am driving and my boost goes crazy...it spikes all the way to .15...
    omg..I pull over open the hood and the hose was not connected so i put it back togehter. I test it out again and stilll i get super high boosts!!!! Could there be a leak somewhere else ...i dont understand. Any diagrams would help!

    Thanks tom
    Last edited by Jack; 01-29-2004 at 07:40 PM.
    -My name is Tom not Jack

    Check profile for mods

    "I wanted to put a bullet between the eyes of every panda that wouldn't screw to save its species" Fight Club

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Jack's Avatar
    Join Date
    Mar 2003
    Location
    North New Jersey, School at Susquehanna University in Pennsylvania (Rt 287, Rt 78, Rt 22, Rt 80)
    Posts
    1,070
    i have a turboxs mbc. After all these i set the boost to 0...thinking maybe my mbc got set wrongly. By Still i get UNCONTROLLEd boost.It spools superfast. HELP!
    -My name is Tom not Jack

    Check profile for mods

    "I wanted to put a bullet between the eyes of every panda that wouldn't screw to save its species" Fight Club

  4. #3
    Registered User AjIsDope's Avatar
    Join Date
    Aug 2002
    Location
    SoCal
    Posts
    7,759
    Did you look in this thread?

    MBC INFO [discussion, questions, guidelines].

    Recheck all your connections and make sure they are snug. Also check your boost gauge hookup and make sure it is working properly.
    03 Cobra
    566whp/515wtq

    Pics
    & Dyno
    Pics

  5. #4
    Registered User Jack's Avatar
    Join Date
    Mar 2003
    Location
    North New Jersey, School at Susquehanna University in Pennsylvania (Rt 287, Rt 78, Rt 22, Rt 80)
    Posts
    1,070
    Yea...

    I tried useing the link but my computer is way to slow to handle it, and i hoped for an ez fix. (also reason why ididnt use thesearch button) I will check the link when i am at school.

    I check the hoses all are snug...

    Is it possible there is a leak of some sort or the hose is disconnected some where i cant see. like further down..?

    I also think it may be the gauge reading wrong...

    And i am guessing .15 mpas is like 21 psi...which is not cool...its my only car so when i drove it tonight i just made sure i didnt floor it or go into boost often.
    -My name is Tom not Jack

    Check profile for mods

    "I wanted to put a bullet between the eyes of every panda that wouldn't screw to save its species" Fight Club

  6. #5
    Registered User AjIsDope's Avatar
    Join Date
    Aug 2002
    Location
    SoCal
    Posts
    7,759
    edited for misinformation
    Last edited by AjIsDope; 01-29-2004 at 08:27 PM.

  7. #6
    Registered User Mr. Fancypants's Avatar
    Join Date
    Sep 2002
    Location
    SFV, CA
    Posts
    582
    Yeah .15 mpa = 21.76 psi. Did you try taking off the MBC all together and seeing if you still get erratic boost?
    04 SVT Lightning

  8. #7
    Registered User WRXout's Avatar
    Join Date
    Dec 2003
    Location
    Houston
    Posts
    3,709
    i know this is off topic, but if my turbo timer gauge says my boost is 1.10 how much psi is that?
    Fadi....
    04' WRX, Stage 4 with fmic R.I.P
    05' WRX STI, 325whp 346wtq @17psi
    MODS
    Quote Originally Posted by Trailboss
    Enough of the bloody titties show.

  9. #8
    Registered User AjIsDope's Avatar
    Join Date
    Aug 2002
    Location
    SoCal
    Posts
    7,759

  10. #9
    Registered User WRXout's Avatar
    Join Date
    Dec 2003
    Location
    Houston
    Posts
    3,709
    thanks so i guess im running 15.6 psi and i had no controller i think thats a little to rich..maybe thats why my cars at the shop now. but do you think the boost gauge on the turbo timer is really acurate?
    Fadi....
    04' WRX, Stage 4 with fmic R.I.P
    05' WRX STI, 325whp 346wtq @17psi
    MODS
    Quote Originally Posted by Trailboss
    Enough of the bloody titties show.

  11. #10
    Registered User AjIsDope's Avatar
    Join Date
    Aug 2002
    Location
    SoCal
    Posts
    7,759
    15.5psi is just fine. That is what mine maxes out at. The limit of the stock turbo is @16.5psi. What is wrong with your car?

  12. #11
    Registered User ryland's Avatar
    Join Date
    Apr 2002
    Location
    NY
    Posts
    2,125
    I am guessing that you have it 100% backwards. Make sure that you have the correct hoses attached to turbo outlet nipple and waste gate actuator.
    2004 Black WRX Sedan

    Mods = yes

  13. #12
    Registered User WRXout's Avatar
    Join Date
    Dec 2003
    Location
    Houston
    Posts
    3,709
    my brother installed it, my car is leaking oil from the turbo and the invidia downpipe burnt the a/c hose off....and i just miss my baby
    Fadi....
    04' WRX, Stage 4 with fmic R.I.P
    05' WRX STI, 325whp 346wtq @17psi
    MODS
    Quote Originally Posted by Trailboss
    Enough of the bloody titties show.

  14. #13
    Registered User qoncept's Avatar
    Join Date
    Oct 2003
    Location
    Montgomery, AL
    Posts
    1,204
    Originally posted by ryland
    I am guessing that you have it 100% backwards. Make sure that you have the correct hoses attached to turbo outlet nipple and waste gate actuator.
    Either that, or adjusting it totally wrong. Go read the instructions better or look at a DIY on here.

  15. #14
    Banned dark_rex's Avatar
    Join Date
    Aug 2001
    Location
    The Hub
    Posts
    12,157
    Originally posted by WRXout
    i know this is off topic, but if my turbo timer gauge says my boost is 1.10 how much psi is that?
    First, DON'T HIJACK THREADS.

    second, you've been a member here for long enough to see the STICKY at the top of THIS VERY FORUM. YOU KNOW BETTER, FADI.

    dR

  16. #15

    Join Date
    Dec 2003
    Location
    Langhorne, PA
    Posts
    1,078
    Originally posted by qoncept
    Either that, or adjusting it totally wrong. Go read the instructions better or look at a DIY on here.
    FYI,

    The ball and spring is reverse thread on the TXS MBCs. Turning COUNTER CLOCKWISE increases boost same as the bleeder.

    Get a Joe P if the TXS one is too complicated for you.

    -Jim

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •