Problem...blinking check engine.
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 30

This is a discussion on Problem...blinking check engine. within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; Hey guys, I am new to WRX's so this is a little confusing. Driving in second gear around 2500rpms than ...

  1. #1
    Registered User
    Join Date
    Aug 2003
    Location
    Minneapolis
    Posts
    18

    Problem...blinking check engine.

    Hey guys, I am new to WRX's so this is a little confusing. Driving in second gear around 2500rpms than I accerate wide open to about 6200 than shift , the check engine light blinks and than the car died. it starts right up with no problem. the CE light is allready lit up beacuse of the previous mods, which I will list .....from what I have seen, not yet confirmed.
    PE 1818 turbo
    PE 650 injectors
    UTEC
    3 in turboback
    blitz intake
    blitz FMIC
    could it be a problem with the UTEC program? I have heard the car does need to tuned??
    Thanks for any help..

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User BoostedBoxer's Avatar
    Join Date
    Mar 2003
    Location
    NOR*Cal
    Posts
    6,558
    be care ful, blinking technically means the engine is doin something that will damage the cat (sky high egt, missfire etc.)
    My Car is 100% STOCK!
    Pics

    Originally posted by platano
    At 14???
    shoot , I'd hit it at current age, on roof of the car, with cousin driving , neighbor and town priest in the back seat, and that kid from "N.Korea" riding shotgun.

  4. #3
    Registered User ebr0t's Avatar
    Join Date
    Aug 2002
    Location
    U of Central Florida (Orlando)
    Posts
    15,307
    doesnt the knock censor from the utec blink the CEL?
    Quote Originally Posted by DTR rex

    Peter North > *

  5. #4
    Registered User WRC_Obsessed's Avatar
    Join Date
    Jan 2002
    Location
    Boston/NNJ
    Posts
    9,026
    Originally posted by ebr0t
    doesnt the knock censor from the utec blink the CEL?
    this is true.

    my utec flashes on startup to signal the map that i am running. it will also flash, as ebr0t says, when it detects knock and pulls timing.

    have you had the car dyno tuning? if not, you better do that today. the stage 4 map that txs provides is for the parts specified as the standard txs stage 4. what you are running is very very different than what their stage 4 is.

    getting a dyno tune should solve all problems.
    -Brian

    Twisty Monster - 335 ft/lb of torque @ 3600 rpm on a stock turbo. Is that possible? Yes it is.

  6. #5
    Registered User
    Join Date
    Aug 2003
    Location
    Minneapolis
    Posts
    18
    Well I bought the car like this, so I am not aware of the tuning thst has been done on it. The nearest awd dyno is in chicago, i'm in minneapolis so i'll have to make a trip. it also has a blitz boost controler witch has a few different settings, rigth now i'm am only running .6bar still a very fun car to drive

  7. #6
    Registered User WRC_Obsessed's Avatar
    Join Date
    Jan 2002
    Location
    Boston/NNJ
    Posts
    9,026
    well i would hope that there was some tuning that was done to the car with those mods on it.

    maybe you can ask the person who you bought it from. but i would still have it dyno tuning to make sure it is running properly.
    -Brian

    Twisty Monster - 335 ft/lb of torque @ 3600 rpm on a stock turbo. Is that possible? Yes it is.

  8. #7
    Banned dark_rex's Avatar
    Join Date
    Aug 2001
    Location
    The Hub
    Posts
    12,157
    Originally posted by WRC_Obsessed
    well i would hope that there was some tuning that was done to the car with those mods on it.

    maybe you can ask the person who you bought it from. but i would still have it dyno tuning to make sure it is running properly.
    yep, by the look of it, you're running a lot leaner, and probably detonating to high hell. get to a dyno immediately, and turn DOWN the boost!

    dR

  9. #8
    Registered User
    Join Date
    Jan 2003
    Location
    Malaysia
    Posts
    173
    Please tell us you omitted an aftermarket uppipe from your mod list.

  10. #9
    Registered User CKxx's Avatar
    Join Date
    Feb 2003
    Location
    Pennsylvania
    Posts
    2,522
    Originally posted by AlexWRX
    Please tell us you omitted an aftermarket uppipe from your mod list.
    lol to that.

    Also...is it just a stage 4 base map? The PE1818 flow way more topend then the vf30 that the base map was made for, this could be why your seeing the det in the topend of the RPM range.
    I created my avatar.

  11. #10
    Registered User
    Join Date
    Jun 2002
    Location
    Morristown, NJ
    Posts
    359
    With the UTec, it flashes when you have knock.

    If you were ont he stock ECU with no UTec or anything, the flashing means a misfire.

    Pull the code and see what it is.
    FS: 02 WRX with JDM V7 RA-C

  12. #11
    Registered User
    Join Date
    Aug 2003
    Location
    Minneapolis
    Posts
    18
    ok this car also came with a blitz boost controler, right now the boost is only at .6bar aound 9lbs. of boost. Honestly I do not know if there is a after market uppipe I am just assuming that there is , I haven't had a chance to get it up on a lift. anyone have a suggestion of where to get it tuned? somewhere close to minneapolis.

  13. #12
    Registered User
    Join Date
    Aug 2003
    Location
    Minneapolis
    Posts
    18
    OK here is something new I have found out. the car had to have a cat put on before it could be sold legally from a dealer , could this cause a blinking cel? I just wish it would drive right

  14. #13
    Registered User BlkWRXWag's Avatar
    Join Date
    Jan 2003
    Location
    Trabuco Canyon, CA
    Posts
    2,236
    If you bought it from a dealer, I would suggest you take it back to them and get them to get it tuned properly. It all sounds very fishy to me!

  15. #14
    Registered User Blue2004WRX's Avatar
    Join Date
    Jul 2003
    Location
    Syracuse NY
    Posts
    1,039
    Originally posted by BlkWRXWag
    If you bought it from a dealer, I would suggest you take it back to them and get them to get it tuned properly. It all sounds very fishy to me!
    I second that. Make the dealer responsible before they claim you caused the problem.

    -Blue
    --2004 WRB WRX--
    Still way too stock.

    Originally posted by MidnightFLAT4
    I like A/C for the sole reason that it makes the idle sound meaner.

  16. #15
    Registered User WRC_Obsessed's Avatar
    Join Date
    Jan 2002
    Location
    Boston/NNJ
    Posts
    9,026
    Originally posted by Blue2004WRX
    I second that. Make the dealer responsible before they claim you caused the problem.

    -Blue
    ya..i would be interested in what they say.

    definitely get rid of that uppipe and get a catless one.
    -Brian

    Twisty Monster - 335 ft/lb of torque @ 3600 rpm on a stock turbo. Is that possible? Yes it is.

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •