"The BIG BOV thread" (Where all bov question threads get merged) - Page 88
Page 88 of 788 FirstFirst ... 38787980818283848586878889909192939495969798138188588 ... LastLast
Results 1,306 to 1,320 of 11815

This is a discussion on "The BIG BOV thread" (Where all bov question threads get merged) within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; Yeah, I tried running the HKS SSQV 100% valve and it made the car run horrible. I have heard of ...

  1. #1306
    Registered User 2003WRX's Avatar
    Join Date
    Aug 2002
    Location
    Utah
    Posts
    583
    Yeah, I tried running the HKS SSQV 100% valve and it made the car run horrible. I have heard of alot of people running the Forge 100% ATM and not having any problems though. I personally don't understand this because the return tube is still plugged up, but thats cool... I was going to buy a Forge, but there was a thread on NASIOC where people were trying and trying to get the guys from Forge to respond as to why their valve wont cause problems and they kept side-stepping the question and just saying "valve is still on sale for christmas! It wont cause any problems!" At that point, I gave up on them. I figured if they couldnt give an explanation to backup their claims, I wasnt giving them my $. I spent almost 2 months reading posts and going back and forth on what valve to buy. I was between the GFB and HKS... I tried the HKS first and my car ran horrible with it... decreased power and loss throttle response between gears. It felt like I was towing a boat when I hit 2nd gear (but it sounded sweet). I sold the HKS after only 1 day of use and bought the GFB instead. I am very satisfied, and also it helps my paranoia of running a 100% ATM valve. lol
    2003 WRX Sedan
    2004 Nissan Xterra SE 4x4

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #1307
    Registered User 2003WRX's Avatar
    Join Date
    Aug 2002
    Location
    Utah
    Posts
    583
    I had the HKS on my car for 1 day. I trimmed a small piece of the extra long hose I needed (used it to replace the elbow shaped stock tube if I remember). I just connected that tube to the BOV and also to my T connector for the boost gauge and that was it I think. Of course, I plugged up my return tube with the metal plug and stuck the hose clamp back on it. As I've said many times (and I'm not going to rehash it yet again, lol)... my car ran terrible with the thing. It sounded cool, but d@mn... I took it off and sold it ASAP. Went with the GFB in hybrid mode instead...

    PS - The HKS came with a weird plastic connector thingy. I tried it with and without that thing and it didn't change anything in terms of the way the car ran. I had a local guy help me with the install initially who had experience with BOVs, so I'm fairly certain it was hooked up right.
    Last edited by 2003WRX; 03-16-2003 at 11:01 PM.
    2003 WRX Sedan
    2004 Nissan Xterra SE 4x4

  4. #1308
    Registered User Murchie's Avatar
    Join Date
    Mar 2003
    Location
    socal
    Posts
    901
    coool.... yeah i chopped off some of the tube and plugged it into the lil connector thing they gave and then to the stock tube then put it into the T connector.. mabye i should just try to go strait on from the hks tube to the T connector... hmm... so it fits on there well then?
    ~Mark

    Mods

  5. #1309
    Registered User Cosmo's Avatar
    Join Date
    Dec 2002
    Location
    Salem, VA
    Posts
    50
    Originally posted by 2003WRX
    I had the HKS on my car for 1 day. I trimmed a small piece of the extra long hose I needed (used it to replace the elbow shaped stock tube if I remember). I just connected that tube to the BOV and also to my T connector for the boost gauge and that was it I think. Of course, I plugged up my return tube with the metal plug and stuck the hose clamp back on it. As I've said many times (and I'm not going to rehash it yet again, lol)... my car ran terrible with the thing. It sounded cool, but d@mn... I took it off and sold it ASAP. Went with the GFB in hybrid mode instead...

    PS - The HKS came with a weird plastic connector thingy. I tried it with and without that thing and it didn't change anything in terms of the way the car ran. I had a local guy help me with the install initially who had experience with BOVs, so I'm fairly certain it was hooked up right.
    What do you mean it ran terrible? Mine runs fine.

  6. #1310
    Registered User is2scooby's Avatar
    Join Date
    Jun 2002
    Location
    Honolulu, HI
    Posts
    4,234
    Kawshon had trouble with his HKS SSQV and driveability as well...
    Aloha, Richard...
    Retired Moderator
    TXS Stage 4 UTEC + TMIC + JoeP
    12.75 @ 105.67mph - 1.74 60'

  7. #1311
    Registered User 2003WRX's Avatar
    Join Date
    Aug 2002
    Location
    Utah
    Posts
    583
    Originally posted by Cosmo
    What do you mean it ran terrible? Mine runs fine.
    I lost power, basically. The turbo wasn't staying spooled between shifts at all and when I hit 2nd gear it basically felt like I was towing something heavy. I have done alot of "research" on BOVs before I purchased and it really just seems some cars run fine with the 100% and others do not. I haven't been able to determine why exactly this is. I sold the HKS to a guy on NASIOC and he PM'd me a few days later and said his car ran fine with the thing with no adjustments, etc to how it showed up at his house which was directly off my car. It sounded great, but the difference was blatantly noticable and I wasnt will to sacrifice power. Conversely, the car actually seems to run better with the GFB. And no, I didnt go straight from the HKS to the GFB. I went stock > HKS > stock > GFB

    Anyhow, thats just my experience with the HKS. If your car runs perfectly with the thing, then thats cool...
    2003 WRX Sedan
    2004 Nissan Xterra SE 4x4

  8. #1312
    Registered User Oo DaRk StAr oO's Avatar
    Join Date
    Apr 2002
    Location
    Long Beach, CA
    Posts
    587
    I had a TXS HRFL and my car ran a little choppy at Idle. Installed the HKS SSQV and the Idle was just like new. The SSQV is an awesome BOV and I am on my 3rd for the rex. Think I found a winner.
    BRS Autodesign | Sportmax Racing | Falken Tyres | Seibon | C2 Power
    http://www.socalspyders.com/gallery/files/1/sig.jpg
    2001 Toyota MR2-S | So Cal Spyders | Car Domain Site

  9. #1313
    Registered User 2003WRX's Avatar
    Join Date
    Aug 2002
    Location
    Utah
    Posts
    583
    The HKS sounded awesome... believe me, I didn't want to get rid of it. It seems that particular valve maybe reacts better on modded cars. Mine is pretty much stock as of now until I can manage to put 5000 miles on it and bring it over to Cobb. I bought it in August and I'm only 1/2 way there. I was getting ansy and wanted to buy something...
    2003 WRX Sedan
    2004 Nissan Xterra SE 4x4

  10. #1314
    Registered User Oo DaRk StAr oO's Avatar
    Join Date
    Apr 2002
    Location
    Long Beach, CA
    Posts
    587
    BTW: I thought I was like the only person with a V2 lip
    BRS Autodesign | Sportmax Racing | Falken Tyres | Seibon | C2 Power
    http://www.socalspyders.com/gallery/files/1/sig.jpg
    2001 Toyota MR2-S | So Cal Spyders | Car Domain Site

  11. #1315
    Registered User 2003WRX's Avatar
    Join Date
    Aug 2002
    Location
    Utah
    Posts
    583
    Originally posted by Oo DaRk StAr oO
    BTW: I thought I was like the only person with a V2 lip
    eheh, the V2 lip is awesome. I slapped that on within a couple weeks of the STi wing and projectors. The V2 totally makes the car looks-wise from the front IMO.
    2003 WRX Sedan
    2004 Nissan Xterra SE 4x4

  12. #1316
    Registered User Hybrid-X's Avatar
    Join Date
    Feb 2002
    Posts
    925

    Greddy Type-S BOV question

    I just installed this bov w/ mounting hardware from enthuzacar. Everything went well, but the BOV sounds very quiet. I noticed there are two lines that need to go somewhere. The main line, I have tapped into my vacuum where my old bov went. Now there is a smaller line where I have no idea where it goes. Should I just plug it up, leave it, etc?

    Currently, I have the other line not going anywhere.

    Any info is appreciated. Thanks!

  13. #1317
    Registered User WRXin''s Avatar
    Join Date
    Jun 2002
    Location
    Houston, TX
    Posts
    8,634
    Is this BOV 100% atmosphere, 50/50, or recirc?
    Fahd

    Floats like a butterfly and stings like when I pee!

  14. #1318
    Registered User Hybrid-X's Avatar
    Join Date
    Feb 2002
    Posts
    925
    It's a 100% atmo., but has 2 nipples instead of one like most BOV's do. It doesn't seem to be blowing off. I don't think the unit is defective because it works sometimes, but is very faint. If I had a leak, where would I check. It still boosts to 14psi and doesn't taper or spike. It basically exhibits the same behavior as my stock BPV in this regard.

    It sounds weird because I'll get on it and when you're normally supposed to hear the BOV when you release the throttle, it flutters and there is a very faint whistle. I can hear the BOV better @ WOT though. Dunno what's going on. Very weird.

  15. #1319
    Registered User WRXin''s Avatar
    Join Date
    Jun 2002
    Location
    Houston, TX
    Posts
    8,634
    Did you plug the return hose that was connected to the stock BOV? If you did, then I don't know what to tell you bud. Try emailing the place you bought it from. I'm sure they can offer you some advice. Good luck
    Fahd

    Floats like a butterfly and stings like when I pee!

  16. #1320
    Registered User Hybrid-X's Avatar
    Join Date
    Feb 2002
    Posts
    925
    Yeah, I don't know what's going on either. And yes, the hose is plugged. I guess I'll check for leaks. I dunno if this has anything to do with it, but I just installed a uppipe and header last week before the bov. It's leaking a little because it has crappy gaskets, but I'm getting new ones next week. Can any of this be related?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •