"The BIG BOV thread" (Where all bov question threads get merged) - Page 315

This is a discussion on "The BIG BOV thread" (Where all bov question threads get merged) within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; turns out there is a plug in the recirculating hose. the BOV I have doesnt have a adapter to hook ...

  1. #4711
    Registered User
    Join Date
    Dec 2003
    Posts
    92
    turns out there is a plug in the recirculating hose. the BOV I have doesnt have a adapter to hook up to the hose, what is that part called? where can i get one?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #4712
    Registered User
    Join Date
    Jul 2004
    Location
    hendersonville nc
    Posts
    294
    scooby was all that beer for you? (your avatar)..you alcoholic















    that is beer right?
    04 black sti, gold rota torque, turbo xs tbe, turbo xs rfl bov, utec

    someone trade their rfl axleback for my regular turbo xs magnaflow!!!!!

  4. #4713
    Registered User Richie03's Avatar
    Join Date
    Feb 2003
    Location
    PA
    Posts
    577
    I am not sure but you might have to buy the whole unit to get that part. I would try to find a used BOV for sale witht he elbow supplied.

  5. #4714
    Registered User
    Join Date
    Jul 2004
    Location
    hendersonville nc
    Posts
    294
    ummmmm lol if its a true bov then that hose is supposed to be plugged. if its an aftermarket bypass valve then you should have an adapter. the air is going into the atmosphere instead of through that hose back to the intake. thats the whole point.

    now if your talking about your stock bypass valve not having the adapter, then i dont quite understand how it was taken off somehow??
    04 black sti, gold rota torque, turbo xs tbe, turbo xs rfl bov, utec

    someone trade their rfl axleback for my regular turbo xs magnaflow!!!!!

  6. #4715
    Registered User
    Join Date
    Dec 2003
    Posts
    92
    this is how http://www.clubwrx.net/forums/showthread.php?t=86418
    it was my mistake to buy it, next time I'll look closer at the pic.

  7. #4716
    Registered User
    Join Date
    Jul 2004
    Location
    hendersonville nc
    Posts
    294
    haha damn that might actually be a good idea. how loud was it? i have a bov already but i am interested in this ghetto bov...
    04 black sti, gold rota torque, turbo xs tbe, turbo xs rfl bov, utec

    someone trade their rfl axleback for my regular turbo xs magnaflow!!!!!

  8. #4717
    Registered User
    Join Date
    Dec 2003
    Posts
    92
    It's not that loud. When I get a complete stock BOV, I will let you have it.

  9. #4718
    Registered User XxScoobYxX's Avatar
    Join Date
    Apr 2003
    Location
    chicago
    Posts
    1,300
    Quote Originally Posted by wrxCIA
    scooby was all that beer for you? (your avatar)..you alcoholic















    that is beer right?
    hahah yes that is beer and no it wasnt all for me...

  10. #4719
    Registered User bluerex47's Avatar
    Join Date
    Jun 2004
    Location
    ohio/texas
    Posts
    2,301
    Quote Originally Posted by XxScoobYxX
    haha you guys should read peoples sigs sometimes....
    he updated it after we had the boost psi issues
    - chris
    04 wrx, 04 corvette, 66 GTO
    ACT installed at 36k...new Gears at 44k...

  11. #4720
    Registered User XxScoobYxX's Avatar
    Join Date
    Apr 2003
    Location
    chicago
    Posts
    1,300
    Quote Originally Posted by bluerex47
    he updated it after we had the boost psi issues

  12. #4721
    Registered User
    Join Date
    Sep 2004
    Location
    NYC
    Posts
    35

    Help please? BOV problem and surging

    Ok this is on 3 forums now. My ssqv stopped blowing off. I was stumped and tried many things and nothing helped. I originally thought the ssqv itself went dead, while the boost was reading full bar and vacuum was the same.

    I replaced the ssqv with a forge, and had the SAME problem, and the compressor surging at boost. I even threw the stocker back on, despite the fact that Im missing a bolt on the bov since its stripped. I took off the vaccum lines and T fitting for the boost gauge, and the forge unit blew off a bit more, but same problem.

    3 bovs, one of them being stock, are not blowing off. The only and last thing I can think of is that the vacuum hose comming from the engine is restricted somewhere. Where does this hose come from, and how do I get to it? If there is a filter this hose attaches to (crankcase or breather element?) the filter itself maybe the source of my misery. Otherwise Im lost and have no solution. I hate to pay a mechanic for something this stupid, and MSPT is booked into mid january.

    ANY IDEAS OR THOUGHTS are greatly appreciated, someone help?
    www.CVRMotorsports.com

  13. #4722
    Registered User
    Join Date
    Sep 2004
    Location
    NYC
    Posts
    35
    Anyone?
    www.CVRMotorsports.com

  14. #4723
    Registered User WRXout's Avatar
    Join Date
    Dec 2003
    Location
    Houston
    Posts
    3,709
    did you check your turbo?
    Fadi....
    04' WRX, Stage 4 with fmic R.I.P
    05' WRX STI, 325whp 346wtq @17psi
    MODS
    Quote Originally Posted by Trailboss
    Enough of the bloody titties show.

  15. #4724
    Registered User
    Join Date
    Sep 2004
    Location
    NYC
    Posts
    35
    What should I be checking it for? Im pretty limited on my knowledge to this car which isnt a help.
    www.CVRMotorsports.com

  16. #4725
    Registered User
    Join Date
    Dec 2004
    Posts
    2

    Help with BOV

    I have an HKS SSQ bov, and i put it on my 04 STi, and it does not work. So i took it apart, oiled it up, put it back on and still did not work. Then i took it apart, and I clipped the spring, put it back, and the BOV will still not open up. When I drive and let off, it flutters everytime, and is causing compressor surge. Can anybody help me, or anybody have any ideas whats wrong with it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •