"The BIG BOV thread" (Where all bov question threads get merged) - Page 262

This is a discussion on "The BIG BOV thread" (Where all bov question threads get merged) within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; Wow!! I started off with the Worx turning bov because everyone said it was just the best. Got it in ...

  1. #3916
    Registered User
    Join Date
    Jun 2004
    Location
    DE
    Posts
    441
    Wow!! I started off with the Worx turning bov because everyone said it was just the best. Got it in and really did not like it at all. Just installed my new Forge and i'm in love. My car is running alot better with it, plus the sound is just awesome. Its so quick Good game Forge. Good game!
    The Beginning is the End is the Beginning
    --
    Provehito In Altum

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #3917
    Registered User sexyrex's Avatar
    Join Date
    Feb 2003
    Location
    OCJ
    Posts
    1,292
    booo!!! i would have gotten it from you!! damn 50 bucks. what a bargain.


    what kind of exhaust do you have? frank said prodrive is a good exhaust to get?
    [SLEEPER]
    [noun] A high performance street car with an inconspicuous, stock outward appearance.

  4. #3918
    Registered User RexMobbin''s Avatar
    Join Date
    Nov 2002
    Location
    zipity here, zipity there, i'm zipity everywhere...
    Posts
    1,700
    Originally posted by jigga
    Forge Atmospheric BOV

    Used the same BOV when I had a TBXS TMIC V2 also... didn't have to adjust the BOV either when I swaped it over... No compressor stall issues of any kind.
    when i first put in my FMIC, i was running this BOV, and had major issues with stalling, fluttering. the stock worked much better, and went with APS to hold the higher boost from my new turbo. FWIW.
    i'm bombin' uppercut swipes
    as my knuckles ignite
    more strikes
    than a teachin' staff's
    fights for pay hikes

  5. #3919
    Registered User
    Join Date
    Jul 2004
    Location
    Sandy, Utah
    Posts
    17
    I'm still waiting for mine...bla. I keep hearing all these wrx's with BOV's and am getting very anxious. Good to know that you are enjoying yours
    4 Tickets in 5 months of owning it....and counting!

  6. #3920
    Registered User Smokescreen's Avatar
    Join Date
    Jan 2004
    Location
    Philly
    Posts
    248
    Recirculating means 100% air going back into your intake like the stock BOV/CBV. It feeds right back in. The tube you block goes into the intake. You can get a WORX(??) and others are adjustable. ABOVs tend to make us run rich, but I have one and have no problems so far.

    200whp 208wtq @ 11psi (old)

  7. #3921
    Registered User qoncept's Avatar
    Join Date
    Oct 2003
    Location
    Montgomery, AL
    Posts
    1,204
    Originally posted by MoonPieSTI
    I am also having trouble finding a worthy Dyno shop that works on subies around where I live... Everyone around here works on Honda/Toyota/Mazda... I live in Pensacola, FL..Its the western panhandle for those unfamiliar...I am willing to drive as far as ATL and dropping off my car to have everything put on and tuned if I have to.
    Knowledge Performance is in Atlanta and works on a lot of Subarus (apparantly). I've heard both good and bad things about them, but don't have any experience with them myself.

  8. #3922
    Registered User WRX135's Avatar
    Join Date
    Nov 2003
    Location
    NC
    Posts
    350

    Problem with TurboXS BOV.....

    Well all of a sudden friday night my BOV stopped making the pshhhhh noise. And so i got out and it was loose and i could twist it around then i lubed it up and all with some synthetic stuff, and the BOV started working again just now it spings around and i think i have a noticable boost leak...the same thing also happened to my friend about 2 weeks ago and he could just twist it around and around. Has this happened to anyone else? and also what can i do it looks like i just need to tighten the bolts but i have been doing that and then dont reach into the little groves... Its a turboXS typeh not the RFL one. Any information would help. Also my clutch is making the ticking noise when i let it out slowly and was wandering if this has happened to anyone else. It sounds like the clutch cable. I just installed whiteline springs saturday mor. and they are awesome. And i put stock gold rims on and the car is silver im going to take pics. tomm. and show you all i think it looks awesome. Any information would help though thanks!
    -02 Black WRX-
    Mods are in profile....

  9. #3923
    Registered User djrez4's Avatar
    Join Date
    Jul 2002
    Location
    Colorado
    Posts
    3,858
    If you mean the entire valve is spinning on the flange, you lost one or more of the set screws that attach it. If you look at the attachment point between the valve and the flange, there are 3 set screws that hold them together. I have two right now and it's holding ok. I'm not sure if you can find them at a regular hardware store. Try giving turboXS a call in the morning.
    Deliberating enclaves of like-minded people are often a breeding ground for extreme movements - Cass Sunstein

  10. #3924
    Registered User DarkKnight04's Avatar
    Join Date
    Mar 2004
    Location
    Charlotte, NC
    Posts
    62

    TurboXS RFL BOV Leaking?

    I currently have this BOV on my car and I noticed today driving that there was very little release of air when I shifted between gears. I could barely hear the BOV. I thought at first that a vacuum hose might have come loose, but I haven't been able to find anything. The BOV has become very quiet, and my car is only holding around 15psi (it is tuned to 19psi). I am wondering if anyone has any idea what might be the problem. Thanks for your help....
    It takes a fast car to drive in a straight line...It takes a fast driver to surpass others on the endless curvy sections of ashpalt we call "roads".

    -------------------------------

    308whp / 275wtq @ 20psi on 93 octane

    Axis Stage 2 2.5 USDM STI Block (Summer 2005)

  11. #3925
    Registered User Wrinkleboi's Avatar
    Join Date
    Jan 2002
    Location
    Langhorne, PA
    Posts
    3,331
    when my TXS BOV was leaking i could noticeably hear it. if you dont hear anything then you might have a leak somewhere else in the system. check all your hoses to make sure they are on tight.
    o-|-<) bryan

    -2003 Blue WRX, complete 2007 STi Engine/Drivetrain transplant - Pic 1 | Pic 2 | Pic 3 | Pic 4 (new!)
    -1994 Black Supra TT 6MT - Pic | Build/Restoration Thread: 67mm, Fuel, Painted Engine Bay, Fuse Box Relocation, Wire Tuck, etc.

    www.TriStateTuners.com

  12. #3926
    Registered User sexyrex's Avatar
    Join Date
    Feb 2003
    Location
    OCJ
    Posts
    1,292
    wish there was a forge bov soundclip. still deciding what to get. greddy, forge, gfb, or txs rfl. grrrr
    [SLEEPER]
    [noun] A high performance street car with an inconspicuous, stock outward appearance.

  13. #3927
    Registered User
    Join Date
    Aug 2004
    Location
    Da Beach
    Posts
    10
    Ask and you shall receive.........taken from Stratmosphere's website.

    Forge BOV

  14. #3928
    Registered User
    Join Date
    Apr 2004
    Location
    Philadelphia
    Posts
    9

    Is anyone Running a Greddy Type R Bov?

    I recently picked up a used greddy fmic and the setup came with a Type R. My problem is that I can't get this thing to vent properly or at all for that matter. I have been driving around in vacume for the past two days. I Someone told me that there was two springs inside and to take out one of them but when i opened it up lastnight there was only one spring inside. I have my factory bov vacume source going to the nipple coming off of the head of the bov.

    Please help

    -OD

  15. #3929
    Registered User DarkKnight04's Avatar
    Join Date
    Mar 2004
    Location
    Charlotte, NC
    Posts
    62
    I can't hear the BOV itself leaking, although it does seem a little lose where it attaches to the adapter plate. I may try tightening it to see if that makes a difference. Does anyone else have any other suggestions. I am going to check all the hoses in the engine today and see if any have come lose. Thanks for your help.
    It takes a fast car to drive in a straight line...It takes a fast driver to surpass others on the endless curvy sections of ashpalt we call "roads".

    -------------------------------

    308whp / 275wtq @ 20psi on 93 octane

    Axis Stage 2 2.5 USDM STI Block (Summer 2005)

  16. #3930
    Registered User WRX135's Avatar
    Join Date
    Nov 2003
    Location
    NC
    Posts
    350
    Yeah i know i am missing one also thanks for telling me... i un did it all and put everything back on and tighted everything and now its not spinning so i think thats good i just need a 3rd screw just in case. thanks.
    -02 Black WRX-
    Mods are in profile....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •