"The BIG BOV thread" (Where all bov question threads get merged) - Page 244
+ Reply to Thread

This is a discussion on "The BIG BOV thread" (Where all bov question threads get merged) within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; Thats odd. They responded to all of my orders. Even overnighted the valve for me when they found out I ...

  1. #3646
    Moderator YBNormal07's Avatar
    Join Date
    Jul 2003
    Location
    PA
    Posts
    6,245
    I Support ClubWRX
    Thats odd. They responded to all of my orders. Even overnighted the valve for me when they found out I needed it quicker for a show. Ate the cost of it even. Hmmmmm....maybe they are getting backed up?? It did take almost a month to ship my exhaust and that pretty much sucked, but I've been able to get Mike on the phone usually when I call. Go figure...
    tEh PriUs=teH faSTah!@@!
    08 Audi S5 Black Diamond edition
    SOLD: 05 SWP Legacy GT Limited 5MT, 13.3ish@105 (stage 2) crappy stock clutch
    SOLD: 04 MPS/SW WRX Sti. 12.971 @ 103.97 (stock)
    278 AWHP/283 AWT, Catback exhaust
    306 AWHP/341 AWT, Stage 2
    (Scott) Moderator-STi, Drag Racing, Car Purchasing, and Tutorial Forums

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #3647
    Registered User
    Join Date
    Oct 2003
    Location
    Chino Hills, CA
    Posts
    16
    no but that sig is .................................................. ..........................
    .................................................. .................................................. ....
    .................................................. .................................................. ....
    .................................................. .................................................. ....
    .................................................. ..................................COOL?

  4. #3648
    Registered User
    Join Date
    May 2004
    Posts
    11
    worx still has not responded to my emails.......

  5. #3649
    Registered User
    Join Date
    Jul 2004
    Location
    Texas
    Posts
    3

    TURBOSMART dual port bov

    I just bought the turbosmart dual port. I was wondering if anyone could give me any tips on setting it up. it comes preset for the regular wrx. The sti makes more boost so it leaks like hell. I already tightened it quite a bit. How do i kno when it is set just right. Should it blow off everytime i shift??? Even at low rpm's. Or should it just blow off when i get the rpms high. Right now i can rev it up in neutral say about 5k and let off and it will open up. any help is appreciated.

  6. #3650
    Registered User
    Join Date
    Jun 2004
    Location
    NY
    Posts
    84

    Accessport BOV Question

    Hey whats up I ordered my accessport 5/03/04 and i am greatly anticipating its arrival. I have a question tho i plan on running stage 2 which puts out anywheres around 16-17 psi of boost. I was wondering if people were running an aftermarket bov or the stock one? and if it were ok to frun an aftermarket setup most likely the GFB 50/50 one and not mess anything up with the programs.

    thanks alot

    jimmy

  7. #3651
    Registered User
    Join Date
    Jun 2004
    Posts
    4,016
    no real need to run a bov, but if you do...a hybrid is better than a fully atmospheric.
    Vanitas vanitatum...et omnia vanitas

  8. #3652
    Registered User Rippa's Avatar
    Join Date
    May 2003
    Posts
    92

    Greddy BOV Help!!!!

    I'm not sure what the problem may be but I don't get that signature whistle the Greddy Type-S usually gives. I have the return hose plugged. Instead of hearing the whistle after I let off, I hear nothing!! It sounds like a boost leak while boosting cause I can hear the turbo spooling like if it was a supercharger. I see on my boost gauge that it holds boost fine, But I don't have the sound. I checked for leaks and even tweaked the adjuster screw but still nothing. Anyone know what the deal is?? Any info would be greatly appreciated!!

    Thanks in advance,
    Will
    310whp / 309trq @ 19psi
    Now with 6 Flavors of JDM Goodness!!
    MODS

  9. #3653
    Registered User sd-wrx04's Avatar
    Join Date
    Jul 2003
    Location
    San Diego, CA
    Posts
    110
    Does your BOV looks like this? I would check to make sure that black hose on the bov is on there securely, check to make sure that the bolts are tighten from the flange to the the intercooler then the bov to the flange. Did you replace the gasket that connects the flange and intercooler?


  10. #3654
    Registered User Rippa's Avatar
    Join Date
    May 2003
    Posts
    92
    My BOV looks exactly like that, but the venting hole for the bov is facing the other way. Could that possibly be the problem?? What if I just turned the hole to vent out the way you have it? I made sure everything is on nice and tight. The only thing I left out was the long hose with the tee. I made the BOV fit without replacing the metal lines running parallel to the intercooler. Could that be the problem???
    310whp / 309trq @ 19psi
    Now with 6 Flavors of JDM Goodness!!
    MODS

  11. #3655
    Registered User sd-wrx04's Avatar
    Join Date
    Jul 2003
    Location
    San Diego, CA
    Posts
    110
    That could be the problem...why didn't you just use the replace hose and "T" connector? Did you get the instruction that came with the BOV? I know its in Japanese and all but there are pictures of how it's suppose to look.

    I would suggest you face the GReddy BOV like the way I had it. And see if that fixes your problem.

  12. #3656
    Registered User WRX-Z's Avatar
    Join Date
    Feb 2004
    Location
    Houston
    Posts
    166
    I'm stage 2 right now and have the GFB Hybrid set at 50/50 and runs fine. I havent had any problems.
    <<My car
    COBB Stage II --- 8.52 @ 81mph in the 1/8 mile
    Mods

  13. #3657
    Registered User wake2snow5's Avatar
    Join Date
    Jan 2004
    Location
    Ellensburg, WA
    Posts
    465
    I also have a GFB set at 50/50 with Cobb's VF34 map and I am running fine. I wouldn't go for a full atmospheric bov.

  14. #3658
    Registered User
    Join Date
    Jan 2004
    Location
    Colorado
    Posts
    293
    another GFB 50/50 user here, I first put the BOV on 100% atm and the car didnt really run too good, I wasnt planning on keeping it that way I just wanted to see how the sound was etc.. but I have since had it set to 50/50 with no problems.
    2004 WRX completely stock! And becoming even more stock daily.

  15. #3659
    Registered User
    Join Date
    Jul 2004
    Location
    Texas
    Posts
    3
    thankyou for all the replies i really appreciate it.

  16. #3660
    Registered User
    Join Date
    Sep 2001
    Location
    Edmonds, Washington
    Posts
    542
    What's wrong with the stock BOV? Your BOV should pop whenever your throttle plate closes yet not leak while on boost. You pretty much want it to pop whenever you start making positive manifold pressure to avoid compressor surge. Just so you know, stock BOVs are good in to the 18-20 psi range and aftermarket ones do NOTHING for performance if you aren't running a turbo that runs more than 18 psi.
    http://homepage.mac.com/supermarkus/PhotoAlbum1.html

    Mullet haiku:
    Daughter's BMX
    Takes me to welfare office
    Trans Am is on blocks

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •