2004 WRX Stage 2 P0037 CEL
Results 1 to 4 of 4

This is a discussion on 2004 WRX Stage 2 P0037 CEL within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; So today I have finally gone Stage 2. I have a 2004 WRX with a Cobb Short air intake, catless ...

  1. #1
    Registered User MisterNBG's Avatar
    Join Date
    Jul 2012
    Location
    PA, USA
    Posts
    268

    2004 WRX Stage 2 P0037 CEL

    So today I have finally gone Stage 2. I have a 2004 WRX with a Cobb Short air intake, catless up pipe, catless 3" turbo back and tuned with the Cobb AP v3. Now note, I have no catalytic converters in my car. Also, I didn't reconnect the o2 sensors in the up pipe or down pipe. After turning on my vehicle for the first time after the stage 2 upgrade, I got the P0037 CEL about 2 minutes into warm up idle. Now I'd like to assume this is due to the fact that I didn't reconnect the up pipe and down pipe o2 sensors, but I just wanted to make sure.

    BTW for those who don't know, P0037 CEL = HO2S Heater Control Circuit Low (Bank 1 Sensor 2)

    Thanks for the help in advanced!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User MisterNBG's Avatar
    Join Date
    Jul 2012
    Location
    PA, USA
    Posts
    268
    Anyone?

  4. #3
    Registered User Mr. DB2's Avatar
    Join Date
    Mar 2014
    Location
    Hendersonville,NC
    Posts
    23
    Re-connect your O2 sensor.
    2004 San Remo Red WRX

  5. #4
    Registered User MisterNBG's Avatar
    Join Date
    Jul 2012
    Location
    PA, USA
    Posts
    268
    Update:
    Reconnected the o2 sensors, code went away. Put 10 miles on it so far, still no codes. I'll keep the post updated if the codes come back.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •