Help guys!!!
Results 1 to 14 of 14

This is a discussion on Help guys!!! within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; I had a shop put my motor back into my '05 STI & now I have no hose feeding coolant ...

  1. #1
    Registered User
    Join Date
    May 2010
    Location
    Fayetteville, NC
    Posts
    12

    Help guys!!!

    I had a shop put my motor back into my '05 STI & now I have no hose feeding coolant to my turbo and I cannot find a source to tee into, can someone please help me locate where it should be going to????
    Re

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Bristol, CT
    Posts
    1,178
    Wait the shop never even bothered to test drive drive or anything to even make sure nothing was wrong?

    Sent from my SCH-I545 using Tapatalk

  4. #3
    Registered User
    Join Date
    May 2010
    Location
    Fayetteville, NC
    Posts
    12
    Nope, decided to push the car outside, close up shop and not even bother telling me. Just ignored my calls till I I valves an atty


    Re
    Re

  5. #4
    Registered User
    Join Date
    May 2010
    Location
    Fayetteville, NC
    Posts
    12
    Basically I'm stuck finishing her up and hoping all is well


    Re
    Re

  6. #5
    Subaru Newb MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    7,947
    I Support ClubWRX I Support ClubWRX
    Upper coolant resivoir. .

  7. #6
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Bristol, CT
    Posts
    1,178
    There should be a line from the turbo to the reservoir by the intercooler

    Sent from my SCH-I545 using Tapatalk

  8. #7
    Registered User
    Join Date
    May 2010
    Location
    Fayetteville, NC
    Posts
    12
    I have that line connected, it's the return line, I was told. The feed line is what I cannot figure out. Thx for the help.


    Re
    Re

  9. #8
    Registered User
    Join Date
    May 2010
    Location
    Fayetteville, NC
    Posts
    12
    Well I found the feed line, or lack there if. The shop removed it and stuck a temp sensor in its place for some unknown reason.


    Re
    Re

  10. #9
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Bristol, CT
    Posts
    1,178
    Lol what?? I would steer nice and clear from them

    Sent from my SCH-I545 using Tapatalk

  11. #10
    Registered User
    Join Date
    May 2010
    Location
    Fayetteville, NC
    Posts
    12
    Everyone should. I'll stay clear of any shops up in Winchester, VA


    Re
    Re

  12. #11
    Registered User WRX-maniac's Avatar
    Join Date
    Sep 2013
    Location
    Western Maryland
    Posts
    473
    Winchester huh? I go that way quite often. What was the name of the shop you went to? I used to deal with AR Fabrication down there and they were always real good to deal with. But its been years since I was there, and I now deal with IAG in Maryland.
    2011 WRB WRX hatchback---Stage 2
    Stink-Eye Mob #301
    http://www.clubwrx.net/forums/builds...ld-thread.html <----Build Thread

  13. #12
    Registered User
    Join Date
    May 2010
    Location
    Fayetteville, NC
    Posts
    12
    AR Fab/CNC Engine Dynamics is who did me this way. The owner Jason Haines is nothing but slime and those that worked for him apparently are all talk on the knowledge side. One guy there seemed to know his ****, Tommy Marple, and they fired him half way through my build and then it all went to ****.


    Re
    Re

  14. #13
    Registered User
    Join Date
    May 2010
    Location
    Fayetteville, NC
    Posts
    12
    Oh since then, Jason closed doors and rename the shop JH Engines, so avoid...


    Re
    Re

  15. #14
    Registered User WRX-maniac's Avatar
    Join Date
    Sep 2013
    Location
    Western Maryland
    Posts
    473
    Wow. Good to know. Like I said though, I havent been there in like 4 years or so. Been dealing with IAG and Agile auto since then. What a shame though, they used to be a very reputible shop.
    2011 WRB WRX hatchback---Stage 2
    Stink-Eye Mob #301
    http://www.clubwrx.net/forums/builds...ld-thread.html <----Build Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •