Check engine light, traction light on and cruise light blinking....Advice??
Page 1 of 2 12 LastLast
Results 1 to 15 of 20

This is a discussion on Check engine light, traction light on and cruise light blinking....Advice?? within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; Got a 2012 WRX with an Indivia Q300 catted downpipe and catback exhaust and Cobb SF intake with airbox. I ...

  1. #1
    Registered User SuperSonic12's Avatar
    Join Date
    Nov 2013
    Location
    Lehighton
    Posts
    72

    Check engine light, traction light on and cruise light blinking....Advice??

    Got a 2012 WRX with an Indivia Q300 catted downpipe and catback exhaust and Cobb SF intake with airbox. I have the Accessport V3 and did the Stage 2+SF 93 map and after 100 miles, the check engine light and traction control light came on along with the cruise control light blinking and all 3 came on at the same time. Also when running that map, it does not feel like the car is running correct especially when doing a 3rd gear pull around 3500 RPMs when it feels like it bogs down. Its also stalls occasionally when coming to a stop with the clutch all the way in. Any ideas or tips??

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    MAINEiac 11blackSTi's Avatar
    Join Date
    Nov 2012
    Location
    Portland, ME
    Posts
    2,773
    I Support ClubWRX
    Well...first of all sir...you need to use that AP to read the cell code that your engine is throwing. Then tell us what that code is and we can point you in the right direction hopefully

  4. #3
    Registered User SuperSonic12's Avatar
    Join Date
    Nov 2013
    Location
    Lehighton
    Posts
    72
    Yeah I guess that would help out alittle...my bad. It's a P0172 - fuel system too rich bank 1. I did a datalog of the pull and sent an email to Cobb support but haven't heard back from them yet.

  5. #4
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,335
    I Support ClubWRX
    Troubleshooting is the same as for PO171 provided your BPV is OK and you do not have a BOV..
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  6. #5
    Registered User SuperSonic12's Avatar
    Join Date
    Nov 2013
    Location
    Lehighton
    Posts
    72
    I don't have a bov and don't plan on putting one on after reading other threads about the troubles with them. Nothing appears to be wrong with the bpv.

  7. #6
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,335
    I Support ClubWRX
    Ok then either wait for a response to your data logs or go through the PO171 checklist to troubleshoot.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  8. #7
    Registered User Z31_2011's Avatar
    Join Date
    Oct 2013
    Location
    Monticello, Kentucky, United States
    Posts
    152
    That's your mass air flow sensor went out


    Sent from my iPhone using Tapatalk

  9. #8
    Registered User Z31_2011's Avatar
    Join Date
    Oct 2013
    Location
    Monticello, Kentucky, United States
    Posts
    152
    Mine done it couple weeks ago u go threw a dealer it's 265


    Sent from my iPhone using Tapatalk

  10. #9
    Registered User Z31_2011's Avatar
    Join Date
    Oct 2013
    Location
    Monticello, Kentucky, United States
    Posts
    152
    All so on your cobb ap check the intake temp it prombly read -41 or so


    Sent from my iPhone using Tapatalk

  11. #10
    Registered User SuperSonic12's Avatar
    Join Date
    Nov 2013
    Location
    Lehighton
    Posts
    72
    My car has alittle over 20k miles on it, seems kinda early to be replacing that...is that cause of just doing the downpipe and intake?? And when should I check the intake temp??...at idle...while driving??

  12. #11
    Registered User Z31_2011's Avatar
    Join Date
    Oct 2013
    Location
    Monticello, Kentucky, United States
    Posts
    152
    Mine only had 64 on it and I even took it too a mech


    Sent from my iPhone using Tapatalk

  13. #12
    Registered User Z31_2011's Avatar
    Join Date
    Oct 2013
    Location
    Monticello, Kentucky, United States
    Posts
    152
    Just put it too intake temp on your ap shouldn't matter driving or not if it's -41 or something and it's hot outside something's wrong or do a engine code on ecu it more likely tell u intake air temperature circuit high input


    Sent from my iPhone using Tapatalk

  14. #13
    Registered User Z31_2011's Avatar
    Join Date
    Oct 2013
    Location
    Monticello, Kentucky, United States
    Posts
    152


    That's what mine showed up


    Sent from my iPhone using Tapatalk

  15. #14
    Registered User SuperSonic12's Avatar
    Join Date
    Nov 2013
    Location
    Lehighton
    Posts
    72
    ok I'll check it today and see what it reads. so after you replaced the MAF sensor, did it go back to full strength?

  16. #15
    Registered User Z31_2011's Avatar
    Join Date
    Oct 2013
    Location
    Monticello, Kentucky, United States
    Posts
    152
    Yes and u erase the code everything back too normal the three lights came on went off and haven't had any more trouble


    Sent from my iPhone using Tapatalk

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •