Just installed new castles downpipe and smells really bad
Results 1 to 3 of 3

This is a discussion on Just installed new castles downpipe and smells really bad within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; Is this normal? I did just get a tune after I put the downpipe on and it has been a ...

  1. #1
    Registered User
    Join Date
    May 2014
    Posts
    1

    Just installed new castles downpipe and smells really bad

    Is this normal? I did just get a tune after I put the downpipe on and it has been a few days now. But the burning smell is not going away. I trimmed my ac condenser tube so it's not touching. And I am cat less from turbo back. Please help!!,!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    MAINEiac 11blackSTi's Avatar
    Join Date
    Nov 2012
    Location
    Land of the Port. ME
    Posts
    2,828
    I Support ClubWRX
    Having a catless downpipe definitely has a very foul smell to it. This is one of the things I don't like about catless DP's and is normal. It is more of a gas smell though (more like a raw exhaust smell - like if you have ever been near a motorcycle with no cat?) as opposed to a burning smell. Most noticeable if you have a rich tune and at start up.

  4. #3
    Registered User
    Join Date
    Mar 2014
    Location
    socal
    Posts
    62
    Yeah, taking out the cats will do that... it's normal, nothing to worry about. I wanted to avoid that, so I went catless do and catted exhaust

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •