05 WRX Smoking white
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on 05 WRX Smoking white within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; Hello ClubWRX, I'm in need of some help (I hope I'm posting in the right place, if not I'm sorry ...

  1. #1
    CFM
    CFM is offline
    Registered User
    Join Date
    Apr 2014
    Posts
    2

    05 WRX Smoking white

    Hello ClubWRX, I'm in need of some help (I hope I'm posting in the right place, if not I'm sorry and please direct me where I need to be). So I have a 05 WRX, and within the last few weeks I noticed a slight white tint to my exhaust. I didn't think too much of it since the weather was cold. I then started to notice my idle was inconsistent, almost like it hiccups. It's idling, then drops low, and back up again. Now pretty much all of a sudden, I noticed it's eating up oil. I was low, so I put 2 quarts in, 2 days later its low again. I threw another quart in to make it home, and it was low the next day. Like I said, out of no where it's no definitely blue smoke... and there's a lot of it at start up. Bad turbo seals? Rings are bad? Bad turbo? I've done some searching and have found similar things, but not an exact situation as mine so I hope I can get some help from you folks. It would be greatly appreciated...

    STi oiling system
    STi rods
    New nitrited crank
    Ported and polished heads
    Newer TD-04 turbo
    Exedy stage 2 clutch
    STi catless uppipe
    Invidia catless downpipe
    Apexi N1 midpipe to 4in straight pipe axle back

    Please help, I'm in desperate need of getting my car back on the road... Thank you.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User MOTION's Avatar
    Join Date
    Oct 2011
    Location
    Mandeville, La.
    Posts
    278
    Sorry but I can almost 100% guarantee its a ringland.

  4. #3
    CFM
    CFM is offline
    Registered User
    Join Date
    Apr 2014
    Posts
    2
    Thank you for your reply, I'm really hoping its not ringlands... I had a small amount of time today to try and do some diagnosing. I took the intake off and noticed some oil in there, not a ton... but some. I put a zip tie in there and got some sludge out. The car on start up smokes a lot, with a good blue tint to it. The smoke dies down a bit after it idles. Next to the alternator on the left hand side, under the intake there was a little puddle on the engine. And also same deal just under the turbo area. I don't see any smoke or anything like that from under the hood or near the turbo.

    What's also weird is I was low on oil 2 days ago when I parked it, and today when I check it again.... it was way over full on my dipstick... I'm confused. I'm concerned about the weird idle it has, it starts and drives fine.... Just at idle, it seems to be inconsistent like I said I can only think to describe it as a hiccup. I checked my coolant and it doesn't seem to have any oil or anything in it.... but for a while now I've smelt coolant here and there... but I'm really never low. I understand it's probably super hard to help me out without hearing or being there to see it.... I just hope my block is not going to be effed. I just had it out a few months ago, had some oil leak from oil pan/valve cover gaskets. So decided while its out I might as well do it all. Did timing belt, Exedy Pro Clutch, re-surface flywheel, valve cover gaskets, spark plugs, 02 sensor, re-seal oil pan, ran some new vac lines. A friend helped me out due to it being my first time pulling a engine (I should say he did most of the work).

  5. #4
    Registered User MOTION's Avatar
    Join Date
    Oct 2011
    Location
    Mandeville, La.
    Posts
    278
    Quote Originally Posted by CFM View Post
    Thank you for your reply, I'm really hoping its not ringlands... I had a small amount of time today to try and do some diagnosing. I took the intake off and noticed some oil in there, not a ton... but some. I put a zip tie in there and got some sludge out. The car on start up smokes a lot, with a good blue tint to it. The smoke dies down a bit after it idles. Next to the alternator on the left hand side, under the intake there was a little puddle on the engine. And also same deal just under the turbo area. I don't see any smoke or anything like that from under the hood or near the turbo.

    What's also weird is I was low on oil 2 days ago when I parked it, and today when I check it again.... it was way over full on my dipstick... I'm confused. I'm concerned about the weird idle it has, it starts and drives fine.... Just at idle, it seems to be inconsistent like I said I can only think to describe it as a hiccup. I checked my coolant and it doesn't seem to have any oil or anything in it.... but for a while now I've smelt coolant here and there... but I'm really never low. I understand it's probably super hard to help me out without hearing or being there to see it.... I just hope my block is not going to be effed. I just had it out a few months ago, had some oil leak from oil pan/valve cover gaskets. So decided while its out I might as well do it all. Did timing belt, Exedy Pro Clutch, re-surface flywheel, valve cover gaskets, spark plugs, 02 sensor, re-seal oil pan, ran some new vac lines. A friend helped me out due to it being my first time pulling a engine (I should say he did most of the work).
    unfortunately it still sounds like a piston/ring issue. As far a checking you roil goes, if you push the dipstick in too hard on these motors it actually pushes the oil down the tube so you don't get an accurate reading which means when you think that it's low you may be over filling it. The best way to be sure you don't over fill it is to drain the oil and refill with the 4.5 quarts and remember to push the dipstick in very slowly and gently or like some people do and pull the oil fill cap at the same time.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •