2013 Wrx Engine Problem - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 19 of 19

This is a discussion on 2013 Wrx Engine Problem within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; There are a lot of examples of guys putting down ~400whp/wtq and not breaking anything trans wise. Rsutton comes to ...

  1. #16
    Registered User
    Join Date
    Oct 2012
    Location
    CT
    Posts
    307
    There are a lot of examples of guys putting down ~400whp/wtq and not breaking anything trans wise. Rsutton comes to mind as an example. ~30000+ miles at over 340whp and hasn't broken the trans. New organic clutch yes however. I'd say yes it's a little luck but mostly how you treat and drive the car. No clutch dumps, no launching, being nice to the trans basically.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User
    Join Date
    Jun 2012
    Posts
    39
    I have a buddy putting down 446whp on stock internals but he uses 100 octane only at that power level, the normal pump tune puts down 320whp, so I know the engine can take a considerable power increase. Do you have any idea what might have cause the failure? Also what oil are you running?

  4. #18
    Registered User
    Join Date
    Nov 2013
    Posts
    277
    who tuned the car?

  5. #19
    Registered User Rmurphy_22's Avatar
    Join Date
    Nov 2013
    Location
    Signal Hill, CA
    Posts
    40
    Any updates...PM me if you are looking to sell some goodies.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •