2002 wrx misfire issue - Page 2
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 16 to 18 of 18

This is a discussion on 2002 wrx misfire issue within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; Originally Posted by pvtxk This happened to me as well, I was jumping from misfires on 2/4 to just 2, ...

  1. #16
    Registered User TylerFerrara's Avatar
    Join Date
    Dec 2012
    Location
    Levittown PA
    Posts
    27
    Quote Originally Posted by pvtxk View Post
    This happened to me as well, I was jumping from misfires on 2/4 to just 2, to 1/2/4, and also had flashing cels on WOT and rough idle/startup. I used injector cleaner (Lukas and techron) and within two drive cycles the CEL went away, next day start up was crisp. Came back when I didn't use the treatment so I just upgraded my injectors and life has been prestine ever since. But definitely do a boost leak/compression test if you have the money for some reassurance, you can never be too sure.


    Sent from my iPhone using Tapatalk
    Alright thanks, the car runs pretty well so it's not a huge concern but I'm definitely doing things as I can afford them

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User pvtxk's Avatar
    Join Date
    Feb 2013
    Location
    Orange County, CA
    Posts
    15
    Haha can never be too sure, my friend. Better fix it while the car's still running you know? but knock on wood, good luck with your car!!


    Sent from my iPhone using Tapatalk
    666

  4. #18
    Registered User TylerFerrara's Avatar
    Join Date
    Dec 2012
    Location
    Levittown PA
    Posts
    27
    Quote Originally Posted by pvtxk View Post
    Haha can never be too sure, my friend. Better fix it while the car's still running you know? but knock on wood, good luck with your car!!


    Sent from my iPhone using Tapatalk
    Yeah true, thanks man. It's definitely running a lot better since I replaced the fuel filter and ran some injector cleaner, but it's still misfiring. I'm gonna run another bottle through and also fix the exhaust leak and see if that helps

+ Reply to Thread
Page 2 of 2 FirstFirst 12

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •