Anyone having Invidia Q300 issues bolting on the spring bolt?
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on Anyone having Invidia Q300 issues bolting on the spring bolt? within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; The mid pip on the invidia q300 connecting to the cat with those two spring bolts is really freaking hard ...

  1. #1
    Registered User blee5192's Avatar
    Join Date
    Aug 2013
    Location
    Bay Area
    Posts
    94

    Anyone having Invidia Q300 issues bolting on the spring bolt?

    The mid pip on the invidia q300 connecting to the cat with those two spring bolts is really freaking hard to put on. I managed to get 1 of the bolts on but not both. I even had a friend help me out and we were really close but not close enough. I tried C-Clamps and the clamps didnt have enough surface area to clamp down.

    I maybe think that my donut gasket is still new so I am having problems getting it closer. My car is a 13' WRX Sedan and I had it since this early September.

    If anyone have any insight or in the vicinity of Riverside, CA or nearby for the help ... I would come out!

    Thanks forum!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Ampliified's Avatar
    Join Date
    May 2012
    Location
    Warren Twp, NJ
    Posts
    811
    Those bolts are a beach and a half to put back on if you are utilizing the donut gasket I could only manage getting one back on before I switched to a new DP
    2012 DGM WRX - Stage Two 93 - Stink Eye Mob #908
    The Epic Life of Emily the WRX

  4. #3
    Moderator rage-wrx's Avatar
    Join Date
    Aug 2010
    Location
    Yonkers/NYC
    Posts
    10,815
    I Support ClubWRX
    They are hard to install.

    Do you have the orientation right? They only go on one way. The bolt goes on the midpipe & the nut goes on the downpipe side.

    Also,I'm not entirely sure,but I think with the Q300 you get a pair of smaller bolts that are used instead of the spring bolts.
    T0ny
    2011 WRX
    2012 FXT

    The Big 2011/2012 Mod Thread


    Ooh,hang on. That is the throb of a turbocharged flat four engine. A sound which,all over the world,heralds the imminent arrival of a moron - JC.

  5. #4
    Registered User blee5192's Avatar
    Join Date
    Aug 2013
    Location
    Bay Area
    Posts
    94
    Quote Originally Posted by rage-wrx View Post
    They are hard to install.

    Do you have the orientation right? They only go on one way. The bolt goes on the midpipe & the nut goes on the downpipe side.

    Also,I'm not entirely sure,but I think with the Q300 you get a pair of smaller bolts that are used instead of the spring bolts.
    Should I just get bigger spring bolts? and where can I get bigger spring bolts?

  6. #5
    Registered User
    Join Date
    Aug 2013
    Posts
    4
    I got a invidia DP and q300 I just bolted them up without using the springs...

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •