Uppipe Question
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 21

This is a discussion on Uppipe Question within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; Ok so I have a 04 WRX... I wanna replace the UP because I have been told that they are ...

  1. #1
    Registered User ClosetSubyLover's Avatar
    Join Date
    Apr 2013
    Location
    Planet Earth
    Posts
    56

    Uppipe Question

    Ok so I have a 04 WRX... I wanna replace the UP because I have been told that they are catted and can break down and cause all those yummies to go into your turbo(Correct me if Im wrong on that).

    I was looking around on RallyDirect and in the description for one of the GrimmSpeed Uppipes, they claimed an extra +10whp and also claimed it was one of the best $/Hp gain ratios you could do to your car. I guess that leads me to a few questions...

    1. Is this true for the extra +10whp?

    2. I have the COBB AP Stage 2 93 tune so am I have gonna have to get it protuned to see any of that extra whp? Or is it just gonna "adapt" so to speak and just free up a couple extra ponys?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    OMG WTF MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,314
    I Support ClubWRX I Support ClubWRX
    +10whp is pretty generous. The turbo will spool better, and you will gain some power, maybe more like 5whp realistically. Your AP stage 2 tune should be fine, I would reset the ECU and then log a day or two after the swap just to be safe.

  4. #3
    Captain James of the SS Impreza has gone down with the ship Drews's Avatar
    Join Date
    Aug 2008
    Location
    Davey Jones Locker
    Posts
    8,596
    I Support ClubWRX
    If you can find a stock UP off a newer model they have catless UPs and would save you a couple bucks.
    Hawk-Eye Alliance #Eleventy,000,000,000|N.E.R.D. Member 20,000
    Stable: 2014 Hyundai Veloster Turbo (Matte Grey), 06 LGT, 03 WRX, 98 RS, 00 OBS


    Resident Clubdub Debbie Downer. I'd love your ideas if you kept them to yourself. Subarus suck, get a new wife.

    Never argue with idiots. They'll drag you to their level and beat you with experience.

  5. #4
    Registered User tirerob's Avatar
    Join Date
    Nov 2012
    Location
    bug-eyeing in the Bakken
    Posts
    1,031
    i did the grimmspeed up pipe and new top mount mishimoto intercooler hoses on my 02. turbo spools much smoother and at a lower rpm than when i bought it. boost gauge says i am making low boost numbers by 2200rpm now verses 2700ish before. maybe not to much more power over all...just sooner. my idle seems a bit smoother to and sits rock solid at 500 rpm.


    edit. after re-reading, i am not tuned yet, still running the factory ecu and everything has been ok.
    Last edited by tirerob; 09-25-2013 at 09:32 PM.
    when my friends come up, i hear, "you sold the camarrrroooh.....HOLY BLEEP A WRX!"
    Ya has that effect on me too.
    Rob

    Where did he go?? http://www.clubwrx.net/forums/builds...ll-thread.html

  6. #5
    Registered User ClosetSubyLover's Avatar
    Join Date
    Apr 2013
    Location
    Planet Earth
    Posts
    56
    OK guys I appreciate the advice I think I know what Im looking for now!

  7. #6
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,768
    I Support ClubWRX
    Quote Originally Posted by ClosetSubyLover
    1. Is this true for the extra +10whp?
    Quote Originally Posted by MainFrame
    +10whp is pretty generous.
    10whp peak or 10whp at points in the RPM band?
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  8. #7
    OMG WTF MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,314
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by EJ257 View Post
    10whp peak or 10whp at points in the RPM band?


    right.. I wouldn't be too surprised to see a 10whp gain around 3500rpm, but not at 5500rpm

  9. #8
    Registered User ClosetSubyLover's Avatar
    Join Date
    Apr 2013
    Location
    Planet Earth
    Posts
    56
    So a couple more things to ask...

    I guess replacing a catted UP for a catless will cause a CEL? but what if its tuned?

    Am I gonna go have to buy that 2.2Kohm resistor people are talking about? and plug it into my EGT sensor?

    I know mainframe said it should be ok and just double checking by logging but no word from anyone on a CEL from the install.

  10. #9
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,739
    I Support ClubWRX
    Quote Originally Posted by ClosetSubyLover View Post
    I guess replacing a catted UP for a catless will cause a CEL?
    It should, yes.

    but what if its tuned?
    "Tuning" refers to altering the base mapping, for better or worse. Since there is access to the ECU, the CEL can be eliminated and hopefully the sensor can be switched to a "ready" state.

    Am I gonna go have to buy that 2.2Kohm resistor people are talking about?
    Not necessarily; see above.
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  11. #10
    Registered User Dzanga's Avatar
    Join Date
    Oct 2011
    Location
    phx
    Posts
    254
    Quote Originally Posted by Drews View Post
    If you can find a stock UP off a newer model they have catless UPs and would save you a couple bucks.
    I have a up pipe off my 13 if anybody would be interested.
    2012 Wrx SWP Hatch-Traded
    2013 Limited ISM Hatch -Current

  12. #11
    Registered User ClosetSubyLover's Avatar
    Join Date
    Apr 2013
    Location
    Planet Earth
    Posts
    56
    Quote Originally Posted by SD_GR View Post
    hopefully the sensor can be switched to a "ready" state.
    Can you elaborate on this a little more? Considering you said I might not necessarily have to get a resistor.... I is confuzzled

  13. #12
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,739
    I Support ClubWRX
    If the CEL is addressed electronically you won't need a resistor. If it is not, you will.
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  14. #13
    Registered User
    Join Date
    Aug 2012
    Posts
    86
    Up-pipe wont cause a cell if it has proper placement of the senser and a place to put it.. Otherwise it will throw a cell and you have to get a fix for the sensor that plugs into it.

    I have GT-spec up-pipe.. With OE sensor installed.. NO cells 2 years going

  15. #14
    Registered User
    Join Date
    Aug 2012
    Posts
    86
    Up-pipe wont cause a cell if it has proper placement of the senser and a place to put it.. Otherwise it will throw a cell and you have to get a fix for the sensor that plugs into it.

    I have GT-spec up-pipe.. With OE sensor installed.. NO cells 2 years going

  16. #15
    Captain James of the SS Impreza has gone down with the ship Drews's Avatar
    Join Date
    Aug 2008
    Location
    Davey Jones Locker
    Posts
    8,596
    I Support ClubWRX
    Quote Originally Posted by Dat8687 View Post
    Up-pipe wont cause a cell if it has proper placement of the senser and a place to put it.. Otherwise it will throw a cell and you have to get a fix for the sensor that plugs into it.

    I have GT-spec up-pipe.. With OE sensor installed.. NO cells 2 years going
    CEL* and sensor* Your posts can be pretty painful to read.
    Hawk-Eye Alliance #Eleventy,000,000,000|N.E.R.D. Member 20,000
    Stable: 2014 Hyundai Veloster Turbo (Matte Grey), 06 LGT, 03 WRX, 98 RS, 00 OBS


    Resident Clubdub Debbie Downer. I'd love your ideas if you kept them to yourself. Subarus suck, get a new wife.

    Never argue with idiots. They'll drag you to their level and beat you with experience.

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •