2011 Invidia Catted Downpipe Questions
+ Reply to Thread
Results 1 to 11 of 11

This is a discussion on 2011 Invidia Catted Downpipe Questions within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; Ok so today me and my buddy installed an invidia catted downpipe on my 2011 wrx. It is currently running ...

  1. #1
    Registered User
    Join Date
    Jul 2012
    Location
    San Jose
    Posts
    27

    2011 Invidia Catted Downpipe Questions

    Ok so today me and my buddy installed an invidia catted downpipe on my 2011 wrx. It is currently running Cobb's OTS Stage 1 tune + SF intake (which is on). I didn't buy an after market heat shield and I didn't have a grinder so I just left the heat shield off. We started it up and a tiny tiny bit of smoke seemed to come from the turbo with a slight weird smell. My buddy had to get somewhere so I drove home very very slowly and didn't go over 3k RPM's. (~2 mile drive) When I got home I opened the hood to see if there was any smoke and there wasn't so I gave it a few revs and no smoke but that weird smell (pretty faint). Now I am not sure what to do. I am ordering a new heat shield right now and I am just wondering if this is normal at all. I do not intend to drive my car until the heat shield comes or if I do I won't do anything stupid. Please let me know if this is normal at all and what I should do if it isn't. Thanks
    - 2011 WRB WRX Premium Hatch

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Sammich Makin' Pwincess wrxtreme06's Avatar
    Join Date
    May 2007
    Location
    orlando flawduh
    Posts
    12,783
    I Support ClubWRX
    Quote Originally Posted by briancox33 View Post
    Ok so today me and my buddy installed an invidia catted downpipe on my 2011 wrx. It is currently running Cobb's OTS Stage 1 tune + SF intake
    You should NOT be running a stage one map with an aftermarket downpipe. Switch to stage 2 immediately

    desiree
    your friendly, neighborhood subaru girl
    abbigale : 06 impreza wrx tr: cobb stage II
    hawkeye alliance #11:11//
    wingl3ss @ll!ance #17 // lvl 80 N.E.R.D.

  4. #3
    Registered User
    Join Date
    Jul 2012
    Location
    San Jose
    Posts
    27
    Sorry I didn't specifiy. I forgot my accessport at home so when I got hom I immediately switched to the Cobb's OTS stage 2 + SF. I drove ~3 miles with the stage 1 tune never going over 3k RPM's
    - 2011 WRB WRX Premium Hatch

  5. #4
    and the Funky Bunch Calvinball's Avatar
    Join Date
    Jan 2012
    Location
    Philly Area
    Posts
    5,980
    What makes you say the smoke was coming from the turbo?
    - Will
    First Mods: What to do and what not to do
    Current Car: 2014 Golf TDI
    Previous Cars:2012 WRB WRX Hatch, 2004 RSX-S, 1998 Grand Prix GTP
    "Isn't it amazing how smart you feel when you just aren't being stupid?"

  6. #5
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,853
    I Support ClubWRX
    Did you use any kind of liquid (e.g., PB Blaster) during your install?
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  7. #6
    Registered User
    Join Date
    Jul 2012
    Location
    San Jose
    Posts
    27
    WD-40 for a couple bolts that were tough. Also how bad is it to run no heat shield for a 3-5 days? Also if it was the wd-40 burining off, it still smelled slightly, kind of like oil after the short drive home but nothing in the car while driving at all
    Last edited by briancox33; 08-10-2013 at 07:47 PM.
    - 2011 WRB WRX Premium Hatch

  8. #7
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,853
    I Support ClubWRX
    Quote Originally Posted by briancox33
    WD-40 for a couple bolts that were tough. Also how bad is it to run no heat shield for a 3-5 days? Also if it was the wd-40 burining off, it still smelled slightly, kind of like oil after the short drive home but nothing in the car while driving at all
    I'd guess it was the WD40. Give it a few days if you can't find any sign of a leak somewhere.

    No heatshield won't kill your car, but it doesn't do it any favors.
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  9. #8
    Registered User
    Join Date
    Jul 2012
    Location
    San Jose
    Posts
    27
    How exactly would I know if there is a leak?
    - 2011 WRB WRX Premium Hatch

  10. #9
    Registered User Motoxdude6's Avatar
    Join Date
    Jan 2013
    Location
    Lubbock, TX
    Posts
    147
    if u used something to help get the bolts off, its most likely that. i used liquid wrench all over the nuts and it smoked like a mofo for a few days. on top of that the new heat wrap on the DP didnt help either. new heat wrap has to basicly burn onto the DP. and as for the heat shield, im in the same boat, i havent had the time to cut the original heat shield, nor the money to order a new one, i havent had mine on my car for over a month, doesnt really do anything

  11. #10
    Registered User Motoxdude6's Avatar
    Join Date
    Jan 2013
    Location
    Lubbock, TX
    Posts
    147
    as for the leak, give it a few days, let the wd40 wear off cause it will take a little while. only way to tell if there is a leak is to listen for it, or feel for it while the car is running but be careful. post turbo exhaust leak wont kill your car, but a leak at the turbo isnt good

  12. #11
    Registered User
    Join Date
    Jul 2012
    Location
    San Jose
    Posts
    27
    Quote Originally Posted by Motoxdude6 View Post
    as for the leak, give it a few days, let the wd40 wear off cause it will take a little while. only way to tell if there is a leak is to listen for it, or feel for it while the car is running but be careful. post turbo exhaust leak wont kill your car, but a leak at the turbo isnt good
    No more smoke at all after that initial start-up. I don't think there is a leak because the exhaust sound is virtually the same as stock and it's clearly coming out the back. With the hood open I even told my friend to give it some high revs and I looked at the turbo and everything seemed fine (Just really hot). Still smells bad when coming to stops but it is going away slowly. I decided to go with a blanket instead of a heat shield so hopefully that will keep temps down.
    - 2011 WRB WRX Premium Hatch

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •