Prosport sensors installed, wiring next!!
Results 1 to 11 of 11

This is a discussion on Prosport sensors installed, wiring next!! within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; Just finished installing sensors for Prosport evo boost, oil pressure, fuel pressure, water temp, and air fuel gauges...

  1. #1
    Registered User scolena's Avatar
    Join Date
    Mar 2013
    Location
    MA
    Posts
    67

    Prosport sensors installed, wiring next!!

    Just finished installing sensors for Prosport Click image for larger version. 

Name:	image.jpg 
Views:	43 
Size:	97.4 KB 
ID:	114931Click image for larger version. 

Name:	image.jpg 
Views:	40 
Size:	102.1 KB 
ID:	114932 evo boost, oil pressure, fuel pressure, water temp, and air fuel gauges

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User scolena's Avatar
    Join Date
    Mar 2013
    Location
    MA
    Posts
    67
    Click image for larger version. 

Name:	image.jpg 
Views:	40 
Size:	79.7 KB 
ID:	114933Click image for larger version. 

Name:	image.jpg 
Views:	40 
Size:	102.1 KB 
ID:	114934

  4. #3
    Subaru Newb MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,027
    I Support ClubWRX I Support ClubWRX
    I hope for your sake they work better than mine did.

  5. #4
    Registered User scolena's Avatar
    Join Date
    Mar 2013
    Location
    MA
    Posts
    67
    Yeah I have read so many good and bad reviews over the past year but took a chance and ordered them. I love the look of the evo digital series, I will def post updates on how they work. What happened with yours?

  6. #5
    Subaru Newb MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,027
    I Support ClubWRX I Support ClubWRX
    My first oil pressure gauge was 15psi low out of the box. 1st replacement worked right for two months, then I discovered it wasn't dropping below 20psi when the engine was off. 2nd replacement worked for three months before the same thing happened.. fourth replacement worked for about six months, then did the same.

    My EGT gauge worked for about eight months, then it started acting all wonky, twitching from max to min constantly. The replacement for it worked nearly a year (although the car was in the shop for more than six months of that), then did the same thing.


    Now it's been so long since I initially bought them I'm out of warranty. With the cost of shipping them to FL all the time to get replaced I could have just bought better gauges.



    The mechanical boost gauge I got still works fine though, so I guess that's one good thing.

  7. #6
    Registered User scolena's Avatar
    Join Date
    Mar 2013
    Location
    MA
    Posts
    67
    That stinks, sorry to hear about your troubles. What series gauges did you have? I tried to mount the sensors away from heat as much as possible.

  8. #7
    Subaru Newb MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,027
    I Support ClubWRX I Support ClubWRX
    I think they were the standard Blue/White 60mm gauges.. only ones they made at the time. Looks like the same sending unit as yours.

  9. #8
    Registered User scolena's Avatar
    Join Date
    Mar 2013
    Location
    MA
    Posts
    67
    I am hoping maybe they make them a little better now!!!! We will see

  10. #9
    Registered User scolena's Avatar
    Join Date
    Mar 2013
    Location
    MA
    Posts
    67
    Got all the gauges wired today, took about 4 hours. They look great, hoping the keep working correctly!!!!Click image for larger version. 

Name:	image.jpg 
Views:	23 
Size:	100.7 KB 
ID:	114950Click image for larger version. 

Name:	image.jpg 
Views:	23 
Size:	97.0 KB 
ID:	114951Click image for larger version. 

Name:	image.jpg 
Views:	23 
Size:	83.3 KB 
ID:	114952Click image for larger version. 

Name:	image.jpg 
Views:	23 
Size:	94.4 KB 
ID:	114953

  11. #10
    Registered User
    Join Date
    Jun 2012
    Location
    NJ
    Posts
    220
    Thats a lot of gauges! Have any DIy?

  12. #11
    Registered User scolena's Avatar
    Join Date
    Mar 2013
    Location
    MA
    Posts
    67
    I do not, sorry

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •