Cold startup Noise - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 18 of 18

This is a discussion on Cold startup Noise within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; THANK YOU Mcdbrendan and Twister, was just about to ask about that whining noise, was driving me nuts havent been ...

  1. #16
    Registered User Kam91's Avatar
    Join Date
    Jul 2012
    Posts
    58
    THANK YOU Mcdbrendan and Twister, was just about to ask about that whining noise, was driving me nuts havent been able to get on to the site in a while and like you guys said my 2012 only does it when its super cold, anything above 15-20 degrees and its fine

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Road Hazard STI*NG's Avatar
    Join Date
    Sep 2012
    Location
    Columbus, OH
    Posts
    191
    My 09 STI does it too in anything below freezing. I did notice that the fluid level was a bit low as well, but that didn't change anything.

  4. #18
    Registered User EndlessSea's Avatar
    Join Date
    Nov 2012
    Location
    Las Vegas
    Posts
    407
    Do those year wrxs have that electric air pump looking thing on the drivers side front of the engine? Mine makes a sound like a small vacuum cleaner when it's cold out. Although I have no idea what that little black cylinder does......

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •