Need Help With Engine Build!
Results 1 to 2 of 2

This is a discussion on Need Help With Engine Build! within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; Okay guys I seriously need some help, So I did a engine rebuild and now that I have the engine ...

  1. #1
    Registered User
    Join Date
    Apr 2011
    Posts
    10

    Need Help With Engine Build!

    Okay guys I seriously need some help, So I did a engine rebuild and now that I have the engine in and everything it will crank over but wont fire up. I made sure all the connection where pluged up and still nothing. Not only will it not start, when cranking it cranks really slow. I was wondering if there was something wrong with my TGV. Does the TGV have to be close when being installed to the intake manifold or is it open? Another problem I have is when installing my new clutch my slave and master cylinder went out? how do I bleed the slave properly to make sure everything is good. Because when I put in in gear and crank it the car jumps but does not start up, but when its in neutural it cranks but nothing happens. Please help guys! Thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,036
    I Support ClubWRX
    It the fuel pump priming? Did you connect the coilpacks back up right? The black connectors go to the back. The TGV's don't have to be closed to start. The clutch is bled just like a brake is.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •