What are your EvoIII 16G Spoolup RPMs on 2.0?
Results 1 to 11 of 11

This is a discussion on What are your EvoIII 16G Spoolup RPMs on 2.0? within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; For all you EvoIII16G guys out there, I'm curious as to what your spool RPMs are. Preferably in both first ...

  1. #1
    Registered User MWatson17's Avatar
    Join Date
    Nov 2009
    Location
    SE Michigan
    Posts
    79

    What are your EvoIII 16G Spoolup RPMs on 2.0?

    For all you EvoIII16G guys out there, I'm curious as to what your spool RPMs are. Preferably in both first gear and a high gear. I've had my 16G (bought used from a friend... no details on its history but pretty good deal) on the car since summer and when I first put it on, I was surprised by the increase in lag. Don't get me wrong, I knew it was gonna be worse than the stock turbo, but I didn't think it would be so dramatic. My first gear does not spool until 5000rpm, and at freeway speeds in fifth it will not spool until around 4000rpm.

    I've gotten used to it for the most part, but it still seems odd, so I thought I'd ask and see if that is normal before I start checking for boost and exhaust leaks.

    Car is 2002 WRX, full exhaust with grimmspeed ported manifolds and x, EWG, and E85, self tuned. Stock TMIC for now.
    Matt
    2003 Silver Pontiac Vibe (sold)
    1990 Red Miata on Megasquirt3, soon to be getting the stock turbo off the WRX
    2002 Silver WRX sedan, Full Exhaust, 16G, Cobb AP self-tuned on E85 (work in progress)
    1986 Chevy K20, 350 4x4 on Megasquirt. Brings the car home when it breaks.

    Future cars? Too many to list.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User sxcrxy's Avatar
    Join Date
    Nov 2011
    Posts
    233
    seems about right i have a tts big 16g (very similar to evoIII 16g) with a sti tmic full spool is at 3800rpm (decatted uppipe and avo inlet and silicone pipes helps) running 21psi 1st gear i struggle to hit full boost under light load also check for any leaks and your tune, the tune also plays a big part

  4. #3
    Registered User MWatson17's Avatar
    Join Date
    Nov 2009
    Location
    SE Michigan
    Posts
    79
    So I'm not the only one then, interesting...

    I'm kind of curious then, because I've been doing a lot of forum searching for this topic. A lot of people say it should reach full boost by 3500-600. I've also seen some people describing the spool of 20G on a 2.0 and it's barely worse if not very similar to what I have now. I dunno, for the "quick spool" option, it just doesn't seem to be as quick spooling as people make it out to be.
    Matt
    2003 Silver Pontiac Vibe (sold)
    1990 Red Miata on Megasquirt3, soon to be getting the stock turbo off the WRX
    2002 Silver WRX sedan, Full Exhaust, 16G, Cobb AP self-tuned on E85 (work in progress)
    1986 Chevy K20, 350 4x4 on Megasquirt. Brings the car home when it breaks.

    Future cars? Too many to list.

  5. #4
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,670
    I Support ClubWRX
    Can you post up a datalog? Also, what boost control are you using?
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning, LLC

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  6. #5
    Registered User MWatson17's Avatar
    Join Date
    Nov 2009
    Location
    SE Michigan
    Posts
    79
    Sure, I'll see if I can dig some old ones up right now. If not I'll head out this afternoon and grab a couple.
    Matt
    2003 Silver Pontiac Vibe (sold)
    1990 Red Miata on Megasquirt3, soon to be getting the stock turbo off the WRX
    2002 Silver WRX sedan, Full Exhaust, 16G, Cobb AP self-tuned on E85 (work in progress)
    1986 Chevy K20, 350 4x4 on Megasquirt. Brings the car home when it breaks.

    Future cars? Too many to list.

  7. #6
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,670
    I Support ClubWRX
    Quote Originally Posted by MWatson17
    Sure, I'll see if I can dig some old ones up right now. If not I'll head out this afternoon and grab a couple.
    New one(s) would be ideal.

    Log only the following (since we're only concerned with boost, limit yourself to those parameters):
    Load
    RPM
    Target Boost
    MRP (Corrected)
    Primary WGDC
    Initial WGDC
    Max WGDC
    Throttle
    TD Integral
    TD Proportional

    I know you have the AP, so I'm not exactly sure what the proper parameters are for that, but those are the ones in Romraider.
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning, LLC

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  8. #7
    Registered User MWatson17's Avatar
    Join Date
    Nov 2009
    Location
    SE Michigan
    Posts
    79
    Well I took the datalogs and I feel like an idiot. In fifth I'm getting 1 bar of boost by 3100, full boost at 3600. I hardly do any freeway driving and last time I did a freeway pull I just looked at the boost gauge and back at the tach and it seemed slow. I guess the moral of the story is, if you think something is off just by watching the gauges on the dash, do a datalog before asking for help.

    So I guess I will reask my original post. First gear will spool about 10psi at 5000rpm. Fifth will spool 14psi by 3100. Does this seem more acceptable? First gear in particular, I'm no longer concerned with higher gears.

    I can still post the datalogs if anyone wants to see them.
    Matt
    2003 Silver Pontiac Vibe (sold)
    1990 Red Miata on Megasquirt3, soon to be getting the stock turbo off the WRX
    2002 Silver WRX sedan, Full Exhaust, 16G, Cobb AP self-tuned on E85 (work in progress)
    1986 Chevy K20, 350 4x4 on Megasquirt. Brings the car home when it breaks.

    Future cars? Too many to list.

  9. #8
    Registered User MWatson17's Avatar
    Join Date
    Nov 2009
    Location
    SE Michigan
    Posts
    79
    Quote Originally Posted by EJ257 View Post
    what boost control are you using?
    Grimmspeed 3 port EBCS, in case you were still curious.
    Matt
    2003 Silver Pontiac Vibe (sold)
    1990 Red Miata on Megasquirt3, soon to be getting the stock turbo off the WRX
    2002 Silver WRX sedan, Full Exhaust, 16G, Cobb AP self-tuned on E85 (work in progress)
    1986 Chevy K20, 350 4x4 on Megasquirt. Brings the car home when it breaks.

    Future cars? Too many to list.

  10. #9
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,670
    I Support ClubWRX
    Quote Originally Posted by MWatson17
    Well I took the datalogs and I feel like an idiot. In fifth I'm getting 1 bar of boost by 3100, full boost at 3600. I hardly do any freeway driving and last time I did a freeway pull I just looked at the boost gauge and back at the tach and it seemed slow. I guess the moral of the story is, if you think something is off just by watching the gauges on the dash, do a datalog before asking for help.

    So I guess I will reask my original post. First gear will spool about 10psi at 5000rpm. Fifth will spool 14psi by 3100. Does this seem more acceptable? First gear in particular, I'm no longer concerned with higher gears.

    I can still post the datalogs if anyone wants to see them.
    I'd be curious to see a 3rd gear pull
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning, LLC

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  11. #10
    Registered User MWatson17's Avatar
    Join Date
    Nov 2009
    Location
    SE Michigan
    Posts
    79
    Sure!

    https://docs.google.com/open?id=0B0-...mRHendHRm04MWM

    Please let me know if you see something that I'm doing wrong with the tune. PS I'm not 100% sure, but I think I'm exceeding the stock MAP sensor limits because my boost gauge shows it peak much closer to my target.
    Matt
    2003 Silver Pontiac Vibe (sold)
    1990 Red Miata on Megasquirt3, soon to be getting the stock turbo off the WRX
    2002 Silver WRX sedan, Full Exhaust, 16G, Cobb AP self-tuned on E85 (work in progress)
    1986 Chevy K20, 350 4x4 on Megasquirt. Brings the car home when it breaks.

    Future cars? Too many to list.

  12. #11
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,670
    I Support ClubWRX
    Quote Originally Posted by MWatson17
    I think I'm exceeding the stock MAP sensor limits because my boost gauge shows it peak much closer to my target.
    You are. You need to buy an upgraded MAP sensor or dial back the boost a bit, IMO.
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning, LLC

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •