Blown head Gasket...rings...or turbo seals?
Results 1 to 2 of 2

This is a discussion on Blown head Gasket...rings...or turbo seals? within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; History of the car. Its an 08 WRX with 56K miles. I bought this 3rd party for a very good ...

  1. #1
    Registered User
    Join Date
    Aug 2012
    Posts
    25

    Question Blown head Gasket...rings...or turbo seals?

    History of the car. Its an 08 WRX with 56K miles. I bought this 3rd party for a very good price. It came with a VF52 Turbo upgrade and a cat back Magnaflow exhaust and a turboSX BOV. Car ran ok but i could tell that it needed to be tuned. Did not smoke. I scheduled for it to get a tune. A few days before the tune i installed a cobb downpipe on it and drove it very concervative. At this point is when i noticed that when i sat at idle for long periods of time it would begin to make a whitish smoke. I thought it was unburnted fuel from running to rich for the mods. Got to the tuner and told him my symptoms. Ditched to BOV and went to a Forge BPV and threw it on the dyno. Started the car and let it run for 45 minutes at idle and it started to smoke lightly probably 10 minutes in. In his opinion he thinks its the Turbo seals that have gone bad. He tells me my crank pressure is good but to do a compression test to verify the rings are good. Did a few pulls and stoped as it was just smoking too much. It only reached 250hp on a "half tune".


    Turbo with blown seals? - YouTube

    Compression test revieled

    cy 1= 125
    cy 2=140
    cy 3=125
    cy 4=140



    Im torn on the blown/leaking head gasket because both cyliders are at 125..i would think if it were blown one cy. would read high while the other reads low. Any help is appreciated. Is their a way to tell if its the turbo for sure?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Aug 2012
    Posts
    25
    re-did the compression check.. made a noob mistake and didnt hold down the throttle while testing compression.. new test reveiled 140 on every cyclinder. bout a rebuild kit for the turbo... read a book..watched a video. rebuilt the turbo on saturday... car is fixed...no more smoking. Thanks for all the help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •