Down Pipe Emissions Test Question? - Page 2
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 16 to 24 of 24

This is a discussion on Down Pipe Emissions Test Question? within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; I am newbie, but isn't a Stage 2 tune, in my case was looking at the Perrin setup not suppose ...

  1. #16
    Registered User
    Join Date
    May 2009
    Location
    New York City
    Posts
    37

    Silly Question

    I am newbie, but isn't a Stage 2 tune, in my case was looking at the Perrin setup not suppose to throw any CELs? I mean heck they sell it as a set/stage? I could see it if you just threw on a downpipe, or some other mod, and didn't have a tune. Then the OBD could see something amiss. But I thought I would be good to go if I had a tune to go with it? Is this common, getting the CELs even with an access port tune?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User Sunkist's Avatar
    Join Date
    Mar 2002
    Location
    Tucson, AZ
    Posts
    216
    Quote Originally Posted by mjboudreaux77 View Post
    I have read many people talking about getting CELs with downpipes. I have a COBB DP and AP set to stage 2, so those CELs haven't happened to me.

    What is surprising though is I have gotten other CELs - for various non-DP reasons. Whenever my CEL throws, the car absolutely will not go into boost.

    How are people putting catless DPs on their cars and "just dealing" with thrown CEL codes? Doesn't that defeat the purpose if the car goes into protect mode? It would drive me nuts.
    The CEL does not put you into protect mode, the car runs fine still. Since you have a tune the CEL for the sensor in downpipe is blocked (or tricked to think it is functioning).
    Last edited by Sunkist; 04-28-2010 at 12:15 PM.
    My woman hates the money pit
    2002 WRX Hybrid 2.5L 16G

  4. #18
    Supporting Member mjboudreaux77's Avatar
    Join Date
    Sep 2007
    Location
    Northern Vermont
    Posts
    843
    I Support ClubWRX
    Quote Originally Posted by Sunkist View Post
    The CEL does not put you into protect mode, the car runs fine still. Since you have a tune the CEL for the sensor in downpipe is blocked (or tricked to think it is functioning).
    Whenever my CEL lights - I get a flashing cruise. The car will not go into boost in this situation. Perhaps this is something specific to the 07 model year?

    My past CELs were due to a bad MAF, and most recently the secondary air injection valve was stuck open.
    If I don't die by Thursday, I'll be roarin Friday night - Jimmy Buffett

  5. #19
    Registered User
    Join Date
    May 2009
    Location
    New York City
    Posts
    37
    So your CELs had nothing to do with your mods basically?

  6. #20
    Registered User Sunkist's Avatar
    Join Date
    Mar 2002
    Location
    Tucson, AZ
    Posts
    216
    Quote Originally Posted by mjboudreaux77 View Post
    Whenever my CEL lights - I get a flashing cruise. The car will not go into boost in this situation. Perhaps this is something specific to the 07 model year?

    My past CELs were due to a bad MAF, and most recently the secondary air injection valve was stuck open.
    Different CELs different problems, I am just referring to the CEL for the sensor in the downpipe.
    My woman hates the money pit
    2002 WRX Hybrid 2.5L 16G

  7. #21
    Supporting Member mjboudreaux77's Avatar
    Join Date
    Sep 2007
    Location
    Northern Vermont
    Posts
    843
    I Support ClubWRX
    Quote Originally Posted by Paradox00 View Post
    So your CELs had nothing to do with your mods basically?
    Not directly, I don't think...

    The MAF is curious since when I first put the K&N filter in, I don't think I "latched" the airbox correctly - so a lot of junk may have gotten into the intake and crudded up the sensor; but I don't know for sure.

    The secondary air injection failure is curious because those hoses and electrical connections are directly under the intercooler - which you have to lean on pretty hard to get back in place. I cleared the engine codes a couple of times, and the CEL never came back. Before this, I was boosting fine. When the light would come on, I couldn't boost. When I cleared the CEL with my AP, I was able to boost again until the light came on.

    I know the 04+ WRX's have a different ECU than the 02/03. Reading a bunch of places on the internet, I seem to find others that say the CEL and flashing cruise put the car in a protection mode.

    I have owned other cars when the CEL lit - and it never seemed to change how the car felt when it was driving so this was new to me with the subaru.
    If I don't die by Thursday, I'll be roarin Friday night - Jimmy Buffett

  8. #22
    OMG WTF MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,705
    I Support ClubWRX I Support ClubWRX
    IMO you shouldn't be installing a DP without a tune. I realize that some cars will run okay without a tune, but you're not going to get your hp increase without a tune. It's kind of pointless to install a new DP and not have the car tuned for it.

  9. #23
    Registered User Kam91's Avatar
    Join Date
    Jul 2012
    Posts
    58
    Just trying to get most of this straight.... I also live in NY, so basically your car will pass the emissions portion of the obd II test even with a catless DP as long as the car is tuned???

  10. #24
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,853
    I Support ClubWRX

    Re: Down Pipe Emissions Test Question?

    Quote Originally Posted by Kam91
    Just trying to get most of this straight.... I also live in NY, so basically your car will pass the emissions portion of the obd II test even with a catless DP as long as the car is tuned???
    Yes. You do have to deal with a visual, if the tech bothers to do what they're required to do. Many just skip that step.
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

+ Reply to Thread
Page 2 of 2 FirstFirst 12

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •