p0139
Results 1 to 10 of 10

This is a discussion on p0139 within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; I have somthing wired in that is blinking on my 04s rear o2 sensor. I dont know what it is. ...

  1. #1
    Registered User smurf976's Avatar
    Join Date
    May 2009
    Location
    CA
    Posts
    15

    p0139

    I have somthing wired in that is blinking on my 04s rear o2 sensor. I dont know what it is. I dont think its stock and I replaced the sensor and Im still geting a code. Help

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator
    Join Date
    Jul 2003
    Location
    Maryland
    Posts
    11,098
    I Support ClubWRX
    Did you replace it with a Subaru part or from another company.
    0-60 faster then your first sexual experience.
    "You've come far, and though you're far from the end
    You don't mind where you are, cause you know where you've been"

  4. #3
    Registered User smurf976's Avatar
    Join Date
    May 2009
    Location
    CA
    Posts
    15
    I did some reaserch and found out that it is infact a perrin o2 simulator. I think that the person that had the car before me had exaust then removed it when they sold the car leaving the o2 simulator. I think that this is why Im throw ing a code. Do you know that if I remove it will my car go back to stock? Its running waaaaaaaaaay to rich. 91 oc aint cheap when you burn it to damb fast!!!

  5. #4
    Moderator
    Join Date
    Jul 2003
    Location
    Maryland
    Posts
    11,098
    I Support ClubWRX
    If you remove it the car needs to be put back to stock. If it was me I'd go and buy an 02 sensor and install it wherever the Perrin peice is. Then I'd probably anticipate on buying the other one and replacing it as well.

    The thing with a used car is you have no idea what if anything is done to the ECU.
    0-60 faster then your first sexual experience.
    "You've come far, and though you're far from the end
    You don't mind where you are, cause you know where you've been"

  6. #5
    Registered User smurf976's Avatar
    Join Date
    May 2009
    Location
    CA
    Posts
    15
    I have already replaced the o2 sensor and the code still comes up. I just dont want to screw somthing up by pulling the simulator. Iv looked at the ecu and they definatly did some stuff to it. its a electrical tape mess. I dont know what all they did but I need to find somone who lives buy me to take a look!!! know anyone in cali?

  7. #6
    Registered User
    Join Date
    Dec 2005
    Location
    NJ
    Posts
    15
    if that was me i would go back to were i got the car with a bat or a few friends and get some answers

  8. #7
    Registered User smurf976's Avatar
    Join Date
    May 2009
    Location
    CA
    Posts
    15
    I removed the o2 sim, and it worked. no more cel. MOst peaple in these forums I notice us resistors and other things like what I found in my car. why not just spend 660 and get the cobb?

  9. #8
    Registered User subywrex05's Avatar
    Join Date
    Oct 2012
    Location
    New Castle, Delaware
    Posts
    16
    cause the resistor is $1.25 at radio shack but the cobb does alot more aparently so im sure its worth it

  10. #9
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,970
    I Support ClubWRX
    3........year.............old..................thr ead.................bump. And the resister trick is more for the EGT,not the rear O2 sensor. It will just cause other codes.
    Last edited by Donkey; 10-06-2012 at 04:05 AM.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  11. #10
    Registered User Ruh Roh's Avatar
    Join Date
    Dec 2011
    Location
    Pottstown PA
    Posts
    3,221
    Zombie threadddd

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •