Invidia Exhaust Hitting
Page 1 of 2 12 LastLast
Results 1 to 15 of 25

This is a discussion on Invidia Exhaust Hitting within the Engine Modifications forums, part of the Tech & Modifying & General Repairs category; Me and my brother installed an Invidia G200 Titanium Tip Catback on my 2005 STi today and when I fired ...

  1. #1
    Registered User Grumpy STI's Avatar
    Join Date
    Jun 2005
    Location
    So. Cal.
    Posts
    57

    Invidia Exhaust Hitting

    Me and my brother installed an Invidia G200 Titanium Tip Catback on my 2005 STi today and when I fired it up and began to back out the garage it started making a loud tapping sound. I know it's tapping the chasis, but just wondered if anybody else has had this problem with the Invidia exhuast and if you did how you solved it. Oh yeah I also put kartboy hangers on the exhuast when I changed it.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User prspect06's Avatar
    Join Date
    Feb 2003
    Location
    Land of the Kings
    Posts
    750
    Did you use the kartboy long exhaust hangers?

  4. #3
    Registered User Grumpy STI's Avatar
    Join Date
    Jun 2005
    Location
    So. Cal.
    Posts
    57
    Quote Originally Posted by prspect06
    Did you use the kartboy long exhaust hangers?
    No there the regular replacement exhaust hanger bushings. I lined them up with the factory ones and they were the exact same size.

  5. #4
    Boba Fett BrianH's Avatar
    Join Date
    Oct 2003
    Location
    Way up high.
    Posts
    17,899
    where is it tapping the chassis?

  6. #5
    Registered User Grumpy STI's Avatar
    Join Date
    Jun 2005
    Location
    So. Cal.
    Posts
    57
    The tapping is coming from the section right behind the downpipe.

  7. #6
    Registered User
    Join Date
    May 2005
    Posts
    158
    its hitting the tranny...........had the same problem just get under there and where it connects to the tranny the bracket slides just put it all the way to the other side.

  8. #7
    Boba Fett BrianH's Avatar
    Join Date
    Oct 2003
    Location
    Way up high.
    Posts
    17,899
    Quote Originally Posted by evothis
    its hitting the tranny...........had the same problem just get under there and where it connects to the tranny the bracket slides just put it all the way to the other side.

    The downpipe doesn't screw onto that bracket? My invidia was setup so that it would.

  9. #8
    Registered User
    Join Date
    May 2005
    Posts
    158
    ^^^^^^^^^^ it wouldnt be considering you drive and EVO lol

  10. #9
    Boba Fett BrianH's Avatar
    Join Date
    Oct 2003
    Location
    Way up high.
    Posts
    17,899
    Quote Originally Posted by evothis
    ^^^^^^^^^^ it wouldnt be considering you drive and EVO lol
    uhh, yeah and I didn't drive a wrx before it.

  11. #10
    Toboggan T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Your Mommas
    Posts
    25,514
    I Support ClubWRX
    Do you have the factory downpipe or aftermarket? Did you replace the doughnut with a flat gasket? I had my doughnut on when I had my factory downpipe and it rubbed the chassis until I did my downpipe and got rid of the doughnut for a flat gasket.


    Lead Wrench @ WTF Tuning, LLC

  12. #11
    Registered User Grumpy STI's Avatar
    Join Date
    Jun 2005
    Location
    So. Cal.
    Posts
    57
    Here's a pic, the red arrow is showing where about it's hitting. You may also notice the bushing is sitting funny. I tried to move it over but the piece of crap won't budge. The rear section of the exhaust sits fine and clears everything. I'm going to loosen everthing one more time to see if I can get it over any. If not I'm probably going to take it to a muffler shop and have the hanger location adjusted.
    Attached Thumbnails Attached Thumbnails Exhaust 003.jpg  

  13. #12
    Registered User
    Join Date
    Sep 2005
    Posts
    9
    Hey i have the exact same exhaust and im having the exact same problem
    did you fix it yet?
    whenever i shift gears or turn on/off it makes the noise
    im guessing you have the same problem

  14. #13
    Registered User cavallino333's Avatar
    Join Date
    Feb 2005
    Location
    Campbell CA
    Posts
    11,843
    My exhaust was hitting in the same spot I used one of the Karboy Xl hangers on the hnager closest to the tapping area and it solved the problem.
    FORZA FERRARI
    BLOBEYE SYNDICATE (retired) #13
    Quote Originally Posted by Integra96 View Post
    One day I hope to buy a car that is lubricated exclusively by pure manatee oil.

  15. #14
    Registered User BoostedTeg96's Avatar
    Join Date
    Nov 2004
    Location
    IL
    Posts
    121
    with my invidia N1 my exaust is hitting the same exact spot with my sti, its annoying as shi$
    05-Aspen White STI
    96-GSR-T **sold**

  16. #15
    Registered User WrxRick's Avatar
    Join Date
    Apr 2005
    Location
    Houston
    Posts
    418
    So all of yall with this similiar problem, is this associated with the downpipe? Yall have me confused...

    I just ordered a catback invidia race exhaust for my STi, and hope i dont encounter the same problem...
    when the turbo spins the bull**** ends

    My mods

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •