Factory Subwoofer?
Results 1 to 4 of 4

This is a discussion on Factory Subwoofer? within the Electronics/Car Audio forums, part of the Interior Mods category; Anyone got the factory sub installed in the WRX? If so, is there an internal or external fuse for it? ...

  1. #1
    Registered User DRatedA.W.D's Avatar
    Join Date
    Sep 2004
    Location
    Portland, Oregon
    Posts
    62

    Factory Subwoofer?

    Anyone got the factory sub installed in the WRX? If so, is there an internal or external fuse for it? I don't know if i blew mine or not and want to check for fuses before dismantling the subwoofer. Thanks.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Sep 2004
    Location
    Charles City, IA
    Posts
    12
    I have the factory subwoofer but I have no idea about the location of any fuses? If you find out reply in case anyone else has problems.
    -Bosco

    2004 WRX Sedan
    2004 Yamaha R6

  4. #3
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,591
    I Support ClubWRX
    Pm ej20fan. If he doesn't know, I'm not sure who would

  5. #4
    Registered User DRatedA.W.D's Avatar
    Join Date
    Sep 2004
    Location
    Portland, Oregon
    Posts
    62
    Well, it turned out that the wire connecting the coil to the posts was singed/cut. Probably bumpin it too hard. Could I just solder these wires back together?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •