Pioneer avh-3500bhs
+ Reply to Thread
Results 1 to 7 of 7

This is a discussion on Pioneer avh-3500bhs within the Electronics/Car Audio forums, part of the Interior Mods category; Hey guys, looking for some help with a newly installed pioneer radio in 2013 wrx. I used the Aswc-1 , ...

  1. #1
    Registered User
    Join Date
    Aug 2013
    Posts
    5

    Pioneer avh-3500bhs

    Hey guys, looking for some help with a newly installed pioneer radio in 2013 wrx. I used the Aswc-1 , 20-pin forward harness (with extra connections for Aswc) and several forums to walk me through the install. Everything works great, steering wheel controls, Bluetooth,pandora etc. the only thing that doesn't work is the actual radio (fm radio) . When I go to the "hdradio" screen nothing happens, no frequencies show up.

    Anyone out there seen this before? I checked the wiring again and it all looks good. Any help would be greatly appreciated.

    Thanks,
    Chris

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User cflip2x's Avatar
    Join Date
    Jan 2012
    Location
    New Jersey
    Posts
    1,461
    I Support ClubWRX
    did you forget to pug in the antenna? it may sound silly but with all the connections back there it could have been missed
    2012 WRB 4DR | SPT Exhaust | Short Throw | Rally Armour | WC Lathe Werks Custom TI Knob | Kartboy Bushings | Stoptech Brake Lines | JBK Elements DRL | STI HID Retrofit | XB LED Angel Eyes | GrimmSpeed Lightweight Crank Pulley

    CFLip2x 2012 WRB WRX

  4. #3
    Registered User S20002STI's Avatar
    Join Date
    Aug 2007
    Location
    Garden City, KS
    Posts
    331
    Or it could be a faulty antenna. This happened to me with a brand new unit.

  5. #4
    Registered User
    Join Date
    Aug 2013
    Posts
    5
    I checked the antenna connection, no issues there...

  6. #5
    Registered User
    Join Date
    Aug 2013
    Posts
    5
    Do I need an adapter to use the stock antenna? It plugs in to the new head unit fine, but I have been told that an adapter might be needed? Has anyone had to use one with a pioneer HU before?

  7. #6
    Registered User cflip2x's Avatar
    Join Date
    Jan 2012
    Location
    New Jersey
    Posts
    1,461
    I Support ClubWRX
    You shouldnt maybe contact pioneer maybe you have a faulty HU
    2012 WRB 4DR | SPT Exhaust | Short Throw | Rally Armour | WC Lathe Werks Custom TI Knob | Kartboy Bushings | Stoptech Brake Lines | JBK Elements DRL | STI HID Retrofit | XB LED Angel Eyes | GrimmSpeed Lightweight Crank Pulley

    CFLip2x 2012 WRB WRX

  8. #7
    Registered User dan5505's Avatar
    Join Date
    Sep 2012
    Location
    Montana
    Posts
    73
    I have the same head unit in my 2013. I don't think I have ever used the hd radio so I ran out to the garage and checked mine just now. I can confirm mine works fine for what its worth.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •