Radio install
Results 1 to 3 of 3

This is a discussion on Radio install within the Electronics/Car Audio forums, part of the Interior Mods category; Having trouble with my radio install. I have all the wires correctly spliced, and plugged to the back of the ...

  1. #1
    Registered User stoneeyyy's Avatar
    Join Date
    Apr 2010
    Location
    Chicago
    Posts
    18

    Radio install

    Having trouble with my radio install. I have all the wires correctly spliced, and plugged to the back of the new jvc head unit. Also correctly plugged the power in. Now going to start the car up I have no power to the radio. Checked the fuse box as well and the fuses are all in tact. Any suggestions?...

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,642
    I Support ClubWRX
    Multimeter?
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning, LLC

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  4. #3
    Registered User stoneeyyy's Avatar
    Join Date
    Apr 2010
    Location
    Chicago
    Posts
    18
    It's right around 6 to 8 on 200m. That's probly workings for a new battery. I don't think thy would cause my illumi an radio to not work?!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •