Audio system info - Page 2
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 16 to 18 of 18

This is a discussion on Audio system info within the Electronics/Car Audio forums, part of the Interior Mods category; so I bought the wrong double din surround kit... didnt even fit over the JVC kw-av60bt head unitl ... that ...

  1. #16
    Registered User mgmoehn's Avatar
    Join Date
    Jun 2012
    Location
    Peoria Area - IL
    Posts
    105
    so I bought the wrong double din surround kit... didnt even fit over the JVC kw-av60bt head unitl ... that crutchfield says will fit the car...

    I put the HU in without any brackets or mounting and just put the old bezel back on ... the HU doesnt seem to really "slide" in nicely either... it barely fits onthe top... not even sure that a new double-din surround will work.

    What did you go with... assuming you have the same HU?
    2012 WRX Hatchback ISM - Base Model - STI STS, SPT Boost Gauge, AEM Intake, TP Stage 1 Tune, red illumination kit, cobb shift knob, 20% tint - currently on stock wheels wrapped in Pirelli Winter Carving Edge Tires
    Some cool tidbits to come...

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User mgmoehn's Avatar
    Join Date
    Jun 2012
    Location
    Peoria Area - IL
    Posts
    105
    I bought the Metra kit first and it didnt even fit over the JVC HU...

    Just ordered the Scosche SU2027... hopefully this one works better and actually fits over the HU!
    2012 WRX Hatchback ISM - Base Model - STI STS, SPT Boost Gauge, AEM Intake, TP Stage 1 Tune, red illumination kit, cobb shift knob, 20% tint - currently on stock wheels wrapped in Pirelli Winter Carving Edge Tires
    Some cool tidbits to come...

  4. #18
    Registered User SoFloRex's Avatar
    Join Date
    Jul 2012
    Location
    West Palm Beach
    Posts
    128

    Audio system info

    Quote Originally Posted by mgmoehn View Post
    so I bought the wrong double din surround kit... didnt even fit over the JVC kw-av60bt head unitl ... that crutchfield says will fit the car...

    I put the HU in without any brackets or mounting and just put the old bezel back on ... the HU doesnt seem to really "slide" in nicely either... it barely fits onthe top... not even sure that a new double-din surround will work.

    What did you go with... assuming you have the same HU?
    I took mine to brandsmart cause I don't have the patience for electronics myself. They told me I would have to get a new bezel but I told them I knew the stock one would work and to go ahead with and and I'd buy the bezel later. The stock one works just fine, doesn't look odd at all and the unit is in there pretty solid. I'm not buying the other bezel

+ Reply to Thread
Page 2 of 2 FirstFirst 12

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •