Weird stereo problem
Results 1 to 9 of 9

This is a discussion on Weird stereo problem within the Electronics/Car Audio forums, part of the Interior Mods category; I was attempting to install my pioneer double din aftermarket stereo and I realized I didn't have the harness that ...

  1. #1
    Registered User Browzer's Avatar
    Join Date
    Jan 2012
    Posts
    36

    Weird stereo problem

    I was attempting to install my pioneer double din aftermarket stereo and I realized I didn't have the harness that comes off the aftermarket stereo...thats not the problem lol.

    when I was putting everything back I cant install the stereo back the way it was meant to be installed. Then I realized it was never installed the proper way. I took some pictures to show the problem...

    The person who owned the car before me had the same problem and just drilled it in right below it.




    Idk how to get it lined up perfectly or what the problem is.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    7,581
    I Support ClubWRX
    The metal tabs should line up with the holes in the plastic. It looks like the bottom tabs have been bent inward completely. You need to pull the harness out, straighten those bottom tabs to where they're perpendicular to the side of the harness. Then feed the whole harness back into place where it goes. In you picture it appears to be sitting about half an inch lower than where it should be. There are six screws to hold it, four that are flush in the top, and two that are recessed where your tabs are bent inward.

    Basically, just straighten those tabs out, and line it up with the factory holes.

  4. #3
    Registered User Browzer's Avatar
    Join Date
    Jan 2012
    Posts
    36
    yeah, but it cant fit any higher up. it just gets stuck there. and its weird cause its like inorder to put the HVAC controls back in to put it all back to stock, it feels like it has to be lower? its really weird.

    I have a feeling that something in there isnt legit and is from another model or year.

  5. #4
    Lando Calrissian DemonWRX's Avatar
    Join Date
    Jul 2011
    Location
    Cloud City, Bespin
    Posts
    3,077
    I Support ClubWRX
    Well..... you have a 2005 WRX, and that is a 2003 WRX stereo, so that is likely your issue

    This is what you should have:
    Stink-Eye Mob #39
    N.E.R.D. Operative #8

  6. #5
    Registered User Browzer's Avatar
    Join Date
    Jan 2012
    Posts
    36
    Quote Originally Posted by DemonWRX View Post
    Well..... you have a 2005 WRX, and that is a 2003 WRX stereo, so that is likely your issue

    This is what you should have:
    I f-ing knew it man....I thought I was going insane.

  7. #6
    Registered User Browzer's Avatar
    Join Date
    Jan 2012
    Posts
    36
    i mean it has a tape deck...i thought we were done with tapes in 2002

  8. #7
    Registered User
    Join Date
    Sep 2007
    Posts
    4
    Hey you can either get 05+ radio brackets (that y2kauto site I told u) or honestly if it lines up perfect wit the hole he made I would just leave it..maybe add 2 more screws at the top if u want

  9. #8
    Registered User
    Join Date
    Mar 2012
    Posts
    5
    Get the brackets.

  10. #9
    Registered User Browzer's Avatar
    Join Date
    Jan 2012
    Posts
    36
    got em. It fits perfectly. Its been an adventure trying to get this car back to look the way its supposed to.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •