Stock Boost Gauge Help? (2002 WRX)
Results 1 to 11 of 11

This is a discussion on Stock Boost Gauge Help? (2002 WRX) within the Electronics/Car Audio forums, part of the Interior Mods category; Problem: My factory installed boost gauge won't light up. I bought my '02 WRX wagon last April that came with ...

  1. #1
    Registered User 2002SubieWRX's Avatar
    Join Date
    Apr 2010
    Location
    North Seattle area
    Posts
    333

    Stock Boost Gauge Help? (2002 WRX)

    Problem: My factory installed boost gauge won't light up.

    I bought my '02 WRX wagon last April that came with the factory installed Lamco boost gauge on the column but the light has never worked. I just figured it didn't come with a bulb but recently took it apart and sure enough it does. I went to the local AutoZone, Carquest and O'Reilly's auto parts stores and only found a couple bulbs that were even small enough to fit the gauge but all were a higher voltage/wattage. The bulb reads "S .12V 2W". The only bulbs that were even small enough to fit were 1.2V 12W.

    I bought the 1.2V 12W ones and tried them out but no luck. I don't know if it's the brighter bulb or something wrong with the wiring. Traced the wires under the dash and they are spliced into a connector that plugs into the under dash fuse box then out into a group of more wires. (Does this sound like it's correctly wired?)

    I've read it can be wired off the dimmer on the back of the stock CD player/radio (which is still in the car) but was wondering if this is the only way.

    Any help is much appreciated! Thanks.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Rholman1's Avatar
    Join Date
    May 2008
    Location
    Stamford, CT
    Posts
    133
    Was it easy to take the gauge pod apart and how did you do it? My temperature gauge had been dead (just stayed all the way to the left) since I bought my car 4 years ago, but it recently started randomly spiking back and forth all over the place. Did you just pry the cover up with a screwdriver or something? I'm guessing I just have a loose connection somewhere in there.

  4. #3
    Registered User 2002SubieWRX's Avatar
    Join Date
    Apr 2010
    Location
    North Seattle area
    Posts
    333
    Quote Originally Posted by Rholman1 View Post
    Was it easy to take the gauge pod apart and how did you do it? My temperature gauge had been dead (just stayed all the way to the left) since I bought my car 4 years ago, but it recently started randomly spiking back and forth all over the place. Did you just pry the cover up with a screwdriver or something? I'm guessing I just have a loose connection somewhere in there.
    Are you asking about taking the boost gauge apart or the main gauge cluster in the dash? The boost gauge wasn't very hard. I used a four small flat screwdrivers and gently pried around the gauge until it slides out. The pod is hard rubber but it gives a little bit. Make sure not to pry at the 12-o'clock location as you will break the connector and have to buy a new gauge.

    Hope this helps.

  5. #4
    Registered User KnightFury's Avatar
    Join Date
    Sep 2010
    Location
    salem, oregon
    Posts
    284
    imo i would re-wire the guage to the light bezel so you have control of when the light turns off and on, if the prev bulb wasnt bad then poob gonna be the guage or a bad wire somewhere, if you have a voltmeter this will be an easy test to single out

  6. #5
    Registered User Rholman1's Avatar
    Join Date
    May 2008
    Location
    Stamford, CT
    Posts
    133
    Thank you that does help, yes I meant the turbo gauge pod- I would have tried to pry up the whole cover from the top of the dash, it sound like you basically just pried the face out of it... easier I hope

  7. #6
    Registered User 2002SubieWRX's Avatar
    Join Date
    Apr 2010
    Location
    North Seattle area
    Posts
    333

  8. #7
    Registered User 2002SubieWRX's Avatar
    Join Date
    Apr 2010
    Location
    North Seattle area
    Posts
    333
    KnightFury - I'll look into wiring it to my lights. That would make the most sense to me, but I'm no automotive electrician. Thanks for the tip.

  9. #8
    Registered User KnightFury's Avatar
    Join Date
    Sep 2010
    Location
    salem, oregon
    Posts
    284
    No prob; not to dificult im no electrician either lol but found a helpful diagram that made it a sinch, been lookin but at my work pc am limited acess... Sry

  10. #9
    Registered User 2002SubieWRX's Avatar
    Join Date
    Apr 2010
    Location
    North Seattle area
    Posts
    333
    Quote Originally Posted by KnightFury View Post
    No prob; not to dificult im no electrician either lol but found a helpful diagram that made it a sinch, been lookin but at my work pc am limited acess... Sry
    Hey man did you ever find the diagram you refer to here? I still haven't fixed the light on my boost gauge. Thanks.
    - 2013 BRZ Limited, WRB, manual
    - 2002 WRX WRB Sport Wagon (Stage 1) SOLD
    - 1968 Mercury Cougar w/ custom 331ci stroker & 5-spd
    ~Best 1/4 mi ET: 13.00 Video here--> http://s55.photobucket.com/albums/g1...t=MVI_0378.mp4
    ~Best 1/4 mi Trap Speed: 109mph

  11. #10
    Registered User oguitar's Avatar
    Join Date
    Nov 2009
    Location
    Albuquerque, New Mexico, United States
    Posts
    1,014
    Go to radio shack and try to find the right bulb there.
    Life is like riding a bicycle in order to keep your balance you must keep moving.

  12. #11
    Registered User 2002SubieWRX's Avatar
    Join Date
    Apr 2010
    Location
    North Seattle area
    Posts
    333
    Quote Originally Posted by oguitar View Post
    Go to radio shack and try to find the right bulb there.
    I'll try that thanks!
    - 2013 BRZ Limited, WRB, manual
    - 2002 WRX WRB Sport Wagon (Stage 1) SOLD
    - 1968 Mercury Cougar w/ custom 331ci stroker & 5-spd
    ~Best 1/4 mi ET: 13.00 Video here--> http://s55.photobucket.com/albums/g1...t=MVI_0378.mp4
    ~Best 1/4 mi Trap Speed: 109mph

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •