Help with Axxess ASWC?
+ Reply to Thread
Results 1 to 8 of 8

This is a discussion on Help with Axxess ASWC? within the Electronics/Car Audio forums, part of the Interior Mods category; has anyone installed one of these? i just got mine in but am a little confused by the directions. i ...

  1. #1
    Registered User
    Join Date
    Jan 2011
    Posts
    23

    Help with Axxess ASWC?

    has anyone installed one of these? i just got mine in but am a little confused by the directions. i have no clue what wires to use or anything. i have a 2008 impreza wrx without stock navigation. any help is appreciated....

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,863
    I Support ClubWRX
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  4. #3
    Registered User
    Join Date
    Jan 2011
    Posts
    23
    Well, I didn't know about that harness so I purchased a different one. The one I have does NOT have pin 4 or 14. Does this mean I have to hack into my factory harness for those 2 connections. This is what I have so far. The black wire AND the green/white wire on the ASWC harness is going to the black (ground( wire on my aftermarket harness. The red wire on the ASWC harness is going to the red wire on my aftermarket harness. No other wires connected. From what I understand, I need to connect the gray/red wire on the ASWC harness to pin 4 on the stock harness and pin 14 on the stock harness needs to go to ground. Is that correct? What is the best way to do this if that is correct?

  5. #4
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,863
    I Support ClubWRX
    Quote Originally Posted by dustintinsley
    Well, I didn't know about that harness so I purchased a different one. The one I have does NOT have pin 4 or 14. Does this mean I have to hack into my factory harness for those 2 connections. This is what I have so far. The black wire AND the green/white wire on the ASWC harness is going to the black (ground( wire on my aftermarket harness. The red wire on the ASWC harness is going to the red wire on my aftermarket harness. No other wires connected. From what I understand, I need to connect the gray/red wire on the ASWC harness to pin 4 on the stock harness and pin 14 on the stock harness needs to go to ground. Is that correct? What is the best way to do this if that is correct?
    I haven't installed one.

    The pin-layout page describes differences between OE/aftermarket harnesses:
    Subaru 20-pin radio harness pin-out

    Does your aftermarket harness not have brown and brown/black wires?
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  6. #5
    Registered User
    Join Date
    Jan 2011
    Posts
    23
    No, my harness does not have those wires...

  7. #6
    Registered User SVXdc's Avatar
    Join Date
    Mar 2005
    Location
    Atlanta, GA
    Posts
    47
    Quote Originally Posted by EJ257 View Post
    Does your aftermarket harness not have brown[/red] and brown/black wires?
    Mine are the only harnesses with those wires. All of the other harness manufacturers omit the SWC wires.

    Quote Originally Posted by dustintinsley View Post
    The [harness] I have does NOT have pin 4 or 14. Does this mean I have to hack into my factory harness for those 2 connections.
    Yes.

    This is what I have so far. The black wire AND the green/white wire on the ASWC harness is going to the black (ground) wire on my aftermarket harness.

    The red wire on the ASWC harness is going to the red wire on my aftermarket harness.

    From what I understand, I need to connect the gray/red wire on the ASWC harness to pin 4 on the stock harness and pin 14 on the stock harness needs to go to ground.

    Is that correct?
    Yes. [those instructions apply to 2008-2010 models, and 2011 models without the phone buttons on the steering wheel]

    What is the best way to do this ?
    People have had bad results trying to use "vampire" taps on the factory wires, in part because the factory wires are so small (20 gauge).

    The best way would be to add the missing pins/wires (into pins 4 and 14) of the aftermarket harness you already have. You can get a second 20-pin harness and "transplant" two wires from it to your first harness. In some cases I will provide the extra wires. E-mail me for details.

    I haven't tried them myself, but have seen recommendations to use these: Posi-Tap- No Crimp Tap
    Last edited by SVXdc; 01-21-2011 at 06:42 PM.

  8. #7
    Registered User 07 Boosty's Avatar
    Join Date
    Mar 2013
    Posts
    14
    Quote Originally Posted by dustintinsley View Post
    This is what I have so far. The black wire AND the green/white wire on the ASWC harness is going to the black (ground( wire on my aftermarket harness. The red wire on the ASWC harness is going to the red wire on my aftermarket harness. No other wires connected. From what I understand, I need to connect the gray/red wire on the ASWC harness to pin 4 on the stock harness and pin 14 on the stock harness needs to go to ground. Is that correct?
    Quote Originally Posted by SVXdc View Post
    Yes. [those instructions apply to 2008-2010 models, and 2011 models without the phone buttons on the steering wheel]
    Kinda late, but.....

    I have a 2011 WRX that does have the phone buttons on the steering wheel. No navi. Are these instructions the same or are there additional wires that need to be connected?
    Last edited by 07 Boosty; 05-22-2013 at 12:54 PM.
    -Jay
    11 WRX Hatchback
    07 WRX STI (RIP)
    Hawk-Eye Alliance #1024 | Stink-Eye Mob #1024

  9. #8
    Registered User
    Join Date
    Jan 2012
    Location
    Upstate NY
    Posts
    15

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •