2011 STI Stereo (Pioneer) Install
Results 1 to 6 of 6

This is a discussion on 2011 STI Stereo (Pioneer) Install within the Electronics/Car Audio forums, part of the Interior Mods category; I put my Pioneer AVH-3200BT in my STI last night. First off, it drives the stock speakers very well. The ...

  1. #1
    Supporting Member mjboudreaux77's Avatar
    Join Date
    Sep 2007
    Location
    Northern Vermont
    Posts
    843
    I Support ClubWRX

    2011 STI Stereo (Pioneer) Install

    I put my Pioneer AVH-3200BT in my STI last night. First off, it drives the stock speakers very well. The stock stereo would distort quickly (though it sounded ok at lower volumes). The Pioneer doesn't distort - just sounds amazing. The stocker also sounds terrible when listening to the radio - it only sounds decent with listening to an aux/cd input. The pioneer sounds great either way.


    Some informational stuff for those who are going to do this:
    1.) I couldn't find an easy way to wire the e-brake, so I went the "bypass" route. Worked very well. For those interested - this is a great "how to" specific for the Pioneers:

    http://www.caraudioparts.net/pioneer...vd-bypass.html

    You can not just ground the connection - it won't work.

    2.) If you buy the 20pin connector from Crutchfield, or a local shop - they don't seem to pin out the antenna power conncection. If you look at the link below, it is pin 9:

    http://ae64.com/20-pin-pinout.htm

    To get around this - I just wired it to my remote turn on and it worked fine. I didn't do this in my last car - and couldn't get a radio station to come in even if I was sitting under the stations broadcast antenna. Now my reception is as good as the stock stereo.

    3.) I also installed my BOSS Audio low profile 8 inch sub. I placed it under the passenger seat just as I did on my 07 WRX. On my 2007, this added a lot and sounded great. I think the issue for me now is the seats sit lower to the floor than the 07. The BOSS needs a certain amount of air clearance between it and anything above it if you really want to drive it hard - otherwise it resonates and sounds like a blown speaker. I have left it in for now, but I have had to turn the volume so far down you barely notice it is on.

    4.) Lastly... I don't know how long I will keep this stereo in. Even though it sounds so incredible - I now have an iPod wire hanging out the front of the stereo since you loose your armrest connection. Also, the angle the stereo sits has really bad glare. When the sun hits, you can't see any of the screen. I am going to look around for an anti-glare screen to see if that helps at all. I will update if I find one that works.
    Last edited by mjboudreaux77; 11-13-2010 at 07:43 AM. Reason: added subwoofer stuff
    If I don't die by Thursday, I'll be roarin Friday night - Jimmy Buffett

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User MrDavros2U's Avatar
    Join Date
    Aug 2010
    Location
    Bucks County PA
    Posts
    40
    I was looking at this exact same unit today on Crutchfield.

    Can you let me know how long the install took, and any chance you could post some pictures?

    Thanks, and congrats

  4. #3
    Registered User Ashesofthewake's Avatar
    Join Date
    Oct 2009
    Location
    CNJ
    Posts
    107
    Quote Originally Posted by mjboudreaux77 View Post
    I now have an iPod wire hanging out the front of the stereo since you loose your armrest connection.
    Can't you just run it into the glovebox? I had my ipod cable run behind the dash and into the glovebox when I had my legacy.

  5. #4
    The Fruit mangostick's Avatar
    Join Date
    Oct 2009
    Location
    VB VA .. the ghetto on the sea
    Posts
    4,735
    There's a write up somewhere on keeping the original aux jack location and running the wire to it from the new unit. All the parts needed are available between parts express and radio shack.. with some slight ingenuity it should be pretty easy.
    OBP 2010 5dr *traded*
    SWP 2013 FRS
    My name is Shawn, I'm a Devout Practicalist and I'm addicted to flat4's
    This page has had 1,666 visits
    SUCH IS MANGO!

  6. #5
    Supporting Member mjboudreaux77's Avatar
    Join Date
    Sep 2007
    Location
    Northern Vermont
    Posts
    843
    I Support ClubWRX
    I attached a blackberry pic (so its awful) of the radio. The install kit wasn't the crutchfield one, because a local shop had this one for $10. It worked fine.

    I have done many stereo installs, including putting this model in my 2007 WRX - so I was already familiar with the wiring and instructions. This install took me 30 minutes. I just put my stock stereo back in and it took 10. Had I never seen the unit before, and not had Mangostick's advice on removing the dash piece, it would have taken an hour or so... I did not purchase the PAC steering wheel control module - so I don't know how much longer that would have taken.

    This stereo is definitely awesome. It really sounds incredible. The car "booms" without a sub when using the stock speakers and this unit. I took it back out since I am still dorkin with the local dealer on getting my door rattles fixed. I have temporarily fixed the rattles myself - but I want a permanent fix from them and I don't want them blaming this thing. The only negative I can say about this model is the glare is just awful. When the sun hits it, the screen is un-usable. This didn't happen as bad in my 07 - the angle of the new Subie HUs is definitely pointing more upward than before.

    I don't believe I can run the ipod cable anywhere from the back. The AVH-3200DVD and AVH-4200 have ports on the back, so I can see how that would work. The AVH-3200BT (which I thought was identical to the 3200DVD except it has blue tooth built in) only has the usb port on the front. When I bought it, I didn't care because I wanted the SD card in the front - little did I know at the time that iTunes wasn't going to let me copy 1/2 of my music to the SD card.

    Does someone have a 3200BT and have a cable that allows the ipod to connect to the back? If so - please let me know how you did that!
    Attached Thumbnails Attached Thumbnails pioneer_in_sti2.jpg  
    If I don't die by Thursday, I'll be roarin Friday night - Jimmy Buffett

  7. #6
    The Fruit mangostick's Avatar
    Join Date
    Oct 2009
    Location
    VB VA .. the ghetto on the sea
    Posts
    4,735
    Nice, looks like the scosche install kit. Its the same one I used.. except I shaved 1/4" off the inside so the face of the radio sits flush with the face of the install kit.

    Looks good man, I hear ya on the glare though.. My pioneer has a very similar problem.. window tint helps but mine isn't dark.. so.. I still have that glare issue at certain angles.
    OBP 2010 5dr *traded*
    SWP 2013 FRS
    My name is Shawn, I'm a Devout Practicalist and I'm addicted to flat4's
    This page has had 1,666 visits
    SUCH IS MANGO!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •