2009 premium stereo opinions
Results 1 to 8 of 8

This is a discussion on 2009 premium stereo opinions within the Electronics/Car Audio forums, part of the Interior Mods category; Hi All, I'm very new to the Rex gang -- bought an '09 Premium sedan last week. :-) I'll eventually ...

  1. #1
    Registered User
    Join Date
    May 2009
    Location
    Denver, CO
    Posts
    4

    Question 2009 premium stereo opinions

    Hi All,

    I'm very new to the Rex gang -- bought an '09 Premium sedan last week. :-)

    I'll eventually get into tuning, but she performs great for me for now. I must do something with the stereo, though. I'm not an audiophile, but my ears do demand something better than what's currently in there.

    From my last vehicle, I have an Alpine deck with iPod adapter, a pair of Infinity component 6 1/2 door speakers w/ separate tweeter, and a 10" sub with an amp.

    My questions:

    1) Should I install the Alpine deck, or just use the factory HU? Alpine decks rock and it powers the door speakers handily, but I'm assuming I'd need an external amp if I keep the factory HU. I'd also have to buy the iPod integration kit if I keep the HU. I love my Alpine deck, but I also like the clean look of the factory HU. The factory HU is also much less of a target for thieves...

    2) If I install the Alpine deck, is there an easy way to maintain the functionality of the steering wheel radio controls? I don't want them to be useless if they're right in front of me.

    I know there could be lots of "it depends" answers, but if there are any car audio junkies out there with strong feelings one way or the other, I'd love to hear from you.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User VideoCrack's Avatar
    Join Date
    Apr 2009
    Location
    Syracuse
    Posts
    31
    i know crutchfield offers a harness to keep the steering wheel controls on an aftermarket deck. It also depends on if the deck is compatible. I am also having the same debate and my car hasnt arrived yet. Hopefully Wednesday.... I have a pioneer avic that i will probably switch from my 2.5i to the new one and start from there. I got the premium package as well.

  4. #3
    Registered User economatic's Avatar
    Join Date
    May 2009
    Location
    Portland, OR
    Posts
    840

    Ditch the factory HU

    I was hopeful that if I replaced all the speakers and added a sub to the factor HU I would get an improvement out of my '09 premium but was terribly disappointed. I put two sets of Infinity 6.5's in the doors (sorry, don't remember the model) and can't say I even noticed a difference. Of course the sub was an improvement but when everything else sounds like crap its difficult to be satisfied. In short, the factory HU is junk even though it is a Clarion.

    Re: the steering wheel controls, I'm not sure about Subarus but there is an adapter out there (look at Crutchfield, it starts with SWI- ). I used one with a Kenwood HU in my Nissan Frontier and it worked with most vehicles you just need a wired remote output from your Alpine (pretty sure most top of the line ones will have it). However, don't be optimistic that the adapter will interface seamlessly. The one I used had a delay when pushing the buttons and I couldn't increase the volume one unit at a time. As a result I rarely used the steering wheel buttons.

  5. #4
    Registered User
    Join Date
    Jun 2008
    Location
    Scottsdale, AZ
    Posts
    50
    I wouldn't use crutchfield unless their the only place you can find the adapter. They rip people off so bad.

  6. #5
    Registered User
    Join Date
    May 2009
    Location
    Denver, CO
    Posts
    4

    Update

    I ended up replacing the factor HU with the Alpine. I spoke with some installers and they said that even if I'd add external amps to the factory HU, the sound wouldn't be as good as the Alpine deck. Apparently amping HUs requires too many integration points and sound quality tends to suffer.

    I was able to get an adapter for the steering wheel controls, but there is definitely a lag. All the buttons work, but there's about a 1-second delay. Also, I can only adjust the volume 1 increment at a time, which is pretty annoying. However, it's really not too difficult to reach for the good ol' knob on the actual HU... :-)

  7. #6
    UnBanned Sinister's Avatar
    Join Date
    Nov 2006
    Location
    Denver Metro Area
    Posts
    17,628
    I Support ClubWRX
    Welcome fellow Denver-ite!
    Kevin
    Moderator
    Sinister's Blowoff Valve FAQ
    WRX Gas Mileage FAQ
    Sinister's Progress Thread - 430whp 429wtq - Sold
    Firearms Enthusiasts Thread

    The Sheriff's Star at the bottom left corner rates a user's reputation.
    If you found a user's post to be helpful or quite the opposite, please make it known to them by clicking the Star!

  8. #7
    Registered User elwray's Avatar
    Join Date
    Nov 2008
    Location
    Central NJ
    Posts
    991
    Quote Originally Posted by ephilli2 View Post
    I ended up replacing the factor HU with the Alpine. I spoke with some installers and they said that even if I'd add external amps to the factory HU, the sound wouldn't be as good as the Alpine deck. Apparently amping HUs requires too many integration points and sound quality tends to suffer.

    I was able to get an adapter for the steering wheel controls, but there is definitely a lag. All the buttons work, but there's about a 1-second delay. Also, I can only adjust the volume 1 increment at a time, which is pretty annoying. However, it's really not too difficult to reach for the good ol' knob on the actual HU... :-)
    Glad to hear it worked out for ya. I used a SWI-JACK with my Kenwood HU, and there is a delay as well. That is the reason I opted for the smaller screen with volume knob to reach for, instead of the more expensive full double din screen.
    2009 WRX Hatch PP Dark Gray Metallic
    Torqued Performance Stage 1
    Cobb CBE
    Kenwood DNX5120

  9. #8
    Registered User SVXdc's Avatar
    Join Date
    Mar 2005
    Location
    Atlanta, GA
    Posts
    46
    Quote Originally Posted by ephilli2 View Post
    I was able to get an adapter for the steering wheel controls, but there is definitely a lag. All the buttons work, but there's about a 1-second delay. Also, I can only adjust the volume 1 increment at a time, which is pretty annoying. However, it's really not too difficult to reach for the good ol' knob on the actual HU... :-)
    Does your Alpine have a jack or wire for wired SWCs, or did you have to use the SWI-X (infrared version)?

    Is your SWI unit the newer ones in the small blue enclosure, or the older kind in the black enclosure?

    I recently met with a sales manager for PAC, who gave me these tips for programming:

    • When you reach the step where you will "teach" the unit the steering buttons, and the instructions say to "turn the key to Accessory," go ahead and crank the engine. This is so that the car's voltage will be at the level it will normally be when you use the SWCs. That can affect the resistance/voltage levels that the SWI module sees during operation.


    • As you program each SWC button, press and hold firmly for 2 seconds (i.e., keep holding it a little after you get the LED confirmation). Don't just tap the button. Don't anticipate the timing of the LED.

    So you might try clearing and reprogramming this way. Let us know if things improve.

    BTW, I'm in the process of making radio harnesses that include the SWC wires, so you don't have to tap into the car's wire. None of the harnesses from aftermarket harness manufacturers include those wires. PM or e-mail me for more info.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •