2009 wrx stereo help - Page 5
+ Reply to Thread
Page 5 of 5 FirstFirst 12345
Results 61 to 70 of 70

This is a discussion on 2009 wrx stereo help within the Electronics/Car Audio forums, part of the Interior Mods category; Hi everyone. I am new to this site. I just got my 2010 WRX 4door Premium yesterday and I am ...

  1. #61
    Registered User
    Join Date
    Jan 2010
    Posts
    3
    Hi everyone. I am new to this site. I just got my 2010 WRX 4door Premium yesterday and I am not pleased with the system. But it sounds ok when I play a MP3, but the radio sux. I just ordered a Pioneer AVIC-Z110BT, Diamond D662 for the front, Diamond D661 ( I had these from my previuos car), JL Audio 6 CH amp (had also), and a MTX box (had too), steering wheel control adapter to work with new radio, and IPOD adapter. I plan on doing the install myself. I have the 10 speaker system. Since the D662's have detachable tweeters, I am putting them where the existing tweeters are and I am putting the D661 in the rear. Is there a factory amp in the car or do I have to rerun all speaker wires? My previuos car (2008 Audi TT) had the amp in the trunk and I tapped into the speaker wires and used the stock Navi unit with a JL DSP Clean Sweep (which I am selling for $100 if anyone is interested).

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #62
    Registered User
    Join Date
    Sep 2009
    Posts
    6

    Factory underseat sub with a custom Apline deck?

    Do you guys know if that's possible? Would I need an adapter? Don't have $$ right now for the stand-alone amplifier, also don't want to take up space in back.

    Many thanks!

  4. #63
    Registered User Nigel79's Avatar
    Join Date
    Oct 2009
    Posts
    95
    Quote Originally Posted by shatty View Post
    Hi everyone. I am new to this site. I just got my 2010 WRX 4door Premium yesterday and I am not pleased with the system. But it sounds ok when I play a MP3, but the radio sux. I just ordered a Pioneer AVIC-Z110BT, Diamond D662 for the front, Diamond D661 ( I had these from my previuos car), JL Audio 6 CH amp (had also), and a MTX box (had too), steering wheel control adapter to work with new radio, and IPOD adapter. I plan on doing the install myself. I have the 10 speaker system. Since the D662's have detachable tweeters, I am putting them where the existing tweeters are and I am putting the D661 in the rear. Is there a factory amp in the car or do I have to rerun all speaker wires? My previuos car (2008 Audi TT) had the amp in the trunk and I tapped into the speaker wires and used the stock Navi unit with a JL DSP Clean Sweep (which I am selling for $100 if anyone is interested).
    You have to re-run the wires. The factory head unit is crap. There was a huge difference when I installed my pioneer avh-d4200. Also the factory holes were too small to house my MB Quarts Tweets so I had to custom mount them in the doors so keep that in mind.
    Last edited by Nigel79; 04-15-2010 at 06:25 PM.
    '09 Sti

  5. #64
    Registered User Nigel79's Avatar
    Join Date
    Oct 2009
    Posts
    95
    Quote Originally Posted by mEmENT0m0RI View Post
    Do you guys know if that's possible? Would I need an adapter? Don't have $$ right now for the stand-alone amplifier, also don't want to take up space in back.

    Many thanks!
    Just mount an amp under the other seat. I have an amp for my sub under the drivers seat and one for my highs under the passenger seat. An amp for that little sub should be cheap. I would have thought that the factory sub came with a built in amp?
    Last edited by Nigel79; 04-15-2010 at 06:26 PM.
    '09 Sti

  6. #65
    Registered User
    Join Date
    Sep 2009
    Posts
    6
    Quote Originally Posted by Nigel79 View Post
    Just mount an amp under the other seat. I have an amp for my sub under the drivers seat and one for my highs under the passenger seat. An amp for that little sub should be cheap. I would have thought that the factory sub came with a built in amp?
    Factory sub does come with the amp built-in, however, I was told that it may not work with a custom deck because of connectors, wiring, etc...

  7. #66
    Registered User elwray's Avatar
    Join Date
    Nov 2008
    Location
    Central NJ
    Posts
    997
    Quote Originally Posted by mEmENT0m0RI View Post
    Factory sub does come with the amp built-in, however, I was told that it may not work with a custom deck because of connectors, wiring, etc...
    I have the Factory upgraded sub and an aftermarket stereo. The sub works off speaker line ins, so it's transparent to a new deck install.
    2009 WRX Hatch PP Dark Gray Metallic
    Torqued Performance Stage 1
    Cobb CBE
    Kenwood DNX5120

  8. #67
    Registered User
    Join Date
    Sep 2009
    Posts
    6
    Quote Originally Posted by elwray View Post
    I have the Factory upgraded sub and an aftermarket stereo. The sub works off speaker line ins, so it's transparent to a new deck install.
    I apologize if I ask a lame question - I'm not a big specialist in car stereo. My number one problem right now is that the existing speakers can not handle lows and vibrate.
    I was told that installing the sub would not solve this problem by itself unless there are crossovers configured (my deck has separate sub volume). Would that be achievable in this configuration?

    Thanks

  9. #68
    Registered User elwray's Avatar
    Join Date
    Nov 2008
    Location
    Central NJ
    Posts
    997
    Quote Originally Posted by mEmENT0m0RI View Post
    I apologize if I ask a lame question - I'm not a big specialist in car stereo. My number one problem right now is that the existing speakers can not handle lows and vibrate.
    I was told that installing the sub would not solve this problem by itself unless there are crossovers configured (my deck has separate sub volume). Would that be achievable in this configuration?

    Thanks
    Ah, okay. My stereo does have dedicated outputs for a sub as well, however I left it connected to the speaker lines as it came from the dealership so I didn't have to mess with much more.

    I don't have much info for you; I'll have to defer to someone else with more knowledge. But, as one possibility, you could sell the factory option subwoofer setup, and replace it with something like this:

    Boss Audio BASS600 - The one to get w/ pictures! - IWSTI.com: Subaru WRX STI Forums

    Got some nice reviews, and it's affordable.

    Good luck
    2009 WRX Hatch PP Dark Gray Metallic
    Torqued Performance Stage 1
    Cobb CBE
    Kenwood DNX5120

  10. #69
    Registered User
    Join Date
    Apr 2011
    Posts
    1

    Nav System 09 Subaru Sound Upgrade

    Hey all, this is my first post. I'm a proud new owner of a 2009 Subaru WRX w/ the navigation system. I'm wanting more out of my sound system without replacing the head unit obviously. I own an Infinity reference 475a 4 channel amp that I pulled out of my trade in (98 Mitsubshi Eclipse GS-T). How hard would it be to set up the amp? I'm not looking to do a lot of wire splicing and changes. The main thing I'm looking to gain is some bass, so would I be better off just adding in the Subaru subwoofer under the seat?

    In short I'm looking for the simplest, most cost effective way to add more kick to my sound system without changing out the head unit.

    Thanks in advance....

  11. #70
    Registered User
    Join Date
    Apr 2011
    Posts
    1
    Hi, I recommend reading this thread, from start to finish. I came here with exactly the same question, read this thread, and went out and bought and Amp today!

+ Reply to Thread
Page 5 of 5 FirstFirst 12345

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •