Investigating my front speaker noise.. and considering upgrades.
Results 1 to 7 of 7

This is a discussion on Investigating my front speaker noise.. and considering upgrades. within the Electronics/Car Audio forums, part of the Interior Mods category; I heard some buzzing on my right side speaker today. First time I've heard it in the 3 weeks I've ...

  1. #1
    Registered User
    Join Date
    Nov 2005
    Location
    Bay Area, CA
    Posts
    303

    Investigating my front speaker noise.. and considering upgrades.

    I heard some buzzing on my right side speaker today. First time I've heard it in the 3 weeks I've had the car. 2005 WRX. I was pleasantly surprised at how easy it is to get the door panels off.

    First, you remove 2 screws. They are under little flip up caps. One is inside the armrest bucket, and the other is behind the inner door handle. Once I had each screw out, I was able to carefully pull the plastics off. The armrest plastic which holds the window switches just snapped right out. I started from the rear and it came out pretty easy. The door handle plastic was a bit stubborn, and I thought I had broke something. But it did come off perfectly also.

    Next, you just pop the door panel off carefully. I started at the bottom where there was a little gap. I have door panel pliers but they werent much use, I just used my hands.

    I then saw my front speaker which is not paper, but a synthetic type plastic sort of. The magnet was the funniest thing I ever seen, and it was about the diameter of a quarter.

    I do have the tweets in the door handle piece also. I have no idea if I have the factory subwoofer, I doubt I do or I'd know.

    Nothing looked funny in my main speaker, so I just reinstalled it. I did trim the plastic speaker bezel from the inside of the door panel while I had it off. Just in case it was causing some vibrations.

    I am no longer into car stereo, so I plan to keep it stock. Resale value is a big point, no one likes a hacked up car and loose dooor panels. I might be one of the few that buys that $135 speaker upgrade kit, not because I think it will be better, but just so it works properly. I want to keep the car bone stock if possible.

    The "upgrade" speaker kit usually mentioned 06, and not 05. I'm trying to find out if it is also spec'ed for 2005 models. I guess that just because a car has the "6 speaker" setup, it doesnt neccessarily mean it has the OEM subwoofer?



    *************************************************

    I have had the McIntosh, Focal Kevlars, TRU, and Brax in my younger days, and I just have no desire for that level of sound anymore. Some eye candy of what I've had, to make this post more interesting:























    2011 VW GTI - K04

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User bikefreax's Avatar
    Join Date
    Jan 2006
    Location
    Columbia
    Posts
    403
    I had the same buzzing and found out it was the door panel vibrating against the metal in the door handle area. Put sonr foam on top and its gone. Kind of hard to explain but with the door off you see the metal handle.
    '05 WRX Wagon San Remo Red, Stage ?????????????

  4. #3
    Registered User
    Join Date
    Nov 2005
    Location
    Bay Area, CA
    Posts
    303
    Quote Originally Posted by bikefreax View Post
    I had the same buzzing and found out it was the door panel vibrating against the metal in the door handle area. Put sonr foam on top and its gone. Kind of hard to explain but with the door off you see the metal handle.
    the two 90 degree brackets?
    2011 VW GTI - K04

  5. #4
    gil
    gil is offline
    Registered User
    Join Date
    Feb 2006
    Location
    Central Jersey
    Posts
    389
    I've got an 06 rex . I put in an aftermarket jvc head unit with the proper wire harness and now my right front speaker keeps cutting out. If I tap on the side of the dashboard where the head unit is it'll come back on but only for a minute or two. Does anybody know what the problem could be ?BTW sorry for hijacking your thread.

  6. #5
    Registered User
    Join Date
    Nov 2005
    Location
    Bay Area, CA
    Posts
    303
    Quote Originally Posted by gil View Post
    I've got an 06 rex . I put in an aftermarket jvc head unit with the proper wire harness and now my right front speaker keeps cutting out. If I tap on the side of the dashboard where the head unit is it'll come back on but only for a minute or two. Does anybody know what the problem could be ?BTW sorry for hijacking your thread.
    how did you connect the aftermarket harness to your new decks harness? solder? twisted wire? crush connectors? The obvious first check would be to pull out the deck and check for loose wire there.
    2011 VW GTI - K04

  7. #6
    gil
    gil is offline
    Registered User
    Join Date
    Feb 2006
    Location
    Central Jersey
    Posts
    389
    Quote Originally Posted by plac View Post
    how did you connect the aftermarket harness to your new decks harness? solder? twisted wire? crush connectors? The obvious first check would be to pull out the deck and check for loose wire there.
    actually I bought the correct harness from comp usa and it plugged right into both ends. And yeah I guess I'll have to pull out the head unit and check it out . THANKS

  8. #7
    Registered User
    Join Date
    Nov 2005
    Location
    Bay Area, CA
    Posts
    303
    Quote Originally Posted by gil View Post
    actually I bought the correct harness from comp usa and it plugged right into both ends. And yeah I guess I'll have to pull out the head unit and check it out . THANKS
    oh ok. most aftermarket harnesses i see only have a plug on one end. and you have to splice the other end.
    2011 VW GTI - K04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •