MY05 Radio Problem...
+ Reply to Thread
Results 1 to 7 of 7

This is a discussion on MY05 Radio Problem... within the Electronics/Car Audio forums, part of the Interior Mods category; Hey guys I had a question about a problem I'm having with my radio. I was driving along listening to ...

  1. #1
    Registered User rexSTi's Avatar
    Join Date
    Jan 2006
    Location
    California
    Posts
    31

    MY05 Radio Problem...

    Hey guys I had a question about a problem I'm having with my radio. I was driving along listening to my stereo and out of no where the cd stopped playing. It showed which disc it was playing but didn't show the track number or time information at all. Then I checked to see if it was just that cd. Nope, it was all of 'em. Then I checked the radio and it works fine. Anybody have any ideas on what it might be. I was thinking the ribbon cable that connects the CD changer to the radio but haven't had time to take the radio apart and check. Oh yeh, its model is the P-133. Any help would be appreciated.

    ~Chad

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Skreekin's Avatar
    Join Date
    May 2005
    Location
    Bellingham, WA
    Posts
    1,582
    Quote Originally Posted by rexSTi
    Hey guys I had a question about a problem I'm having with my radio. I was driving along listening to my stereo and out of no where the cd stopped playing. It showed which disc it was playing but didn't show the track number or time information at all. Then I checked to see if it was just that cd. Nope, it was all of 'em. Then I checked the radio and it works fine. Anybody have any ideas on what it might be. I was thinking the ribbon cable that connects the CD changer to the radio but haven't had time to take the radio apart and check. Oh yeh, its model is the P-133. Any help would be appreciated.

    ~Chad
    I will assume that you have the stock in dash 6 disc changer, right? I had a similar problem with mine. One day I switched CDs and it just kept shuffling around but never playing any of the CDs. Common bug for these head units. I believe that the deck is made by Panasonic for Subaru. Will it eject the CDs? Your car should still be under warranty, so take it into the dealer and have them take a look at it. Odds are they will have to order you a new deck and when it comes in they will swap it out with the broken one. After that, I suggest that you start thinking about a new deck anyway, there are plenty of more reliable/higher powered head units out there that you will like better than the stock one.
    2005 WRB WRX Stage 2
    Blobeye Syndicate #76
    A Must Read http://www.clubwrx.net/forums/engine...do-not-do.html

  4. #3
    Registered User D0WNxSH1FT's Avatar
    Join Date
    Oct 2004
    Location
    Westchester Cnty, NY
    Posts
    6,545
    I have my stock 05 6disk headunit out of my car. Let me know if you want to buy it. it works perfectly.
    2008 Satin White Pearl WRX Sedan w/ Navi
    2005 San Remo Red WRX Sedan w/ VF34 (traded)
    Pi Kappa Alpha | New England Flat 4

  5. #4
    Registered User Death To Ricers's Avatar
    Join Date
    Jan 2004
    Location
    Phoenix, AZ
    Posts
    1,930
    Same thing happend to me a few times. If you just eject the CD then wait a few seconds then stick it back in.It will work fine after that.
    2006 WRX
    Quote Originally Posted by RayfieldsWRX View Post
    You could vote to fix me a sammich.

  6. #5
    Registered User mike05STi's Avatar
    Join Date
    Jan 2006
    Location
    Nashville, TN
    Posts
    2,720
    My cd changer for some reason does not like burned CDs. They seem to skip every now and then when they don't in my Pathfinder, nor on my laptop. It has NO problem with store bought CDs.
    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.
    -Albert Einstein

    Some people go through their whole lives wondering if they ever made a difference in the world. Marines don't have that problem.
    -Ronald Reagan

  7. #6
    Registered User Darrell's Avatar
    Join Date
    Sep 2004
    Location
    Indy, IN
    Posts
    715
    Sounds like a great reason to upgrade!
    Mine: '05 PSM WRX 5MT Sport Wagon, Cobb AP
    Wife's: '05 SRR 2.5RS 5MT Sport Wagon

    The Knack. It's a rare condition characterized by an extreme intuition about all things mechanical and electrical ... and utter social ineptitude.

  8. #7
    Registered User rexSTi's Avatar
    Join Date
    Jan 2006
    Location
    California
    Posts
    31
    yeh i plan on getting a kenwood ddx-8017 but until then i'm just using the stock with a LOC. It's weird tho cuz i've tried ejecting everything waiting and putting it back in but still it wont respond. I can hear the cd spinning too. And it doesn't work with store bought cd's either. but the radio works so i guess i'll have to just listen to that crap....or i could jus listen to that great boxer rumble. I think im gunna have to make an appointment...

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •