When SUVs start pulling on you, you know...
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 25

This is a discussion on When SUVs start pulling on you, you know... within the Comparison: WRX vs World forums, part of the Community - Meet other Enthusiasts category; ...something is definetly WRONG with your car! driving to work today, i had to KEEP UP with a bmw X5! ...

  1. #1
    Moderator Penguinking's Avatar
    Join Date
    Nov 2001
    Location
    Houston, TX / Athens, GA -at the same time!
    Posts
    2,472
    I Support ClubWRX

    When SUVs start pulling on you, you know...

    ...something is definetly WRONG with your car!

    driving to work today, i had to KEEP UP with a bmw X5! i read my boost gauge and i was only making 10psi, tops?!! i feel like i've lost all my torque - normally the car keeps pullling in 4th @ 60mph, but this time i had to downshift into 3rd to follow the bimmer

    i was humiliated today...(hanging head in shame)
    Silver 911
    WRX's older brother

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User PlatinumWRX's Avatar
    Join Date
    Jul 2001
    Location
    PA
    Posts
    6,581
    10psi??!? What the hell is wrong with your car?

    -Jim

  4. #3
    Registered User slin02's Avatar
    Join Date
    Feb 2002
    Location
    Carol Stream, IL
    Posts
    555
    read my signature.
    8 psi ( what I get everytime for 5 min when I adjust my sbc-id ) and integra type R= I lost.
    my car is slow,,,,,, very slow.

  5. #4
    Moderator Penguinking's Avatar
    Join Date
    Nov 2001
    Location
    Houston, TX / Athens, GA -at the same time!
    Posts
    2,472
    I Support ClubWRX
    i honestly think its an exhaust leak, but i don't hear the highpitched whiny noise when i go hard on the gas. and if the leak was big enuf to drop me to 10psi, there would be a significantly louder exhauste sound comming from the engine bay around the uppipe, and i'm not hearing that either. so i'm dumbfounded for right now.
    Silver 911
    WRX's older brother

  6. #5
    Registered User 2001S4's Avatar
    Join Date
    Feb 2002
    Posts
    845
    Keep in mind that the X5 is not a slow truck to begin with. I do believe they were releasing an "M" version of the truck (it may not have been labeled M though). I think it was supposed to share the V8 engine with the M5. If that is the case and you lost to one, than don't feel so bad. However, check out your car and find out what is wrong. Loosing boost definitely sucks.

  7. #6
    Registered User
    Join Date
    May 2002
    Posts
    899
    The X5 4.6is is the equivalent of an M-variant of an X5. The only reason BMW did not badge it as an M is because it has an automatic transmission, a no-no for any M car. The 4.6is has a 340hp V8 and will do 0-60 in about 6 seconds, so it's certainly a match for our Rexs from the line (if we're having a bad day). Even the 4.4L X5 sports almost 300hp so it's no slouch either!

  8. #7
    Registered User WRXed's Avatar
    Join Date
    Nov 2001
    Location
    Macon, GA
    Posts
    3,073
    Originally posted by 2001S4
    Keep in mind that the X5 is not a slow truck to begin with. I do believe they were releasing an "M" version of the truck (it may not have been labeled M though). I think it was supposed to share the V8 engine with the M5. If that is the case and you lost to one, than don't feel so bad. However, check out your car and find out what is wrong. Loosing boost definitely sucks.
    ditto that. The X5 is a pretty quick little sucker, ok BIG sucker. Anyway, I'd definitely check out your low boost problem. You obviously shouldn't have had that kind of trouble keeping up with your setup.
    All those who believe in psychokinesis, raise my hand. - Steven Wright

    Moderator, of the "Super" persuasion

  9. #8
    Moderator Penguinking's Avatar
    Join Date
    Nov 2001
    Location
    Houston, TX / Athens, GA -at the same time!
    Posts
    2,472
    I Support ClubWRX
    it wasn't the "M" X5 for sure - it was the normal 3.0 or whatever the regular x5 is. (still fast for an suv, no doubt)
    Silver 911
    WRX's older brother

  10. #9
    Registered User
    Join Date
    May 2002
    Posts
    899
    Well the 4.6is is actually a hell of a sleeper, there's no M-badging anywhere (cause it's not technically an M car). The differences from the 3.0 and the 4.4 on the exterior are:

    1) 20inch ridiculously wide wheels.
    2) A slight body kit.
    3) A different dual outlet exhaust.
    4) 14 inch (god that's bigger than the wheels on some crap- box cars!) front disc brakes.

  11. #10
    Registered User AmSFighter's Avatar
    Join Date
    Jan 2002
    Location
    Chicago
    Posts
    219
    My dad just picked up his 4.6is from momentum beemer last night. FOCK load of money for a car and a pretty long wait period if you don't want to pay the exhorbitant "dealer adjustment fees." Apparently its very fast. I personally got to drive around a loaner 4.4i when I visited my parents last winter after dropping off their other beemer for service, I've gotta say that the 4.4i is pretty quick in itself, I'd imagine with the extra hp and torque, the 4.6is would be faster.
    Last edited by AmSFighter; 06-19-2002 at 09:01 PM.
    2006 Porsche Cayman S

  12. #11
    Registered User Nexus6's Avatar
    Join Date
    Jun 2002
    Location
    O.C., Ca
    Posts
    1,748
    I want a X5!
    La Fee Verte
    Subaru 2002 Impreza WRX Sedan

  13. #12
    Registered User
    Join Date
    May 2002
    Posts
    899
    Originally posted by AmSFighter
    My dad just picked up his 4.6is from momentum beemer last night.
    SOLID!!!

    My dad has a 740i and a 996 Porsche 911 Cabriolet. German cars rule! For now my WRX kicks MORE than enough ass

  14. #13
    Registered User WRXed's Avatar
    Join Date
    Nov 2001
    Location
    Macon, GA
    Posts
    3,073
    Originally posted by Schaf100
    4) 14 inch (god that's bigger than the wheels on some crap- box cars!) front disc brakes.
    my car has 13" wheels...
    All those who believe in psychokinesis, raise my hand. - Steven Wright

    Moderator, of the "Super" persuasion

  15. #14
    Registered User
    Join Date
    Jun 2002
    Location
    newport beach, ca
    Posts
    18
    ok, original poster with the vishnu stage 0... did you make sure your boost controller is not loose? if it comes loose and opens up, the boost will go down.

    if your boost is really at 8, give it about 2 full turns clockwise (tighen it), and it should be back up to a decent level (15.5 psi or so). you do not want to overboost it to 16 or 17 psi, as it is bad for the stock turbo, and it really won't give you that much improvement over the recommended 15.5psi (1.05 on the stock boost guage).

    if your boost is still low after adjusting it, you probably have a leak in your boost line somewhere. i know that area gets super hot, so make sure the hose hasn't broken or come loose from the heat.

    good luck!
    -eric m.

  16. #15
    Moderator Penguinking's Avatar
    Join Date
    Nov 2001
    Location
    Houston, TX / Athens, GA -at the same time!
    Posts
    2,472
    I Support ClubWRX
    Originally posted by eric m.
    ok, original poster with the vishnu stage 0... did you make sure your boost controller is not loose? if it comes loose and opens up, the boost will go down.

    if your boost is really at 8, give it about 2 full turns clockwise (tighen it), and it should be back up to a decent level (15.5 psi or so). you do not want to overboost it to 16 or 17 psi, as it is bad for the stock turbo, and it really won't give you that much improvement over the recommended 15.5psi (1.05 on the stock boost guage).

    if your boost is still low after adjusting it, you probably have a leak in your boost line somewhere. i know that area gets super hot, so make sure the hose hasn't broken or come loose from the heat.

    good luck!
    my name is "Robert", not "original poster"

    anyway, the max boost is 10, not 8, and the mbc's position hasnt changed since i had first installed it, so something must be wrong in the lines to make it run 10 when it used to run 15.5. i've got some extra hose lying around so i'm gonna replace the mbc hosing.
    Silver 911
    WRX's older brother

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •