AWD Launch
Results 1 to 15 of 15

This is a discussion on AWD Launch within the Comparison: WRX vs World forums, part of the Community - Meet other Enthusiasts category; Me against a hatch with a LS swap on nitrous. I set him out a car... and it was over ...

  1. #1
    Registered User
    Join Date
    Jul 2003
    Location
    Houston
    Posts
    68

    AWD Launch

    Me against a hatch with a LS swap on nitrous. I set him out a car... and it was over the second I let go of the clutch.

    http://www.funkyfootwork.com/bigturkey.wmv

    I'd like to give thanks to AZScoobie on NASIOC for that beautiful launch right there.

    Also, you need to download the KS codec to view it, or have the Windows Media Player 9. If you don't have it, just search for KS CODECS on google and download them, they're free.
    If anything's worth doing.. it's worth doing right.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Banned Mili727's Avatar
    Join Date
    Jun 2002
    Location
    Ga
    Posts
    3,114
    Ok? The video is like 7 seconds long and just shows your launch.

  4. #3
    Registered User
    Join Date
    Jul 2003
    Location
    Houston
    Posts
    68
    Yep. Hence, that's why I said it was over the second I let go of the clutch. That's why it's called "AWD Launch"
    If anything's worth doing.. it's worth doing right.

  5. #4
    Banned Mili727's Avatar
    Join Date
    Jun 2002
    Location
    Ga
    Posts
    3,114
    Wow you replied in .02 seconds.

  6. #5
    Registered User
    Join Date
    Jul 2003
    Location
    Houston
    Posts
    68
    Originally posted by Mili727
    Wow you replied in .02 seconds.
    It's that perfect reaction time, with my mountain cat agility
    If anything's worth doing.. it's worth doing right.

  7. #6
    Ike
    Ike is offline
    Registered User Ike's Avatar
    Join Date
    Apr 2003
    Location
    Milwaukee, Wi.
    Posts
    764
    This is a joke right... The video I watched showed the lining up, reving up, then skip and you're ahead of him. NO LAUNCH!

  8. #7
    Registered User
    Join Date
    Jul 2003
    Location
    Houston
    Posts
    68
    You need to either have Media Player 9 or DL those KS codecs. Same thing happened to me the first time I DLed it.
    If anything's worth doing.. it's worth doing right.

  9. #8
    Ike
    Ike is offline
    Registered User Ike's Avatar
    Join Date
    Apr 2003
    Location
    Milwaukee, Wi.
    Posts
    764
    I still think it's just a sick joke, to make me think I'm going insane

  10. #9
    Registered User BassMan097's Avatar
    Join Date
    May 2003
    Location
    North Jersey
    Posts
    639
    that was a nice launch...what did you go at?? You dump it?
    2004 R32: 220 whp

    For Sale: 2003 wrx
    376 whp @ 22 psi, 93 octane

    Pics:
    http://www.cardomain.com/id/badassrex

  11. #10
    Registered User renichms's Avatar
    Join Date
    Jun 2003
    Location
    Birmingham, AL
    Posts
    1,777
    No flaming hoops for me...works or doesn't, first time. Didn't work.

    RN

  12. #11
    Registered User
    Join Date
    Jul 2003
    Location
    Houston
    Posts
    68
    If anything's worth doing.. it's worth doing right.

  13. #12
    Registered User Th3Franz's Avatar
    Join Date
    May 2003
    Location
    Wisconsin
    Posts
    2,766
    Why do people use crazy and obscure codecs? I never understand that. Just use divx or some known codec. A pet peeve of mine since I spend way too much time tracking down stupid codecs.
    - F r a n z
    Bucky with teh lime powah!

  14. #13
    Registered User DeeezNuuuts83's Avatar
    Join Date
    Dec 2002
    Location
    Southern California
    Posts
    199
    Hey Big Turkey...

    It seems like you've got your AWD launch down pretty well. Is your clutch stock or aftermarket? And if it's stock, how's it doing? And if not, did you replace it just to get a better one or because you wore it down?

  15. #14
    Registered User
    Join Date
    Jul 2003
    Location
    Houston
    Posts
    68
    Originally posted by DeeezNuuuts83
    Hey Big Turkey...

    It seems like you've got your AWD launch down pretty well. Is your clutch stock or aftermarket? And if it's stock, how's it doing? And if not, did you replace it just to get a better one or because you wore it down?
    I'm on a stock clutch, and it's doing great. Right after a launch like that, if you do it correctly, it shouldn't burn your clutch at all. The first few times I slipped it too slowly, and it rode the hell outta the clutch and the whole car smelled like it. But after i got it down, there isn't even a hint of clutch.
    If anything's worth doing.. it's worth doing right.

  16. #15
    Registered User wrx420's Avatar
    Join Date
    Jul 2003
    Location
    Monroe, CT
    Posts
    137
    Didn't see your video, but if it's anything like the other guy's on that thread... NICE!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •