myWRX vs. 2G dsm *VID*
Results 1 to 9 of 9

This is a discussion on myWRX vs. 2G dsm *VID* within the Comparison: WRX vs World forums, part of the Community - Meet other Enthusiasts category; I'm stage 4 FMIC against what was probably a stock turbo'd, bolt on'd 2G DSM. I can't launch the car ...

  1. #1
    Registered User InfamousDX's Avatar
    Join Date
    Jan 2003
    Location
    Bergen, NJ
    Posts
    900

    myWRX vs. 2G dsm *VID*

    I'm stage 4 FMIC against what was probably a stock turbo'd, bolt on'd 2G DSM. I can't launch the car because the clutch is all but gone and doesn't hold anything above what boost I was at (16 psi.. I was tuned for 22.5)). So my car is probably a low 13 second car with a decent trap speed as it sits right now. You'll love me using our AWD system like I was grandma leaving a stoplight

    http://infamousdx.com/wrx/infamousdx_vs_dsm.wmv

    Oh and sorry it's a **** video... just wanted to share what went down at the local races earlier.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User SERacing's Avatar
    Join Date
    Feb 2003
    Location
    Staten Island, NY
    Posts
    1,819
    Yeahhhhh Mike Next time hit me up when you're going.
    SIRacing.Net

    Originally posted by yermom
    heh, fairlady

    does not sound like a fast car, no wonder they changed the name for the US market

  4. #3
    Boba Fett BrianH's Avatar
    Join Date
    Oct 2003
    Location
    Way up high.
    Posts
    17,923
    cool, what kind of mods on the 2g?

  5. #4
    Registered User StoplightWarrior's Avatar
    Join Date
    Jun 2003
    Location
    CA
    Posts
    2,364
    haha

    1. That was the weakest launch evar

    2. That eclipse was so slow!!

    3. Good kill.
    2003 SRT-4

  6. #5
    Registered User InfamousDX's Avatar
    Join Date
    Jan 2003
    Location
    Bergen, NJ
    Posts
    900
    1. ya damn right!! doesn't even qualify as a launch i don't think
    2. yup.. probably stock turbo with bolt ons
    3. tunk u.

    John... I'll hit you up next time.

  7. #6
    Registered User E-Wrex's Avatar
    Join Date
    May 2005
    Location
    Portland
    Posts
    720
    silly mitsus, tricks are for kids.
    My poor tranny!... someone sell me an aspen white 06 sti.

    Mods

  8. #7
    Registered User BamBooI's Avatar
    Join Date
    Oct 2001
    Location
    Milky Way Galaxy
    Posts
    1,026
    lol nice launch. Pretty hard shift from 1st to 2nd. also your tach is in the middle. did you swap out clusters? What kind of exhaust do you have b/c it is loud on the inside so it must be crazy loud on the outside.
    Last edited by BamBooI; 08-07-2005 at 03:39 PM.

  9. #8
    Moderator timber's Avatar
    Join Date
    Apr 2005
    Location
    St. George, Ut.
    Posts
    3,718
    I Support ClubWRX
    Hahaha.. he had a three day headstart..
    "Never Launched"
    Dougie
    - Founder, 250,000 mile club
    -5,000 posts

  10. #9
    Registered User InfamousDX's Avatar
    Join Date
    Jan 2003
    Location
    Bergen, NJ
    Posts
    900
    BamBooI: haha thanks. yea i flat shift in all gears cuz i have UTEC launch control and it rev limits to 5K so it works well and holds boost in between shifts. I have an exhaust cutout... that's why it's so loud. a QTEC actually. And I have an STI cluster in my 03 wrx now

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •