2013 subaru sti stage 2 problem (limp mode maybe)
+ Reply to Thread
Results 1 to 9 of 9

This is a discussion on 2013 subaru sti stage 2 problem (limp mode maybe) within the Clubwrx Website/Forum Support - Report Errors forums, part of the Community - Meet other Enthusiasts category; My 2013 STI is now stage 2. I have the BOV, invidia exhaust, invidia dp, cobb intake, and the accessport ...

  1. #1
    Registered User
    Join Date
    Jan 2014
    Posts
    4

    2013 subaru sti stage 2 problem (limp mode maybe)

    My 2013 STI is now stage 2. I have the BOV, invidia exhaust, invidia dp, cobb intake, and the accessport 003. Everything was on and working well for about an hour. I was driving with my friend and basically everything turned of. Power steering turned off, oil light came on, and the car shut off. I don't know why this is happening. I tried reflashing to eco mode and stage 2. It works for about 5 minutes then it happens again. Im almost certain this isn't a problem with anything that I bought from Cobb im just confused. From what I've heard, it may be going into limp mode, which doesn't make sense. Some of the forums are saying it could be a MAF sensor issue. Maybe an o ring on that. Or i just need to clean it. Any suggestions?

    Thank you,

    Grayson

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Jan 2014
    Posts
    4
    My accessport also said there are no trouble codes to be found

  4. #3
    MAINEiac 11blackSTi's Avatar
    Join Date
    Nov 2012
    Location
    Land of the Port. ME
    Posts
    2,904
    I Support ClubWRX
    You will know you are in limp mode if a CEL is on, DCCD on the dash will constantly bink, traction control light turns organge, and cruise control is blinking.

    Have you read the CEL with your AP? If so, what does it say? Typically LIMP mode won't turn the car completely off. I would suggest you get the car looked at ASAP.

  5. #4
    and the Funky Bunch Calvinball's Avatar
    Join Date
    Jan 2012
    Location
    Philly Area
    Posts
    5,980
    This is the wrong subforum for this type of question, and you don't need more than one thread. PM a mod to merge them.

    That way everyone trying to help you will be reading the same things.
    - Will
    First Mods: What to do and what not to do
    Current Car: 2014 Golf TDI
    Previous Cars:2012 WRB WRX Hatch, 2004 RSX-S, 1998 Grand Prix GTP
    "Isn't it amazing how smart you feel when you just aren't being stupid?"

  6. #5
    Registered User wrxnguyen's Avatar
    Join Date
    Jul 2013
    Location
    714 Orange County
    Posts
    331
    What map are you running? It could be a fuel cut off because your overboosting

  7. #6
    MAINEiac 11blackSTi's Avatar
    Join Date
    Nov 2012
    Location
    Land of the Port. ME
    Posts
    2,904
    I Support ClubWRX
    It was his BOV. Not installed correctly.

  8. #7
    Registered User ProZach626's Avatar
    Join Date
    Aug 2008
    Location
    St. Louis Metro East, on the Illinois side, but not the really bad Illinois side, but also not the really good side.
    Posts
    326
    Hence why you don't put a freaking BOV on these cars...

  9. #8
    Registered User
    Join Date
    Nov 2013
    Posts
    30
    Stage 2 with stock turbo there is no reason to run a BOV

    Sent from my Nexus 5 using Tapatalk

  10. #9
    Registered User
    Join Date
    Nov 2013
    Posts
    30
    I have an 07 that I have been stage 2 since 8-900 miles. Now have 36k miles and absolutely no issues. Stage 2 can be reliable. Is the downpipe catted ? What Map ?

    Sent from my Nexus 5 using Tapatalk

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •