Sheepyhollow's 14' WRX Build Thread
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 16

This is a discussion on Sheepyhollow's 14' WRX Build Thread within the Builds forums, part of the Tech & Modifying & General Repairs category; Sheepy hollow's 14' Subaru WRX Hatchback Build Thread The Backstory About three weeks ago, I decided to do a datalog ...

  1. #1
    Registered User SheepyHollow's Avatar
    Join Date
    Jul 2016
    Location
    New Jersey
    Posts
    34

    Sheepyhollow's 14' WRX Build Thread

    Sheepyhollow's 14' Subaru WRX Hatchback Build Thread

    The Backstory
    About three weeks ago, I decided to do a datalog just to run some tests. Car is running fine, get into Third Gear, start the datalog, go to redline.. stop the log and the car seems fine. I turn around, drive about a mile, and the check engine light comes on, flashing cruise control light, oil light is on, the whole nine. Run the code, i get P0011, P0021, which if you're familiar with this code, it's usual a blown motor. With 6 months left on my warranty, I figured I would take my chances and see if they will cover it. Of course, they didn't and quoted me $10,000 for a new Short Block with possibilities of needing new left and right heads.

    The Aftermath
    Knowing I cannot afford $10,000 out of pocket, I decided, it was time to just go with a Build. I went up to my local tuner shop, talked to the tuner there for sometime, and decided to get a new 2.5 Block. STi Forged Crankshaft, STi Forged Rods, topped off with Manley Pistons. The motor is rated to hold 500AWHP.

    Prior Modifications to the Car Before Motor Failure
    The prior mods done to my car before the motor failure were/are: Tsudu Cat-Back Exhaust, Cobb SF Intake, Cobb Accessport, Killer B Short Throw Shifter.

    I will be posting pictures as updates and let you know how things are going if you are interested.

    Here is a picture of the car at its glory running strong

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User SheepyHollow's Avatar
    Join Date
    Jul 2016
    Location
    New Jersey
    Posts
    34
    Got the car back from the dealer earlier! At about 7:00PM EST
    As soon as I got the vehicle parked where I wanted it. I popped the hood to just
    see how well they put the motor back together after taking it apart to find the cause
    of engine failure. I noticed two things which I am very un-happy about. After paying
    for the Diagnostics to figure out the cause, which happened to be Rod Bearing Failure,
    they also made me pay to re-assemble the motor, I get the car back with a broken bolt
    in the Turbo Inlet.



    Next I notice the A/C Belt wasn't returned to me. I can understand them not installing it
    back onto the car because they are Stretch belts and really shouldn't be re-used. But still,
    if I pay 400 bucks for you to re-assemble to motor, I expect it to be back the way I brought
    it there. I am more pissed about the broken bolt in my Turbo Inlet!



    Other than that, we started pulling off parts for when the new motor arrives.


    Last edited by SheepyHollow; 07-28-2016 at 08:10 PM.

  4. #3
    Registered User SheepyHollow's Avatar
    Join Date
    Jul 2016
    Location
    New Jersey
    Posts
    34
    What's been going on!?
    Damn guys, sorry for such a delayed Update post!
    It's been pretty crazy thus far throughout this process.
    Got into a big dispute with the dealer, other **** went down.
    It was a big mess.

    BUT, all in all. Everything is back on track and the car should be
    ready for startup as soon as within the next couple of days!
    I'm excited and ****!


    The motor is out!


    Removed the Oil Pan, and talk about Bearing Failure...



    Head off for inspection. They look great, ended up doing a DIY Resurface of the deck. No warp/bends thank god.


    The new Stage 1 STi Block arrived!


    <3 Manley Pistons <3


    Cams Reinstalled


    Re-assembly almost complete!
    Last edited by SheepyHollow; 07-30-2016 at 09:46 AM.

  5. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  6. #4
    Registered User SheepyHollow's Avatar
    Join Date
    Jul 2016
    Location
    New Jersey
    Posts
    34
    RESERVED SPACE 3

  7. #5
    For External Use Only irickchad's Avatar
    Join Date
    Sep 2013
    Location
    WV
    Posts
    3,738
    I Support ClubWRX
    What kind and how often often were you doing oil changes when it crapped out on you? Who tuned it? Seems like a fairly new car for it to have crapped out and Subaru deny a claim on an S1 car. Sorry about your luck!
    I have an STi with an intake and no tune, I never change my oil, and my wheel spacerz are mad tyte.

  8. #6
    Registered User NG WRX STI's Avatar
    Join Date
    Jul 2015
    Location
    Langhorne
    Posts
    125
    That's messed up man....
    BooSTIn19ALLDay

    Don't believe anything you hear and half the things you see!
    ... one that jumps to conclusions often splatters at the bottom of confusion...

  9. #7
    Registered User SheepyHollow's Avatar
    Join Date
    Jul 2016
    Location
    New Jersey
    Posts
    34
    irickchad, the oil was a bit dark/dirty looking. I think I was at about 4 months between the last oil change and when the motor blew. Mileage wise, I still had like 700 miles left before oil change.

    Also, sorry for the long break of not updating this build thread. A lot has come up since the last post. I should have more added to the posts a little later on tonight. I'll prob Bump this thread once I update it.

  10. #8
    lit fam XJman's Avatar
    Join Date
    Feb 2015
    Location
    At work
    Posts
    5,667
    Call the dealer give them pictures I assume the car was towed back and forth? It's extremely hard to identify oil condition from color, unless it's obvious like water in the oil.

    Good luck with the future of the car. I hope things work out.

    Sent from my Nexus 6 using Tapatalk
    All? NO ALL!

  11. #9
    Registered User SheepyHollow's Avatar
    Join Date
    Jul 2016
    Location
    New Jersey
    Posts
    34
    I sent them plenty of pictures, not only did they break a bolt and not give me back a belt...

    Lets make a list here:
    They broke the bolt that holds the dip stick in place
    They lost one of my down-pipe nuts
    They broke both negative wires on each head to the chassis.
    I don't think I am forgetting anything.

    When i contacted them about it, they said that they just "assumed" I was going to call back and tell them to put in a new motor and heads. So they would have replaced those parts. But since I called and said I was going to just get a new block and build it, they are saying that they wont even give me anything that they broke, nor any money back on the reassembly fee of the motor with them taking poor care of my property. Just going to go after corporate and have them deal with it and have them complain to the dealer.

    BUT on other news! New updated will be added to posts above tonight after I am finished playing Overwatch haha.

    EDIT: and must I say the heads off my wrx motor are completely fine. So they would have had my pay an extra like 1300 bucks for new L and R heads.

  12. #10
    lit fam XJman's Avatar
    Join Date
    Feb 2015
    Location
    At work
    Posts
    5,667
    Get a lawyer, they have no legal right to keep the parts off your car.

    Sent from my Nexus 6 using Tapatalk
    All? NO ALL!

  13. #11
    Registered User SheepyHollow's Avatar
    Join Date
    Jul 2016
    Location
    New Jersey
    Posts
    34
    Well that's what we are going to do if Corporate doing do anything about it first. I asked the guy if at the least he could provide me the hardware they broke and lost, and his words were "ill see what I can do" I never heard anything back from him yet. Already me and my buddy have gotten the necessary hardware we needed anyway, as well as tap and dyeing the broken bolt on the turbo inlet. We were going to do the same with the dipstick bolt but as its incorporated into the head (left head i believe) we didn't want to take a chance.

  14. #12
    lit fam XJman's Avatar
    Join Date
    Feb 2015
    Location
    At work
    Posts
    5,667
    Yeah that back bolt is a turd. I broke mine off a bit back.

    Sent from my Nexus 6 using Tapatalk
    All? NO ALL!

  15. #13
    Registered User SheepyHollow's Avatar
    Join Date
    Jul 2016
    Location
    New Jersey
    Posts
    34
    Yeah they are known to break, but still.. if you break it, they should have replaced it and fixed it them self regardless.

  16. #14
    Registered User SheepyHollow's Avatar
    Join Date
    Jul 2016
    Location
    New Jersey
    Posts
    34
    BUMP added updated pics!

  17. #15
    Registered User SheepyHollow's Avatar
    Join Date
    Jul 2016
    Location
    New Jersey
    Posts
    34
    Just wanted to update everyone! The car is running. Actually 150 miles in so far.
    Using a base map from my Tuner, no Fine Knock or Feedback Knock readings. Been
    staying a 0 throughout drives. DAM has been at a steady 1.0

    Can't wait to break it in and get it Pro-Tuned.
    I will post a video tomorrow most likely.
    2014 Subaru WRX Hatchback
    STi Block w/Manley Pistons
    ARP Headstuds
    Invidia Cat-less Divorced Downpipe matched up to a Tsudu N1 Cat-back Exhaust
    Cobb SF Intake
    AWHP/TQ will be listed once new motor is broken in and gets protuned!

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •