Need some help
Results 1 to 3 of 3

This is a discussion on Need some help within the Builds forums, part of the Tech & Modifying & General Repairs category; I have a 09 wrx. I think something is wrong with my turbo it's not boosting and and something sounds ...

  1. #1
    Registered User
    Join Date
    Jul 2013
    Location
    TN
    Posts
    8

    Need some help

    I have a 09 wrx. I think something is wrong with my turbo it's not boosting and and something sounds deep like a deep rumble. I put a new blow off valve on so not sure if that has anything to do with this or not. Any body got any info?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator rage-wrx's Avatar
    Join Date
    Aug 2010
    Location
    Yonkers/NYC
    Posts
    10,790
    I Support ClubWRX
    Get rid of the blow off valve.
    T0ny
    2011 WRX
    2012 FXT

    The Big 2011/2012 Mod Thread


    Ooh,hang on. That is the throb of a turbocharged flat four engine. A sound which,all over the world,heralds the imminent arrival of a moron - JC.

  4. #3
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,709
    I Support ClubWRX
    Before valve, fine
    After valve, issue

    That correct?
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning, LLC

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •