'02 wrx wagon- dd/side-project - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 22 of 22

This is a discussion on '02 wrx wagon- dd/side-project within the Builds forums, part of the Tech & Modifying & General Repairs category; Everything yesterday went well. Installed radiator this morning before work and start it up. Ran perfect, then after burping the ...

  1. #16
    Registered User
    Join Date
    Feb 2013
    Location
    Salem, VA
    Posts
    35
    Everything yesterday went well. Installed radiator this morning before work and start it up. Ran perfect, then after burping the cooling system, I decided to check for leaks. Boy was there a leak, my Mishimoto radiator was leaking bad. Sucks as they are on back order till August so I bought a factory replacement and new hoses today and will install before work tomorrow. I can see why shops charge so much to do this job, very time consuming. I worked on the car 14 hours yesterday, but this is the first dohc engine I have worked on so not too bad. The Company23 tools worked very well.

    Now to get my up-pipe coated and the gaskets to get it installed and put in my Kartboy lock down bolts.
    '02 Midnight Black Pearl WRX wagon, 5-speed 207k miles
    factory short throw, triple gauge pod, premium sound
    Mishimoto radiator, drilled and slotted rotors

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User
    Join Date
    Feb 2013
    Location
    Salem, VA
    Posts
    35
    Turns out my radiator wasn't leaking, just water coming out of the core from being rinsed off. PS valve cover still appears to be leaking as I see smoke every so often.
    '02 Midnight Black Pearl WRX wagon, 5-speed 207k miles
    factory short throw, triple gauge pod, premium sound
    Mishimoto radiator, drilled and slotted rotors

  4. #18
    Registered User
    Join Date
    Feb 2013
    Location
    Salem, VA
    Posts
    35
    Upper radiator hose looked funny during t-belt job and I seem to be losing coolant with evidence of a leak where it attaches to the rad so I ordered a set of Samco black silicone hoses and t-bolt clamps.
    '02 Midnight Black Pearl WRX wagon, 5-speed 207k miles
    factory short throw, triple gauge pod, premium sound
    Mishimoto radiator, drilled and slotted rotors

  5. #19
    Registered User
    Join Date
    Feb 2013
    Location
    Salem, VA
    Posts
    35
    New hoses on. Upper was leaking pretty good at the engine side. Had a trail of drips down to the oil filter.
    '02 Midnight Black Pearl WRX wagon, 5-speed 207k miles
    factory short throw, triple gauge pod, premium sound
    Mishimoto radiator, drilled and slotted rotors

  6. #20
    Registered User
    Join Date
    Feb 2013
    Location
    Salem, VA
    Posts
    35
    Have not done much to the car lately. Replaced the afta-maf hose with a samco piece as mine started to split. Noticed the ps cv inner boot has split and starting noticing a fuel smell Christmas day. Planning on replacing the fuel lines and all rubber hoses in the intake manifold area along with the turbo inlet once I get tax returns.
    '02 Midnight Black Pearl WRX wagon, 5-speed 207k miles
    factory short throw, triple gauge pod, premium sound
    Mishimoto radiator, drilled and slotted rotors

  7. #21
    zax
    zax is offline
    umad?erator zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    11,666
    I Support ClubWRX I Support ClubWRX
    Oooo I like those BBS RKs!
    2015 CWP WRX STi on order ... But how did I get roped back into an EJ motor?!
    Zax' Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    The REAL 'WTF Tuning?!' Progenitor
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero | Blobeye Synd. #Tree-Fiddy
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  8. #22
    Registered User schufflerbot's Avatar
    Join Date
    Dec 2013
    Location
    Houston, TX
    Posts
    87
    great thread so far, needs moar pics though!!11!

    you've got bigger balls than i do, i sent my car to the dealership to have the timing belt and oil cooler o ring replaced.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •