2011 STi Sedan Build Thread (400+whp) - Page 34
Page 34 of 43 FirstFirst ... 2425262728293031323334353637383940414243 LastLast
Results 496 to 510 of 633

This is a discussion on 2011 STi Sedan Build Thread (400+whp) within the Builds forums, part of the Tech & Modifying & General Repairs category; Originally Posted by Mikie13 Seems like the problem was there from the start...so hopefully the shop owns up to it ...

  1. #496
    Registered User Januch09's Avatar
    Join Date
    Jan 2012
    Location
    NJ
    Posts
    730
    Quote Originally Posted by Mikie13 View Post
    Seems like the problem was there from the start...so hopefully the shop owns up to it to make it right...
    So far it's not looking like it, but we'll see...
    2011 STi----------PTE6266--------Fully Built---------ETS--------E85

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #497
    Registered User Januch09's Avatar
    Join Date
    Jan 2012
    Location
    NJ
    Posts
    730
    Okay so the motor is toast. Oil pan is full of metal shavings, most likely from a bearing. Motor has roughly 1k miles on it. The blue smoke was coming from the heads. Most likely a seal, which I'm hoping that's all it is.

    Motor is back at Rallispec getting ripped out and diagnosed.

    I'll keep you guys updated with what is found.

    Btw, if anyone knows anyone that wants to buy parts from my last build, please let me know, I need this stuff sold asap!!

    FS: (For Sale) 2011 STi Part-Out!!! - NASIOC
    2011 STi----------PTE6266--------Fully Built---------ETS--------E85

  4. #498
    Registered User Ashesofthewake's Avatar
    Join Date
    Oct 2009
    Location
    CNJ
    Posts
    104
    Quote Originally Posted by Januch09 View Post
    Okay so the motor is toast. Oil pan is full of metal shavings, most likely from a bearing. Motor has roughly 1k miles on it. The blue smoke was coming from the heads. Most likely a seal, which I'm hoping that's all it is.

    Motor is back at Rallispec getting ripped out and diagnosed.

    I'll keep you guys updated with what is found.

    Btw, if anyone knows anyone that wants to buy parts from my last build, please let me know, I need this stuff sold asap!!

    FS: (For Sale) 2011 STi Part-Out!!! - NASIOC
    That really sucks to just keep getting shafted on motors. That feeling you get when you invest that much time and money into something and it just isn't right is the worst. Has Rallispec figured out what went wrong yet?

  5. #499
    Registered User Ashesofthewake's Avatar
    Join Date
    Oct 2009
    Location
    CNJ
    Posts
    104
    Double Post.

  6. #500
    Registered User Januch09's Avatar
    Join Date
    Jan 2012
    Location
    NJ
    Posts
    730
    Quote Originally Posted by Ashesofthewake View Post
    That really sucks to just keep getting shafted on motors. That feeling you get when you invest that much time and money into something and it just isn't right is the worst. Has Rallispec figured out what went wrong yet?
    Yeah, it sure does suck. And no not yet.
    2011 STi----------PTE6266--------Fully Built---------ETS--------E85

  7. #501
    Registered User Januch09's Avatar
    Join Date
    Jan 2012
    Location
    NJ
    Posts
    730
    Okay so my motor suffered catastrophic bearing failure. We can't truly determine what caused it but there's a few things up in the air.

    The sleeves are fine, pistons are fine.

    Apparently something is messed up with the heads according to Rallispec. The heads are being sent to Headgames in NJ to be checked since they are the ones who built them. Once the heads are there, he will see what he finds and we'll go from there.

    So I need all new:
    -bearings
    -rods
    -piston rings
    -crank
    -heads?

    On top of that, Rallispec thinks the smoke was coming from the turbo seals and not the heads, so the turbo needs to be sent back out to PTE to get checked up on. Apparently they offer a really good warranty service, but with my luck, who the he** knows.

    I'll keep everyone posted.
    2011 STi----------PTE6266--------Fully Built---------ETS--------E85

  8. #502
    Registered User Januch09's Avatar
    Join Date
    Jan 2012
    Location
    NJ
    Posts
    730
    double post
    2011 STi----------PTE6266--------Fully Built---------ETS--------E85

  9. #503
    Registered User Januch09's Avatar
    Join Date
    Jan 2012
    Location
    NJ
    Posts
    730
    Hope everyone enjoyed their Holiday.

    Have a Happy New Year to you all and hopefully I'll have some better news with the car for the New Year!
    2011 STi----------PTE6266--------Fully Built---------ETS--------E85

  10. #504
    Registered User Januch09's Avatar
    Join Date
    Jan 2012
    Location
    NJ
    Posts
    730
    Hope everyone enjoyed their Holiday.

    Have a Happy New Year to you all and hopefully I'll have some better news with the car for the New Year!
    2011 STi----------PTE6266--------Fully Built---------ETS--------E85

  11. #505
    Registered User Ampliified's Avatar
    Join Date
    May 2012
    Location
    Warren Twp, NJ
    Posts
    782
    Good luck dude I really wanna see this car on the road!
    2012 DGM WRX - Stage Two 93 - Stink Eye Mob #908
    The Epic Life of Emily the WRX

  12. #506
    Registered User Januch09's Avatar
    Join Date
    Jan 2012
    Location
    NJ
    Posts
    730
    Quote Originally Posted by Ampliified View Post
    Good luck dude I really wanna see this car on the road!
    Thanks man and me too.
    2011 STi----------PTE6266--------Fully Built---------ETS--------E85

  13. #507
    Registered User Januch09's Avatar
    Join Date
    Jan 2012
    Location
    NJ
    Posts
    730
    No update, just thought I'd share a picture.

    2011 STi----------PTE6266--------Fully Built---------ETS--------E85

  14. #508
    Registered User Agron1979's Avatar
    Join Date
    Jul 2013
    Posts
    151
    I can't wait until you get it back on the road man....I hope everything goes well and you can get back behind that wheel asap. Happy New Years to you too!!!

  15. #509
    Registered User Januch09's Avatar
    Join Date
    Jan 2012
    Location
    NJ
    Posts
    730
    Quote Originally Posted by Agron1979 View Post
    I can't wait until you get it back on the road man....I hope everything goes well and you can get back behind that wheel asap. Happy New Years to you too!!!
    Thanks man. And I sure hope so too!
    2011 STi----------PTE6266--------Fully Built---------ETS--------E85

  16. #510
    Registered User Januch09's Avatar
    Join Date
    Jan 2012
    Location
    NJ
    Posts
    730
    Here's a bit of an update. Went to head games yesterday and saw the actual damage on the heads.

    Heads were starved of oil due to the spun bearing and lack of oil pressure after that. Almost everything was scored up from my recollection of metal that went through the heads. Cams and buckets are ruined. Guides were crooked/bent, scoring on the heads itself, etc.

    Valves were fine, springs were fine, port was fine.

    So after a long chat with Dave at Headgames, we decided to redo the heads mostly.
    -New GSC S2 Camshafts
    -New Beehive Springs and Retainers
    -New Guides
    -New Valve Seals
    -Plus the obvious cleaning and water tank work

    Heads should be done within the day or so and shipped back to Rallispec.

    As far as the motor goes:
    -Cosworth Rings
    -OEM Heat-Treated Crank
    -Pauter X-Beam Rods
    -King Main & Rod Bearings
    -Cosworth High Performance Head Gaskets .78mm
    -OEM Engine Gasket Kit
    -Deglaze Cylinder Walls

    Still no word from PTE about the turbo. Kinda getting aggravated about that.

    Other then that, everything should be coming back together shortly.
    2011 STi----------PTE6266--------Fully Built---------ETS--------E85

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •